Aura 2: Packages

Aura 2 2.1
Volumetric Lighting & Fog for Unity3D
Packages
Here are the packages with brief descriptions (if available):
N Aura2API
N UnityEngine
Generated by doxygen 1.8.14


Aura 2: Aura2API Namespace Reference

Classes | Enumerations
Aura2API Namespace Reference

Classes

class | AmbientLightingCommonDataManager
Handles the ambient lighting data More...
class | Aura
Collection of functions related to the Aura system
class | AuraBaseSettings
Base injection settings for the data computation More...
class | AuraCamera
Main component to assign on a GameObject with a Camera component More...
class | AuraLight
Component to assign on a GameObject with a Light component if you want this Light to be taken into account in Aura More...
class | AuraPreset
Collection of functions related to presets
class | AuraQualitySettings
Quality settings for Aura2 computation More...
class | AuraResourcesCollection
class | AuraSprite
Component allowing the sprites to work with the Aura system More...
class | AuraUtility
Collection of useful functions
class | AuraVolume
Component allowing the volume injection of density/scattering/light More...
class | CameraExtensions
Static class containing extension for Camera type
class | ColorCircularPickerAttribute
Custom attribute for enabling circular picker on Color properties More...
class | CommonDataManager
Handles the lights' and volumes' commond data managers More...
class | CullableObject
Class to inherit from when using an ObjectCuller More...
class | CustomGizmo
Collection of static functions for drawing custom Gizmos in the Editor
struct | DirectionalLightParameters
Struct containing parameters of a directional AuraLight More...
class | DirectionalLightsManager
Manager that handles directional AuraLights More...
class | DirectionalShadowDataCollector
Texture2DArray composer used for collecting directional shadow data maps More...
struct | DynamicNoiseParameters
Collection of parameters for 4D dynamic noise mask to be used in a volume More...
class | FloatExtensions
Static class containing extension for int type
class | Frustum
Ranged camera frustum inside which the volumetric data will be computed More...
class | FrustumCuller
Culls candidate objects according to the camera frustum
class | FrustumParametersEnumExtensions
Collection of extension functions for FrustumParametersEnum objects
class | FrustumSettings
Collection of settings for the data computation More...
struct | FrustumSettingsParameters
Collection of settings defining the computation of the volumetric data More...
class | FrustumSettingsToId
Collects all the settings and compute the flag Id to be used as kernel id of the computeDataComputeShader More...
class | GenericExtensions
Static class containing extension for generic type
class | IntExtensions
Static class containing extension for int type
struct | LevelsData
Ordered struct of Levels operation parameters to be sent to the compute shader More...
struct | LevelsParameters
Collection of parameters for Levels adjustement. Similar to the same tool in Photoshop. More...
class | LightHelpers
Collection of functions/variables related to Light objects
class | LightsCommonDataManager
Handles the lights' registration and maps collection More...
class | MathHelpers
Collection of function/variables related to maths
class | Matrix4X4Extensions
Collection of extension functions for Matrix4x4 objects
struct | MatrixFloats
Ordered struct of Vector4 representing a matrix to be sent to the compute shader More...
class | ObjectExtensions
Collection of extension functions for Object objects
class | ObjectsCuller
Culls candidate objects according to the ranged camera frustum and puts an array of visible objects at disposal
struct | PointLightParameters
Struct containing parameters of a point AuraLight More...
class | PointLightsManager
Manager that handles point AuraLights More...
class | ShadowmapsCollector
Texture2DArray composer used for collecting shadow maps More...
struct | SphericalHarmonicsCoefficients
Struct containing spherical harmonics coefficients to use probes in shaders More...
class | SphericalHarmonicsExtensions
Static class containing extension for spherical harmonics
struct | SphericalHarmonicsFirstBandCoefficients
Struct containing spherical harmonics coefficients to use probes in shaders More...
struct | SpotLightParameters
Struct containing parameters of a spot AuraLight More...
class | SpotLightsManager
Manager that handles spot AuraLights More...
class | StringExtensions
Static class containing extension for string type
class | SwappableRenderTexture
Double buffering render texture More...
class | Texture2DArrayComposer
Builds a Texture2DArray out of a collection of Textures More...
struct | Texture2DMask
Texture2D mask to be used in a AuraVolume More...
class | Texture3DAtlasComposer
Compose a Texture3D out of several Texture3Ds
class | Texture3DExtensions
Extensions for Texture3D object so we can just invoke functions on them
struct | Texture3DMask
Texture3D mask to be used in a AuraVolume More...
class | Texture3DPreviewAttribute
Attribute enabling Texture3D preview in a Monobehaviour component in the Inspector More...
class | TextureBuffers
Collection of texture buffers which contain the computed volumetric data More...
struct | TextureMaskData
Ordered struct of texture mask parameters to be sent to the compute shader More...
struct | TransformParameters
Used for transforming reference position for textures/noise inside volumes More...
class | Vector3Extensions
Static class containing extension for Vector3 type
class | Vector4Extensions
Static class containing extension for Vector4 type
struct | VisibleCellData
Struct containing data size of a visible cell inside the volume More...
struct | VolumeData
Ordered struct of volume parameters to be sent to the compute shader More...
struct | VolumeDynamicNoiseData
Ordered struct of noise parameters to be sent to the compute shader More...
struct | VolumeGradient
struct | VolumeInjectionColorParameters
Volume injection parameters for color More...
struct | VolumeInjectionCommonParameters
Base volume injection parameters for density/scattering/color More...
struct | VolumeInjectionParameters
Volume injection parameters for density/scattering More...
struct | VolumeInjectionShape
class | VolumesCommonDataManager
Handles the volumes' registration and maps collection More...
class | VolumesManager
Manages the volumes, collects and packs data and volumetric textures More...
class | XrHelpers
Collection of functions/variables related to Xr

Enumerations

enum | BlurFilterRange { OneNeighbour = 0, ThreeNeighbours = 1, FiveNeighbours = 2 }
Defines the range of blur filter applied on the data texture3D More...
enum | BlurFilterType { Box = 0, Gaussian = 1 }
Defines the type of blur filter applied on the data texture3D More...
enum | BooleanChoice { Default = 0, True = 1, False = 2 }
Defines multiple choice between Default, True and False More...
enum | DenoisingFilterRange { OneNeighbour = 0, TwoNeighbours = 1, ThreeNeighbours = 2 }
Defines the range of denoising filter applied on the data texture3D More...
enum FrustumParameters {
EnableNothing = 0, EnableOcclusionCulling = 1 << 0, EnableTemporalReprojection = 1 << 1, EnableVolumes = 1 << 2,
EnableVolumesNoiseMask = 1 << 3, EnableVolumesTexture2DMask = 1 << 4, EnableVolumesTexture3DMask = 1 << 5, EnableAmbientLighting = 1 << 6,
EnableLightProbes = 1 << 7, EnableDirectionalLights = 1 << 8, EnableDirectionalLightsShadows = 1 << 9, DirectionalLightsShadowsOneCascade = 1 << 10,
DirectionalLightsShadowsTwoCascades = 1 << 11, DirectionalLightsShadowsFourCascades = 1 << 12, EnableSpotLights = 1 << 13, EnableSpotLightsShadows = 1 << 14,
EnablePointLights = 1 << 15, EnablePointLightsShadows = 1 << 16, EnableLightsCookies = 1 << 17, EnableDenoisingFilter = 1 << 18,
EnableBlurFilter = 1 << 19
}
Bitmask representing the possible parameters for the volumetric data computation More...
enum | OcclusionCullingAccuracy { Lowest = 0, Low = 1, Medium = 2, High = 3 }
Defines the accuracy of maxima detection for the occlusion culling More...
enum Presets {
SunnyDay = 0, Forest = 1, RainyDay = 2, Dawn = 3,
Desert = 4, SnowyDay = 5
}
Defines the type of preset to apply to the Aura system More...
enum | StereoMode { Mono = 0, MultiPass = 1, SinglePass = 2 }
Defines the type of stereo rendering modes More...
enum | Texture3DFiltering { Linear = 0, Cubic = 1 }
Defines the type of sampling filter used for Texture3D More...
enum VolumeType {
Global = 0, Layer = 1, Box = 2, Sphere = 3,
Cylinder = 4, Cone = 5
}
Defines the type of injection volume used in an AuraVolume More...

Enumeration Type Documentation

◆ BlurFilterRange

enum Aura2API.BlurFilterRange
strong

Defines the range of blur filter applied on the data texture3D

◆ BlurFilterType

enum Aura2API.BlurFilterType
strong

Defines the type of blur filter applied on the data texture3D

◆ BooleanChoice

enum Aura2API.BooleanChoice
strong

Defines multiple choice between Default, True and False

◆ DenoisingFilterRange

enum Aura2API.DenoisingFilterRange
strong

Defines the range of denoising filter applied on the data texture3D

◆ FrustumParameters

enum Aura2API.FrustumParameters
strong

Bitmask representing the possible parameters for the volumetric data computation

◆ OcclusionCullingAccuracy

enum Aura2API.OcclusionCullingAccuracy
strong

Defines the accuracy of maxima detection for the occlusion culling

◆ Presets

enum Aura2API.Presets
strong

Defines the type of preset to apply to the Aura system

◆ StereoMode

enum Aura2API.StereoMode
strong

Defines the type of stereo rendering modes

◆ Texture3DFiltering

enum Aura2API.Texture3DFiltering
strong

Defines the type of sampling filter used for Texture3D

◆ VolumeType

enum Aura2API.VolumeType
strong

Defines the type of injection volume used in an AuraVolume


Aura 2: UnityEngine Namespace Reference

Classes
UnityEngine Namespace Reference

Classes

class RenderTextureExtensions
Extensions methods for RenderTexture objects


Aura 2: Package Functions

Here is a list of all documented namespace members with links to the namespaces they belong to:
  • BlurFilterRange : Aura2API
  • BlurFilterType : Aura2API
  • BooleanChoice : Aura2API
  • DenoisingFilterRange : Aura2API
  • FrustumParameters : Aura2API
  • OcclusionCullingAccuracy : Aura2API
  • Presets : Aura2API
  • StereoMode : Aura2API
  • Texture3DFiltering : Aura2API
  • VolumeType : Aura2API


Aura 2: Package Functions

  • BlurFilterRange : Aura2API
  • BlurFilterType : Aura2API
  • BooleanChoice : Aura2API
  • DenoisingFilterRange : Aura2API
  • FrustumParameters : Aura2API
  • OcclusionCullingAccuracy : Aura2API
  • Presets : Aura2API
  • StereoMode : Aura2API
  • Texture3DFiltering : Aura2API
  • VolumeType : Aura2API


Aura 2: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N Aura2API |
C AmbientLightingCommonDataManager | Handles the ambient lighting data
C AuraBaseSettings | Base injection settings for the data computation
C AuraCamera | Main component to assign on a GameObject with a Camera component
C AuraLight | Component to assign on a GameObject with a Light component if you want this Light to be taken into account in Aura
C AuraQualitySettings | Quality settings for Aura2 computation
C AuraResourcesCollection |
C AuraSprite | Component allowing the sprites to work with the Aura system
C AuraVolume | Component allowing the volume injection of density/scattering/light
C ColorCircularPickerAttribute | Custom attribute for enabling circular picker on Color properties
C CommonDataManager | Handles the lights' and volumes' commond data managers
C CullableObject | Class to inherit from when using an ObjectCuller
C DirectionalLightParameters | Struct containing parameters of a directional AuraLight
C DirectionalLightsManager | Manager that handles directional AuraLights
C DirectionalShadowDataCollector | Texture2DArray composer used for collecting directional shadow data maps
C DynamicNoiseParameters | Collection of parameters for 4D dynamic noise mask to be used in a volume
C Frustum | Ranged camera frustum inside which the volumetric data will be computed
C FrustumSettings | Collection of settings for the data computation
C FrustumSettingsParameters | Collection of settings defining the computation of the volumetric data
C FrustumSettingsToId | Collects all the settings and compute the flag Id to be used as kernel id of the computeDataComputeShader
C LevelsData | Ordered struct of Levels operation parameters to be sent to the compute shader
C LevelsParameters | Collection of parameters for Levels adjustement. Similar to the same tool in Photoshop.
C LightsCommonDataManager | Handles the lights' registration and maps collection
C MatrixFloats | Ordered struct of Vector4 representing a matrix to be sent to the compute shader
C PointLightParameters | Struct containing parameters of a point AuraLight
C PointLightsManager | Manager that handles point AuraLights
C ShadowmapsCollector | Texture2DArray composer used for collecting shadow maps
C SphericalHarmonicsCoefficients | Struct containing spherical harmonics coefficients to use probes in shaders
C SphericalHarmonicsFirstBandCoefficients | Struct containing spherical harmonics coefficients to use probes in shaders
C SpotLightParameters | Struct containing parameters of a spot AuraLight
C SpotLightsManager | Manager that handles spot AuraLights
C SwappableRenderTexture | Double buffering render texture
C Texture2DArrayComposer | Builds a Texture2DArray out of a collection of Textures
C Texture2DMask | Texture2D mask to be used in a AuraVolume
C Texture3DMask | Texture3D mask to be used in a AuraVolume
C Texture3DPreviewAttribute | Attribute enabling Texture3D preview in a Monobehaviour component in the Inspector
C TextureBuffers | Collection of texture buffers which contain the computed volumetric data
C TextureMaskData | Ordered struct of texture mask parameters to be sent to the compute shader
C TransformParameters | Used for transforming reference position for textures/noise inside volumes
C VisibleCellData | Struct containing data size of a visible cell inside the volume
C VolumeData | Ordered struct of volume parameters to be sent to the compute shader
C VolumeDynamicNoiseData | Ordered struct of noise parameters to be sent to the compute shader
C VolumeGradient |
C VolumeInjectionColorParameters | Volume injection parameters for color
C VolumeInjectionCommonParameters | Base volume injection parameters for density/scattering/color
C VolumeInjectionParameters | Volume injection parameters for density/scattering
C VolumeInjectionShape |
C VolumesCommonDataManager | Handles the volumes' registration and maps collection
C VolumesManager | Manages the volumes, collects and packs data and volumetric textures


Aura 2: Aura2API.AmbientLightingCommonDataManager Class Reference

  • Aura2API
  • AmbientLightingCommonDataManager
Public Member Functions | Properties | List of all members
Aura2API.AmbientLightingCommonDataManager Class Reference

Handles the ambient lighting data More...

Public Member Functions

void Update ()
Updates the spherical harmonics coefficients More...

Properties

SphericalHarmonicsCoefficients | Coefficients [get]
Ambient probe's spherical harmonics coefficients packed to be sent to the compute shader More...
static float | GlobalStrength [get]
Returns the global strength of the ambient lighting More...

Detailed Description

Handles the ambient lighting data

Member Function Documentation

◆ Update()

void Aura2API.AmbientLightingCommonDataManager.Update ( )

Updates the spherical harmonics coefficients

Property Documentation

◆ Coefficients

SphericalHarmonicsCoefficients Aura2API.AmbientLightingCommonDataManager.Coefficients
get

Ambient probe's spherical harmonics coefficients packed to be sent to the compute shader

◆ GlobalStrength

float Aura2API.AmbientLightingCommonDataManager.GlobalStrength
staticget

Returns the global strength of the ambient lighting

The documentation for this class was generated from the following file:
  • AmbientLightingCommonDataManager.cs


Aura 2: Member List

  • AmbientLightingCommonDataManager
Aura2API.AmbientLightingCommonDataManager Member List

This is the complete list of members for Aura2API.AmbientLightingCommonDataManager, including all inherited members.

Coefficients | Aura2API.AmbientLightingCommonDataManager |
GlobalStrength | Aura2API.AmbientLightingCommonDataManager | static
Update() | Aura2API.AmbientLightingCommonDataManager |


Aura 2: Aura2API.AuraBaseSettings Class Reference

  • AuraBaseSettings
Public Attributes | List of all members
Aura2API.AuraBaseSettings Class Reference

Base injection settings for the data computation More...

Inheritance diagram for Aura2API.AuraBaseSettings:

Public Attributes

bool | useDensity = true
Enables the injection of the base density More...
float | density = 0.25f
The base density of the environment More...
bool | useScattering = true
Enables the injection of the base scattering More...
float | scattering = 0.5f
The base scattering of the environment More...
bool | useAmbientLighting = true
Enables the ambient lighting More...
float | ambientLightingStrength = 1.0f
The strength of the ambient lighting More...
bool | useColor = false
Enables the injection of the base color More...
Color | color = Color.cyan * 0.5f
The base color of the environment More...
float | colorStrength = 1.0f
The base color factor of the environment More...
bool | useTint = false
Enables the injection of the tint color More...
Color | tint = Color.yellow
The tint color of the environment More...
float | tintStrength = 1.0f
The tint color factor of the environment More...
bool | useExtinction = false
Enables the depth extinction of light More...
float | extinction = 0.75f
The linear light absorbtion of the environment (expressed in decay factor) More...

Detailed Description

Base injection settings for the data computation

Member Data Documentation

◆ ambientLightingStrength

float Aura2API.AuraBaseSettings.ambientLightingStrength = 1.0f

The strength of the ambient lighting

◆ color

Color Aura2API.AuraBaseSettings.color = Color.cyan * 0.5f

The base color of the environment

◆ colorStrength

float Aura2API.AuraBaseSettings.colorStrength = 1.0f

The base color factor of the environment

◆ density

float Aura2API.AuraBaseSettings.density = 0.25f

The base density of the environment

◆ extinction

float Aura2API.AuraBaseSettings.extinction = 0.75f

The linear light absorbtion of the environment (expressed in decay factor)

◆ scattering

float Aura2API.AuraBaseSettings.scattering = 0.5f

The base scattering of the environment

◆ tint

Color Aura2API.AuraBaseSettings.tint = Color.yellow

The tint color of the environment

◆ tintStrength

float Aura2API.AuraBaseSettings.tintStrength = 1.0f

The tint color factor of the environment

◆ useAmbientLighting

bool Aura2API.AuraBaseSettings.useAmbientLighting = true

Enables the ambient lighting

◆ useColor

bool Aura2API.AuraBaseSettings.useColor = false

Enables the injection of the base color

◆ useDensity

bool Aura2API.AuraBaseSettings.useDensity = true

Enables the injection of the base density

◆ useExtinction

bool Aura2API.AuraBaseSettings.useExtinction = false

Enables the depth extinction of light

◆ useScattering

bool Aura2API.AuraBaseSettings.useScattering = true

Enables the injection of the base scattering

◆ useTint

bool Aura2API.AuraBaseSettings.useTint = false

Enables the injection of the tint color

The documentation for this class was generated from the following file:
  • AuraBaseSettings.cs


Aura 2: Member List

  • AuraBaseSettings
Aura2API.AuraBaseSettings Member List

This is the complete list of members for Aura2API.AuraBaseSettings, including all inherited members.

ambientLightingStrength | Aura2API.AuraBaseSettings
color | Aura2API.AuraBaseSettings
colorStrength | Aura2API.AuraBaseSettings
density | Aura2API.AuraBaseSettings
extinction | Aura2API.AuraBaseSettings
scattering | Aura2API.AuraBaseSettings
tint | Aura2API.AuraBaseSettings
tintStrength | Aura2API.AuraBaseSettings
useAmbientLighting | Aura2API.AuraBaseSettings
useColor | Aura2API.AuraBaseSettings
useDensity | Aura2API.AuraBaseSettings
useExtinction | Aura2API.AuraBaseSettings
useScattering | Aura2API.AuraBaseSettings
useTint | Aura2API.AuraBaseSettings


Aura 2: Aura2API.AuraCamera Class Reference

  • AuraCamera
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
Aura2API.AuraCamera Class Reference

Main component to assign on a GameObject with a Camera component More...

Inheritance diagram for Aura2API.AuraCamera:

Public Member Functions

void | SetFrustumGridResolution (Vector3Int resolution)
Sets a new frustum grid resolution More...
void | SetLightProbesProxyGridResolution (Vector3Int resolution)
Sets a new grid resolution for light probes proxy More...

Static Public Member Functions

static GameObject CreateGameObject (string name)
Method allowing to quickly build GameObjects with the component assigned More...

Public Attributes

FrustumSettings frustumSettings
Settings of the frustum More...
Frustum _frustum
The frustum inside which the data will be computed More...

Properties

Camera | CameraComponent [get]
Gets the Camera component More...
static CommonDataManager | CommonDataManager [get]
The manager in charge of registering Aura lights and collecting their common (unculled) data More...
int | FrameId [get]
The frame count since the begining More...
static float | Time [get]
Gets the elapsed Time More...
static float | DeltaTtime [get]
Gets the current Delta Time More...
bool | IsInitialized [get]
Tells if the component has succesfully been initialized More...

Detailed Description

Main component to assign on a GameObject with a Camera component

Member Function Documentation

◆ CreateGameObject()

static GameObject Aura2API.AuraCamera.CreateGameObject ( string name )
static

Method allowing to quickly build GameObjects with the component assigned

Parameters
name The name of the new GameObject
Returns
The created AuraCamera gameObject

◆ SetFrustumGridResolution()

void Aura2API.AuraCamera.SetFrustumGridResolution ( Vector3Int resolution )

Sets a new frustum grid resolution

Parameters
resolution The new resolution

◆ SetLightProbesProxyGridResolution()

void Aura2API.AuraCamera.SetLightProbesProxyGridResolution ( Vector3Int resolution )

Sets a new grid resolution for light probes proxy

Parameters
resolution The new resolution

Member Data Documentation

◆ _frustum

Frustum Aura2API.AuraCamera._frustum

The frustum inside which the data will be computed

◆ frustumSettings

FrustumSettings Aura2API.AuraCamera.frustumSettings

Settings of the frustum

Property Documentation

◆ CameraComponent

Camera Aura2API.AuraCamera.CameraComponent
get

Gets the Camera component

◆ CommonDataManager

CommonDataManager Aura2API.AuraCamera.CommonDataManager
staticget

The manager in charge of registering Aura lights and collecting their common (unculled) data

◆ DeltaTtime

float Aura2API.AuraCamera.DeltaTtime
staticget

Gets the current Delta Time

◆ FrameId

int Aura2API.AuraCamera.FrameId
get

The frame count since the begining

◆ IsInitialized

bool Aura2API.AuraCamera.IsInitialized
get

Tells if the component has succesfully been initialized

◆ Time

float Aura2API.AuraCamera.Time
staticget

Gets the elapsed Time

The documentation for this class was generated from the following file:
  • AuraCamera.cs


Aura 2: Member List

  • AuraCamera
Aura2API.AuraCamera Member List

This is the complete list of members for Aura2API.AuraCamera, including all inherited members.

_frustum | Aura2API.AuraCamera |
CameraComponent | Aura2API.AuraCamera |
CommonDataManager | Aura2API.AuraCamera | static
CreateGameObject(string name) | Aura2API.AuraCamera | static
DeltaTtime | Aura2API.AuraCamera | static
FrameId | Aura2API.AuraCamera |
frustumSettings | Aura2API.AuraCamera |
IsInitialized | Aura2API.AuraCamera |
SetFrustumGridResolution(Vector3Int resolution) | Aura2API.AuraCamera |
SetLightProbesProxyGridResolution(Vector3Int resolution) | Aura2API.AuraCamera |
Time | Aura2API.AuraCamera | static


Aura 2: Aura2API.AuraLight Class Reference

  • AuraLight
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | Events | List of all members
Aura2API.AuraLight Class Reference

Component to assign on a GameObject with a Light component if you want this Light to be taken into account in Aura More...

Inheritance diagram for Aura2API.AuraLight:
Aura2API.CullableObject

Public Member Functions

DirectionalLightParameters GetDirectionnalParameters ()
Returns the collected data for the directional light More...
SpotLightParameters GetSpotParameters ()
Returns the collected data for the spot light More...
PointLightParameters GetPointParameters ()
Returns the collected data for the point light More...
void | SetShadowMapIndex (int index)
Modifies the index of the shadow map in the composed Texture2DArray that is sent to the compute shader More...
void | SetCookieMapIndex (int index)
Modifies the index of the cookie map in the composed Texture2DArray that is sent to the compute shader More...
- Public Member Functions inherited from Aura2API.CullableObject
void | UpdateBoundingSphere (Vector3 position, float radius)
Updates the bounding sphere used to cull with the camera More...
void | UpdateBoundingSphere (BoundingSphere boundingSphere)
Updates the bounding sphere used to cull with the camera More...
bool | CheckFrustumOverlap (Plane[] frustumPlanes)

Static Public Member Functions

static GameObject CreateGameObject (string name, LightType type)
Method allowing to quickly build GameObjects with the component assigned More...

Public Attributes

float | strength = 1.0f
Strength of the volumetric light contribution More...
BooleanChoice | useScattering = BooleanChoice.Default
Allows to ignore the scattering of the light More...
bool | overrideScattering
Allows to ignore local scattering and refers to the "overridingScattering" property instead More...
float | overridingScattering = 0.5f
Overriding scattering if "overrideScattering" is checked More...
float | scatteringBias = 0.0f
Biases the scattering factor in order to have more control for each light More...
bool | useColorTemperatureTint = false
Enables the color temperature tint. Unity currently gives no way to know if the color temperature mode is enabled on the light, therefore it has to be manually enabled. More...
bool | overrideColor
Allows to ignore the light's color and refers to the "overridingColor" property instead More...
Color | overridingColor = Color.white
Overriding color if "overrideColor" is checked More...
bool | useShadow = true
Allows to use light's shadows attenuation More...
RenderTexture | shadowMapRenderTexture
The light's shadow map More...
bool | useCookie = true
Allows to use light's cookie attenuation More...
RenderTexture | cookieMapRenderTexture
The light's cookie map More...
bool | enableOutOfPhaseColor
Allows to ignore the directional light's color and refers to the "overridingColor" property instead More...
float | outOfPhaseColorStrength = 0.1f
Strength of out-of-phase color More...
Color | outOfPhaseColor = Color.cyan
Out-of-phase color More...
RenderTexture | shadowDataRenderTexture
The directional light's shadow data texture More...
float | customDistanceFalloffThreshold = 0.5f
Custom distance falloff start (Spot/Point Lights only) More...
float | customDistanceFalloffPower = 2.0f
Custom distance falloff power (Spot/Point Lights only) More...
float | customCookieDistanceFalloffStartThreshold = 0.1f
Custom cookie distance falloff start (Spot/Point Lights only) More...
float | customCookieDistanceFalloffEndThreshold = 0.25f
Custom cookie distance falloff end (Spot/Point Lights only) More...
float | customCookieDistanceFalloffPower = 2.0f
Custom cookie distance falloff power (Spot/Point Lights only) More...
float | customAngularFalloffThreshold = 0.8f
Custom angular falloff start (Spot Lights only) More...
float | customAngularFalloffPower = 2.0f
Custom angular falloff power (Spot Lights only) More...

Properties

Light | LightComponent [get]
Returns the attached light's type More...
LightType | Type [get]
Returns the attached light's type More...
bool | CastsShadows [get]
Tells if it should cast shadows More...
bool | CastsCookie [get]
Tells if it should cast cookie More...
- Properties inherited from Aura2API.CullableObject
BoundingSphere | BoundingSphere [get]
Accessor to the bounding sphere used to cull with the camera More...

Events

Action< AuraLight, LightType > OnUninitialize
Event raised when the light is being disabled More...

Detailed Description

Component to assign on a GameObject with a Light component if you want this Light to be taken into account in Aura

Member Function Documentation

◆ CreateGameObject()

static GameObject Aura2API.AuraLight.CreateGameObject | ( | string | name,
 |  | LightType | type
 | ) |  |
static

Method allowing to quickly build GameObjects with the component assigned

Parameters
name | The name of the new GameObject
type | The desired light's type
Returns
The created AuraLight gameObject

◆ GetDirectionnalParameters()

DirectionalLightParameters Aura2API.AuraLight.GetDirectionnalParameters ( )

Returns the collected data for the directional light

Returns
The packed data

◆ GetPointParameters()

PointLightParameters Aura2API.AuraLight.GetPointParameters ( )

Returns the collected data for the point light

Returns
The packed data

◆ GetSpotParameters()

SpotLightParameters Aura2API.AuraLight.GetSpotParameters ( )

Returns the collected data for the spot light

Returns
The packed data

◆ SetCookieMapIndex()

void Aura2API.AuraLight.SetCookieMapIndex ( int index )

Modifies the index of the cookie map in the composed Texture2DArray that is sent to the compute shader

Parameters
index The new index

◆ SetShadowMapIndex()

void Aura2API.AuraLight.SetShadowMapIndex ( int index )

Modifies the index of the shadow map in the composed Texture2DArray that is sent to the compute shader

Parameters
index The new index

Member Data Documentation

◆ cookieMapRenderTexture

RenderTexture Aura2API.AuraLight.cookieMapRenderTexture

The light's cookie map

◆ customAngularFalloffPower

float Aura2API.AuraLight.customAngularFalloffPower = 2.0f

Custom angular falloff power (Spot Lights only)

◆ customAngularFalloffThreshold

float Aura2API.AuraLight.customAngularFalloffThreshold = 0.8f

Custom angular falloff start (Spot Lights only)

◆ customCookieDistanceFalloffEndThreshold

float Aura2API.AuraLight.customCookieDistanceFalloffEndThreshold = 0.25f

Custom cookie distance falloff end (Spot/Point Lights only)

◆ customCookieDistanceFalloffPower

float Aura2API.AuraLight.customCookieDistanceFalloffPower = 2.0f

Custom cookie distance falloff power (Spot/Point Lights only)

◆ customCookieDistanceFalloffStartThreshold

float Aura2API.AuraLight.customCookieDistanceFalloffStartThreshold = 0.1f

Custom cookie distance falloff start (Spot/Point Lights only)

◆ customDistanceFalloffPower

float Aura2API.AuraLight.customDistanceFalloffPower = 2.0f

Custom distance falloff power (Spot/Point Lights only)

◆ customDistanceFalloffThreshold

float Aura2API.AuraLight.customDistanceFalloffThreshold = 0.5f

Custom distance falloff start (Spot/Point Lights only)

◆ enableOutOfPhaseColor

bool Aura2API.AuraLight.enableOutOfPhaseColor

Allows to ignore the directional light's color and refers to the "overridingColor" property instead

◆ outOfPhaseColor

Color Aura2API.AuraLight.outOfPhaseColor = Color.cyan

Out-of-phase color

◆ outOfPhaseColorStrength

float Aura2API.AuraLight.outOfPhaseColorStrength = 0.1f

Strength of out-of-phase color

◆ overrideColor

bool Aura2API.AuraLight.overrideColor

Allows to ignore the light's color and refers to the "overridingColor" property instead

◆ overrideScattering

bool Aura2API.AuraLight.overrideScattering

Allows to ignore local scattering and refers to the "overridingScattering" property instead

◆ overridingColor

Color Aura2API.AuraLight.overridingColor = Color.white

Overriding color if "overrideColor" is checked

◆ overridingScattering

float Aura2API.AuraLight.overridingScattering = 0.5f

Overriding scattering if "overrideScattering" is checked

◆ scatteringBias

float Aura2API.AuraLight.scatteringBias = 0.0f

Biases the scattering factor in order to have more control for each light

◆ shadowDataRenderTexture

RenderTexture Aura2API.AuraLight.shadowDataRenderTexture

The directional light's shadow data texture

◆ shadowMapRenderTexture

RenderTexture Aura2API.AuraLight.shadowMapRenderTexture

The light's shadow map

◆ strength

float Aura2API.AuraLight.strength = 1.0f

Strength of the volumetric light contribution

◆ useColorTemperatureTint

bool Aura2API.AuraLight.useColorTemperatureTint = false

Enables the color temperature tint. Unity currently gives no way to know if the color temperature mode is enabled on the light, therefore it has to be manually enabled.

◆ useCookie

bool Aura2API.AuraLight.useCookie = true

Allows to use light's cookie attenuation

◆ useScattering

BooleanChoice Aura2API.AuraLight.useScattering = BooleanChoice.Default

Allows to ignore the scattering of the light

◆ useShadow

bool Aura2API.AuraLight.useShadow = true

Allows to use light's shadows attenuation

Property Documentation

◆ CastsCookie

bool Aura2API.AuraLight.CastsCookie
get

Tells if it should cast cookie

◆ CastsShadows

bool Aura2API.AuraLight.CastsShadows
get

Tells if it should cast shadows

◆ LightComponent

Light Aura2API.AuraLight.LightComponent
get

Returns the attached light's type

◆ Type

LightType Aura2API.AuraLight.Type
get

Returns the attached light's type

Event Documentation

◆ OnUninitialize

Action<AuraLight,LightType> Aura2API.AuraLight.OnUninitialize

Event raised when the light is being disabled

The documentation for this class was generated from the following file:
  • AuraLight.cs


Aura 2: Member List

  • AuraLight
Aura2API.AuraLight Member List

This is the complete list of members for Aura2API.AuraLight, including all inherited members.

BoundingSphere | Aura2API.CullableObject |
CastsCookie | Aura2API.AuraLight |
CastsShadows | Aura2API.AuraLight |
CheckFrustumOverlap(Plane[] frustumPlanes) | Aura2API.CullableObject |
cookieMapRenderTexture | Aura2API.AuraLight |
CreateGameObject(string name, LightType type) | Aura2API.AuraLight | static
customAngularFalloffPower | Aura2API.AuraLight |
customAngularFalloffThreshold | Aura2API.AuraLight |
customCookieDistanceFalloffEndThreshold | Aura2API.AuraLight |
customCookieDistanceFalloffPower | Aura2API.AuraLight |
customCookieDistanceFalloffStartThreshold | Aura2API.AuraLight |
customDistanceFalloffPower | Aura2API.AuraLight |
customDistanceFalloffThreshold | Aura2API.AuraLight |
enableOutOfPhaseColor | Aura2API.AuraLight |
GetDirectionnalParameters() | Aura2API.AuraLight |
GetPointParameters() | Aura2API.AuraLight |
GetSpotParameters() | Aura2API.AuraLight |
LightComponent | Aura2API.AuraLight |
OnUninitialize | Aura2API.AuraLight |
outOfPhaseColor | Aura2API.AuraLight |
outOfPhaseColorStrength | Aura2API.AuraLight |
overrideColor | Aura2API.AuraLight |
overrideScattering | Aura2API.AuraLight |
overridingColor | Aura2API.AuraLight |
overridingScattering | Aura2API.AuraLight |
scatteringBias | Aura2API.AuraLight |
SetCookieMapIndex(int index) | Aura2API.AuraLight |
SetShadowMapIndex(int index) | Aura2API.AuraLight |
shadowDataRenderTexture | Aura2API.AuraLight |
shadowMapRenderTexture | Aura2API.AuraLight |
strength | Aura2API.AuraLight |
Type | Aura2API.AuraLight |
Aura2API::CullableObject.UpdateBoundingSphere(Vector3 position, float radius) | Aura2API.CullableObject |
Aura2API::CullableObject.UpdateBoundingSphere(BoundingSphere boundingSphere) | Aura2API.CullableObject |
useColorTemperatureTint | Aura2API.AuraLight |
useCookie | Aura2API.AuraLight |
useScattering | Aura2API.AuraLight |
useShadow | Aura2API.AuraLight |


Aura 2: Aura2API.AuraQualitySettings Class Reference

  • AuraQualitySettings
Public Member Functions | Public Attributes | List of all members
Aura2API.AuraQualitySettings Class Reference

Quality settings for Aura2 computation More...

Inheritance diagram for Aura2API.AuraQualitySettings:

Public Member Functions

Vector3Int | GetFrustumGridResolution (Camera camera)
Returns the frustum grid resolution, taking into account the camera stereo mode More...
void | SetFrustumGridResolution (Vector3Int resolution)
Sets a new resolution for the frustum grid and tries to apply it on all the Aura components that has the current qualitySettings on More...

Public Attributes

bool | displayVolumetricLightingBuffer
Shows only the volumetric lighting More...
Vector3Int | frustumGridResolution = new Vector3Int(160, 90, 128)
The resolution of the frustum grid More...
bool | enableAutomaticStereoResizing = true
Enables the automatic horizontal resizing of the frustum grid resolution when the camera is running in stereo mode (halved size for MultiPass, doubled size for SinglePass) More...
float | farClipPlaneDistance = 128.0f
The furthest distance where the data will be computed More...
float | depthBiasCoefficient = 0.35f
Focus the depth slices near or far from the camera More...
bool | enableVolumes = true
Enables the computation of volumes More...
bool | enableVolumesTexture2DMask = true
Enables the computation of Texture2D masks More...
bool | enableVolumesTexture3DMask = true
Enables the computation of Texture3D masks More...
bool | enableVolumesNoiseMask = true
Enables the computation of noise mask More...
bool | enableAmbientLighting = true
Enables the computation of ambient lighting More...
bool | enableDirectionalLights = true
Enables the computation of directional lights More...
bool | enableDirectionalLightsShadows = true
Enables the computation of directional lights' shadow More...
bool | enableSpotLights = true
Enables the computation of spot lights More...
bool | enableSpotLightsShadows = true
Enables the computation of spot lights' shadow More...
bool | enablePointLights = true
Enables the computation of point lights More...
bool | enablePointLightsShadows = true
Enables the computation of point lights' shadow More...
bool | enableLightsCookies = true
Enables the computation of lights' cookie More...
bool | enableDithering = true
Enables blue noise dithering to smooth color banding (might need to be smoothed) More...
Texture3DFiltering | texture3DFiltering = Texture3DFiltering.Cubic
The sampling filter used for Texture3D More...
bool | EXPERIMENTAL_enableDenoisingFilter = false
Enables the denoising filter on the data texture3D More...
DenoisingFilterRange | EXPERIMENTAL_denoisingFilterRange = DenoisingFilterRange.OneNeighbour
The range of the denoising filter on the data texture3D More...
bool | EXPERIMENTAL_enableBlurFilter = false
Enables the blur filter on the data texture3D More...
BlurFilterRange | EXPERIMENTAL_blurFilterRange = BlurFilterRange.OneNeighbour
The range of the blur filter on the data texture3D More...
BlurFilterType | EXPERIMENTAL_blurFilterType = BlurFilterType.Box
The type of the blur filter on the data texture3D More...
float | EXPERIMENTAL_blurFilterGaussianDeviation = 0.0025f
The deviation used to compute the gaussian curve factor More...
bool | enableTemporalReprojection = true
Enables temporal reprojection More...
float | temporalReprojectionFactor = 0.95f
Amount of reprojection with the previous frame More...
bool | enableOcclusionCulling = true
Enables depth occlusion culling More...
bool | debugOcclusionCulling = false
Highlights the occluded cells for debug More...
OcclusionCullingAccuracy | occlusionCullingAccuracy = OcclusionCullingAccuracy.Lowest
Accuracy of the occlusion computation More...
bool | enableLightProbes = false
Enables the computation of light probes More...

Detailed Description

Quality settings for Aura2 computation

Member Function Documentation

◆ GetFrustumGridResolution()

Vector3Int Aura2API.AuraQualitySettings.GetFrustumGridResolution ( Camera camera )

Returns the frustum grid resolution, taking into account the camera stereo mode

Parameters
camera The reference camera to look for stereo mode
Returns
The frustum grid resolution, resized according to the stereo mode of the camera

◆ SetFrustumGridResolution()

void Aura2API.AuraQualitySettings.SetFrustumGridResolution ( Vector3Int resolution )

Sets a new resolution for the frustum grid and tries to apply it on all the Aura components that has the current qualitySettings on

Parameters
resolution The new resolution to set

Member Data Documentation

◆ debugOcclusionCulling

bool Aura2API.AuraQualitySettings.debugOcclusionCulling = false

Highlights the occluded cells for debug

◆ depthBiasCoefficient

float Aura2API.AuraQualitySettings.depthBiasCoefficient = 0.35f

Focus the depth slices near or far from the camera

◆ displayVolumetricLightingBuffer

bool Aura2API.AuraQualitySettings.displayVolumetricLightingBuffer

Shows only the volumetric lighting

◆ enableAmbientLighting

bool Aura2API.AuraQualitySettings.enableAmbientLighting = true

Enables the computation of ambient lighting

◆ enableAutomaticStereoResizing

bool Aura2API.AuraQualitySettings.enableAutomaticStereoResizing = true

Enables the automatic horizontal resizing of the frustum grid resolution when the camera is running in stereo mode (halved size for MultiPass, doubled size for SinglePass)

◆ enableDirectionalLights

bool Aura2API.AuraQualitySettings.enableDirectionalLights = true

Enables the computation of directional lights

◆ enableDirectionalLightsShadows

bool Aura2API.AuraQualitySettings.enableDirectionalLightsShadows = true

Enables the computation of directional lights' shadow

◆ enableDithering

bool Aura2API.AuraQualitySettings.enableDithering = true

Enables blue noise dithering to smooth color banding (might need to be smoothed)

◆ enableLightProbes

bool Aura2API.AuraQualitySettings.enableLightProbes = false

Enables the computation of light probes

◆ enableLightsCookies

bool Aura2API.AuraQualitySettings.enableLightsCookies = true

Enables the computation of lights' cookie

◆ enableOcclusionCulling

bool Aura2API.AuraQualitySettings.enableOcclusionCulling = true

Enables depth occlusion culling

◆ enablePointLights

bool Aura2API.AuraQualitySettings.enablePointLights = true

Enables the computation of point lights

◆ enablePointLightsShadows

bool Aura2API.AuraQualitySettings.enablePointLightsShadows = true

Enables the computation of point lights' shadow

◆ enableSpotLights

bool Aura2API.AuraQualitySettings.enableSpotLights = true

Enables the computation of spot lights

◆ enableSpotLightsShadows

bool Aura2API.AuraQualitySettings.enableSpotLightsShadows = true

Enables the computation of spot lights' shadow

◆ enableTemporalReprojection

bool Aura2API.AuraQualitySettings.enableTemporalReprojection = true

Enables temporal reprojection

◆ enableVolumes

bool Aura2API.AuraQualitySettings.enableVolumes = true

Enables the computation of volumes

◆ enableVolumesNoiseMask

bool Aura2API.AuraQualitySettings.enableVolumesNoiseMask = true

Enables the computation of noise mask

◆ enableVolumesTexture2DMask

bool Aura2API.AuraQualitySettings.enableVolumesTexture2DMask = true

Enables the computation of Texture2D masks

◆ enableVolumesTexture3DMask

bool Aura2API.AuraQualitySettings.enableVolumesTexture3DMask = true

Enables the computation of Texture3D masks

◆ EXPERIMENTAL_blurFilterGaussianDeviation

float Aura2API.AuraQualitySettings.EXPERIMENTAL_blurFilterGaussianDeviation = 0.0025f

The deviation used to compute the gaussian curve factor

◆ EXPERIMENTAL_blurFilterRange

BlurFilterRange Aura2API.AuraQualitySettings.EXPERIMENTAL_blurFilterRange = BlurFilterRange.OneNeighbour

The range of the blur filter on the data texture3D

◆ EXPERIMENTAL_blurFilterType

BlurFilterType Aura2API.AuraQualitySettings.EXPERIMENTAL_blurFilterType = BlurFilterType.Box

The type of the blur filter on the data texture3D

◆ EXPERIMENTAL_denoisingFilterRange

DenoisingFilterRange Aura2API.AuraQualitySettings.EXPERIMENTAL_denoisingFilterRange = DenoisingFilterRange.OneNeighbour

The range of the denoising filter on the data texture3D

◆ EXPERIMENTAL_enableBlurFilter

bool Aura2API.AuraQualitySettings.EXPERIMENTAL_enableBlurFilter = false

Enables the blur filter on the data texture3D

◆ EXPERIMENTAL_enableDenoisingFilter

bool Aura2API.AuraQualitySettings.EXPERIMENTAL_enableDenoisingFilter = false

Enables the denoising filter on the data texture3D

◆ farClipPlaneDistance

float Aura2API.AuraQualitySettings.farClipPlaneDistance = 128.0f

The furthest distance where the data will be computed

◆ frustumGridResolution

Vector3Int Aura2API.AuraQualitySettings.frustumGridResolution = new Vector3Int(160, 90, 128)

The resolution of the frustum grid

◆ occlusionCullingAccuracy

OcclusionCullingAccuracy Aura2API.AuraQualitySettings.occlusionCullingAccuracy = OcclusionCullingAccuracy.Lowest

Accuracy of the occlusion computation

◆ temporalReprojectionFactor

float Aura2API.AuraQualitySettings.temporalReprojectionFactor = 0.95f

Amount of reprojection with the previous frame

◆ texture3DFiltering

Texture3DFiltering Aura2API.AuraQualitySettings.texture3DFiltering = Texture3DFiltering.Cubic

The sampling filter used for Texture3D

The documentation for this class was generated from the following file:
  • AuraQualitySettings.cs


Aura 2: Member List

  • AuraQualitySettings
Aura2API.AuraQualitySettings Member List

This is the complete list of members for Aura2API.AuraQualitySettings, including all inherited members.

debugOcclusionCulling | Aura2API.AuraQualitySettings
depthBiasCoefficient | Aura2API.AuraQualitySettings
displayVolumetricLightingBuffer | Aura2API.AuraQualitySettings
enableAmbientLighting | Aura2API.AuraQualitySettings
enableAutomaticStereoResizing | Aura2API.AuraQualitySettings
enableDirectionalLights | Aura2API.AuraQualitySettings
enableDirectionalLightsShadows | Aura2API.AuraQualitySettings
enableDithering | Aura2API.AuraQualitySettings
enableLightProbes | Aura2API.AuraQualitySettings
enableLightsCookies | Aura2API.AuraQualitySettings
enableOcclusionCulling | Aura2API.AuraQualitySettings
enablePointLights | Aura2API.AuraQualitySettings
enablePointLightsShadows | Aura2API.AuraQualitySettings
enableSpotLights | Aura2API.AuraQualitySettings
enableSpotLightsShadows | Aura2API.AuraQualitySettings
enableTemporalReprojection | Aura2API.AuraQualitySettings
enableVolumes | Aura2API.AuraQualitySettings
enableVolumesNoiseMask | Aura2API.AuraQualitySettings
enableVolumesTexture2DMask | Aura2API.AuraQualitySettings
enableVolumesTexture3DMask | Aura2API.AuraQualitySettings
EXPERIMENTAL_blurFilterGaussianDeviation | Aura2API.AuraQualitySettings
EXPERIMENTAL_blurFilterRange | Aura2API.AuraQualitySettings
EXPERIMENTAL_blurFilterType | Aura2API.AuraQualitySettings
EXPERIMENTAL_denoisingFilterRange | Aura2API.AuraQualitySettings
EXPERIMENTAL_enableBlurFilter | Aura2API.AuraQualitySettings
EXPERIMENTAL_enableDenoisingFilter | Aura2API.AuraQualitySettings
farClipPlaneDistance | Aura2API.AuraQualitySettings
frustumGridResolution | Aura2API.AuraQualitySettings
GetFrustumGridResolution(Camera camera) | Aura2API.AuraQualitySettings
occlusionCullingAccuracy | Aura2API.AuraQualitySettings
SetFrustumGridResolution(Vector3Int resolution) | Aura2API.AuraQualitySettings
temporalReprojectionFactor | Aura2API.AuraQualitySettings
texture3DFiltering | Aura2API.AuraQualitySettings


Aura 2: Aura2API.AuraResourcesCollection Class Reference

  • AuraResourcesCollection
Public Attributes | List of all members
Aura2API.AuraResourcesCollection Class Reference
Inheritance diagram for Aura2API.AuraResourcesCollection:

Public Attributes

ComputeShader | computeMaximumDepthComputeShader
Compute Shader in charge of computing the maximum depth for occlusion culling More...
ComputeShader | computeVisibleCellsComputeShader
Compute Shader in charge of ruling out the invisible cells of the volumetric grid More...
ComputeShader | computeDataComputeShader
Compute Shader in charge of computing the data contribution inside the frustum More...
ComputeShader | computeAccumulationComputeShader
Compute Shader in charge of accumulating the data More...
ComputeShader | renderLightProbesTextureComputeShader
Compute Shader in charge of rendering the light probes' coefficients into the 3D texture buffer More...
ComputeShader | applyDenoisingFilterComputeShader
Compute Shader in charge of applying the denoising filter More...
ComputeShader | applyBlurFilterComputeShader
Compute Shader in charge of applying the blur filter More...
Shader | processOcclusionMapShader
Shader in charge of filtering and formatting the maximum depth More...
Shader | postProcessShader
Shader used for applying the volumetric lighting as Post Process More...
Shader | storeDirectionalShadowDataShader
Shader used to copy the directional light's cascaded shadows projection data More...
Shader | storeDirectionalSpotCookieMapShader
Shader used to store the directional/spot light's cookie map More...
Shader | storePointShadowMapShader
Shader used to store the point light's shadow map (renders the TextureCUBE into a Texture2D) More...
Shader | storePointCookieMapShader
Shader used to store the point light's cookie map (renders the TextureCUBE into a Texture2D) More...
Shader | spriteLitShader
Lit shader used to make sprites work with the Aura system More...
Shader | spriteUnlitShader
Unlit shader used to make sprites work with the Aura system More...
Texture2DArray | blueNoiseTextureArray
Texture containing blue noise for dithering volumetric lighting More...
Texture2D | dummyTexture
Dummy Texture2D with 2x2 white pixels More...
Texture2DArray | dummyTextureArray
Dummy Texture2DArray with 2x2x1 white pixels More...
Texture3D | dummyTexture3D
Dummy Texture3D with 2x2x2 white pixels More...
Sprite | defaultSprite
Default Sprite texture More...
Mesh | storePointShadowMapMesh
Mesh used to store the point light's shadow map More...

Member Data Documentation

◆ applyBlurFilterComputeShader

ComputeShader Aura2API.AuraResourcesCollection.applyBlurFilterComputeShader

Compute Shader in charge of applying the blur filter

◆ applyDenoisingFilterComputeShader

ComputeShader Aura2API.AuraResourcesCollection.applyDenoisingFilterComputeShader

Compute Shader in charge of applying the denoising filter

◆ blueNoiseTextureArray

Texture2DArray Aura2API.AuraResourcesCollection.blueNoiseTextureArray

Texture containing blue noise for dithering volumetric lighting

◆ computeAccumulationComputeShader

ComputeShader Aura2API.AuraResourcesCollection.computeAccumulationComputeShader

Compute Shader in charge of accumulating the data

◆ computeDataComputeShader

ComputeShader Aura2API.AuraResourcesCollection.computeDataComputeShader

Compute Shader in charge of computing the data contribution inside the frustum

◆ computeMaximumDepthComputeShader

ComputeShader Aura2API.AuraResourcesCollection.computeMaximumDepthComputeShader

Compute Shader in charge of computing the maximum depth for occlusion culling

◆ computeVisibleCellsComputeShader

ComputeShader Aura2API.AuraResourcesCollection.computeVisibleCellsComputeShader

Compute Shader in charge of ruling out the invisible cells of the volumetric grid

◆ defaultSprite

Sprite Aura2API.AuraResourcesCollection.defaultSprite

Default Sprite texture

◆ dummyTexture

Texture2D Aura2API.AuraResourcesCollection.dummyTexture

Dummy Texture2D with 2x2 white pixels

◆ dummyTexture3D

Texture3D Aura2API.AuraResourcesCollection.dummyTexture3D

Dummy Texture3D with 2x2x2 white pixels

◆ dummyTextureArray

Texture2DArray Aura2API.AuraResourcesCollection.dummyTextureArray

Dummy Texture2DArray with 2x2x1 white pixels

◆ postProcessShader

Shader Aura2API.AuraResourcesCollection.postProcessShader

Shader used for applying the volumetric lighting as Post Process

◆ processOcclusionMapShader

Shader Aura2API.AuraResourcesCollection.processOcclusionMapShader

Shader in charge of filtering and formatting the maximum depth

◆ renderLightProbesTextureComputeShader

ComputeShader Aura2API.AuraResourcesCollection.renderLightProbesTextureComputeShader

Compute Shader in charge of rendering the light probes' coefficients into the 3D texture buffer

◆ spriteLitShader

Shader Aura2API.AuraResourcesCollection.spriteLitShader

Lit shader used to make sprites work with the Aura system

◆ spriteUnlitShader

Shader Aura2API.AuraResourcesCollection.spriteUnlitShader

Unlit shader used to make sprites work with the Aura system

◆ storeDirectionalShadowDataShader

Shader Aura2API.AuraResourcesCollection.storeDirectionalShadowDataShader

Shader used to copy the directional light's cascaded shadows projection data

◆ storeDirectionalSpotCookieMapShader

Shader Aura2API.AuraResourcesCollection.storeDirectionalSpotCookieMapShader

Shader used to store the directional/spot light's cookie map

◆ storePointCookieMapShader

Shader Aura2API.AuraResourcesCollection.storePointCookieMapShader

Shader used to store the point light's cookie map (renders the TextureCUBE into a Texture2D)

◆ storePointShadowMapMesh

Mesh Aura2API.AuraResourcesCollection.storePointShadowMapMesh

Mesh used to store the point light's shadow map

◆ storePointShadowMapShader

Shader Aura2API.AuraResourcesCollection.storePointShadowMapShader

Shader used to store the point light's shadow map (renders the TextureCUBE into a Texture2D)

The documentation for this class was generated from the following file:
  • AuraResourcesCollection.cs


Aura 2: Member List

  • AuraResourcesCollection
Aura2API.AuraResourcesCollection Member List

This is the complete list of members for Aura2API.AuraResourcesCollection, including all inherited members.

applyBlurFilterComputeShader | Aura2API.AuraResourcesCollection
applyDenoisingFilterComputeShader | Aura2API.AuraResourcesCollection
blueNoiseTextureArray | Aura2API.AuraResourcesCollection
computeAccumulationComputeShader | Aura2API.AuraResourcesCollection
computeDataComputeShader | Aura2API.AuraResourcesCollection
computeMaximumDepthComputeShader | Aura2API.AuraResourcesCollection
computeVisibleCellsComputeShader | Aura2API.AuraResourcesCollection
defaultSprite | Aura2API.AuraResourcesCollection
dummyTexture | Aura2API.AuraResourcesCollection
dummyTexture3D | Aura2API.AuraResourcesCollection
dummyTextureArray | Aura2API.AuraResourcesCollection
postProcessShader | Aura2API.AuraResourcesCollection
processOcclusionMapShader | Aura2API.AuraResourcesCollection
renderLightProbesTextureComputeShader | Aura2API.AuraResourcesCollection
spriteLitShader | Aura2API.AuraResourcesCollection
spriteUnlitShader | Aura2API.AuraResourcesCollection
storeDirectionalShadowDataShader | Aura2API.AuraResourcesCollection
storeDirectionalSpotCookieMapShader | Aura2API.AuraResourcesCollection
storePointCookieMapShader | Aura2API.AuraResourcesCollection
storePointShadowMapMesh | Aura2API.AuraResourcesCollection
storePointShadowMapShader | Aura2API.AuraResourcesCollection


Aura 2: Aura2API.AuraSprite Class Reference

  • AuraSprite
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | List of all members
Aura2API.AuraSprite Class Reference

Component allowing the sprites to work with the Aura system More...

Inheritance diagram for Aura2API.AuraSprite:

Public Member Functions

void | SetLitShader ()
void | SetUnlitShader ()

Static Public Member Functions

static GameObject CreateGameObject (string name, Sprite sprite)
Generic method for crating a GameObject with a AuraSprite component assigned More...

Public Attributes

ShadowCastingMode | shadowCastingMode = ShadowCastingMode.TwoSided
bool | receiveShadows = true

Properties

SpriteRenderer | SpriteRenderer [get]
Sprite | Sprite [get, set]

Detailed Description

Component allowing the sprites to work with the Aura system

Member Function Documentation

◆ CreateGameObject()

static GameObject Aura2API.AuraSprite.CreateGameObject | ( | string | name,
 |  | Sprite | sprite
 | ) |  |
static

Generic method for crating a GameObject with a AuraSprite component assigned

Parameters
name | Name of the created GameObject
sprite | Sprite texture
Returns
The created AuraVolume gameObject
The documentation for this class was generated from the following file:
  • AuraSprite.cs


Aura 2: Member List

  • AuraSprite
Aura2API.AuraSprite Member List

This is the complete list of members for Aura2API.AuraSprite, including all inherited members.

CreateGameObject(string name, Sprite sprite) | Aura2API.AuraSprite | static
receiveShadows (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |
SetLitShader() (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |
SetUnlitShader() (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |
shadowCastingMode (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |
Sprite (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |
SpriteRenderer (defined in Aura2API.AuraSprite) | Aura2API.AuraSprite |


Aura 2: Aura2API.AuraVolume Class Reference

  • AuraVolume
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | Events | List of all members
Aura2API.AuraVolume Class Reference

Component allowing the volume injection of density/scattering/light More...

Inheritance diagram for Aura2API.AuraVolume:
Aura2API.CullableObject

Public Member Functions

VolumeData GetData ()
Retrieves the packed data of the volume More...
- Public Member Functions inherited from Aura2API.CullableObject
void | UpdateBoundingSphere (Vector3 position, float radius)
Updates the bounding sphere used to cull with the camera More...
void | UpdateBoundingSphere (BoundingSphere boundingSphere)
Updates the bounding sphere used to cull with the camera More...
bool | CheckFrustumOverlap (Plane[] frustumPlanes)

Static Public Member Functions

static GameObject CreateGameObject (string name, VolumeType shape)
Generic method for crating a GameObject with a AuraVolume component assigned More...

Public Attributes

VolumeInjectionShape volumeShape
Shape of the volume and its fading parameters"
More...
bool | useAsLightProbesProxyVolume = false
Enables the volume to show the light probes lighting More...
float | lightProbesMultiplier = 1
Multiplies the light probes lighting More...
Texture2DMask texture2DMask
Texture2D mask (RGB for color, A for density and scattering) More...
Texture3DMask texture3DMask
Texture3D mask (RGB for color, A for density and scattering) More...
DynamicNoiseParameters noiseMask
Volumetric noise mask More...
VolumeInjectionCommonParameters densityInjection
Density injection parameters More...
VolumeInjectionCommonParameters scatteringInjection
Scattering injection parameters More...
VolumeInjectionColorParameters lightInjection
Light injection parameters More...
VolumeInjectionColorParameters tintInjection
Tint injection parameters More...
VolumeInjectionCommonParameters ambientInjection
Ambient lighting injection parameters More...
VolumeInjectionCommonParameters boostInjection
Boost injection parameters More...

Properties

Bounds | Bounds [get]
The bounds of the current volume More...
bool | UsesTexture2DMasking [get]
Tells if it should use Texture2D masking More...
bool | ShoukdComputeTexture2DMasking [get]
Tells if it should compute Texture2D masking More...
bool | UsesTexture3DMasking [get]
Tells if it should use Texture3D masking More...
bool | ShouldComputeTexture3DMasking [get]
Tells if it should compute Texture3D masking More...
bool | ShouldComputeNoise [get]
Tells if it should compute Noise More...
- Properties inherited from Aura2API.CullableObject
BoundingSphere | BoundingSphere [get]
Accessor to the bounding sphere used to cull with the camera More...

Events

Action< AuraVolume > OnUninitialize
Event raised when the volume is being uninitialized More...

Detailed Description

Component allowing the volume injection of density/scattering/light

Member Function Documentation

◆ CreateGameObject()

static GameObject Aura2API.AuraVolume.CreateGameObject | ( | string | name,
 |  | VolumeType | shape
 | ) |  |
static

Generic method for crating a GameObject with a AuraVolume component assigned

Parameters
name | Name of the created GameObject
shape | Desired volume shape
Returns
The created AuraVolume gameObject

◆ GetData()

VolumeData Aura2API.AuraVolume.GetData ( )

Retrieves the packed data of the volume

Returns
The packed data of the volume

Member Data Documentation

◆ ambientInjection

VolumeInjectionCommonParameters Aura2API.AuraVolume.ambientInjection

Ambient lighting injection parameters

◆ boostInjection

VolumeInjectionCommonParameters Aura2API.AuraVolume.boostInjection

Boost injection parameters

◆ densityInjection

VolumeInjectionCommonParameters Aura2API.AuraVolume.densityInjection

Density injection parameters

◆ lightInjection

VolumeInjectionColorParameters Aura2API.AuraVolume.lightInjection

Light injection parameters

◆ lightProbesMultiplier

float Aura2API.AuraVolume.lightProbesMultiplier = 1

Multiplies the light probes lighting

◆ noiseMask

DynamicNoiseParameters Aura2API.AuraVolume.noiseMask

Volumetric noise mask

◆ scatteringInjection

VolumeInjectionCommonParameters Aura2API.AuraVolume.scatteringInjection

Scattering injection parameters

◆ texture2DMask

Texture2DMask Aura2API.AuraVolume.texture2DMask

Texture2D mask (RGB for color, A for density and scattering)

◆ texture3DMask

Texture3DMask Aura2API.AuraVolume.texture3DMask

Texture3D mask (RGB for color, A for density and scattering)

◆ tintInjection

VolumeInjectionColorParameters Aura2API.AuraVolume.tintInjection

Tint injection parameters

◆ useAsLightProbesProxyVolume

bool Aura2API.AuraVolume.useAsLightProbesProxyVolume = false

Enables the volume to show the light probes lighting

◆ volumeShape

VolumeInjectionShape Aura2API.AuraVolume.volumeShape

Shape of the volume and its fading parameters"

Property Documentation

◆ Bounds

Bounds Aura2API.AuraVolume.Bounds
get

The bounds of the current volume

◆ ShoukdComputeTexture2DMasking

bool Aura2API.AuraVolume.ShoukdComputeTexture2DMasking
get

Tells if it should compute Texture2D masking

◆ ShouldComputeNoise

bool Aura2API.AuraVolume.ShouldComputeNoise
get

Tells if it should compute Noise

◆ ShouldComputeTexture3DMasking

bool Aura2API.AuraVolume.ShouldComputeTexture3DMasking
get

Tells if it should compute Texture3D masking

◆ UsesTexture2DMasking

bool Aura2API.AuraVolume.UsesTexture2DMasking
get

Tells if it should use Texture2D masking

◆ UsesTexture3DMasking

bool Aura2API.AuraVolume.UsesTexture3DMasking
get

Tells if it should use Texture3D masking

Event Documentation

◆ OnUninitialize

Action<AuraVolume> Aura2API.AuraVolume.OnUninitialize

Event raised when the volume is being uninitialized

The documentation for this class was generated from the following file:
  • AuraVolume.cs


Aura 2: Member List

  • AuraVolume
Aura2API.AuraVolume Member List

This is the complete list of members for Aura2API.AuraVolume, including all inherited members.

ambientInjection | Aura2API.AuraVolume |
boostInjection | Aura2API.AuraVolume |
BoundingSphere | Aura2API.CullableObject |
Bounds | Aura2API.AuraVolume |
CheckFrustumOverlap(Plane[] frustumPlanes) | Aura2API.CullableObject |
CreateGameObject(string name, VolumeType shape) | Aura2API.AuraVolume | static
densityInjection | Aura2API.AuraVolume |
GetData() | Aura2API.AuraVolume |
lightInjection | Aura2API.AuraVolume |
lightProbesMultiplier | Aura2API.AuraVolume |
noiseMask | Aura2API.AuraVolume |
OnUninitialize | Aura2API.AuraVolume |
scatteringInjection | Aura2API.AuraVolume |
ShoukdComputeTexture2DMasking | Aura2API.AuraVolume |
ShouldComputeNoise | Aura2API.AuraVolume |
ShouldComputeTexture3DMasking | Aura2API.AuraVolume |
texture2DMask | Aura2API.AuraVolume |
texture3DMask | Aura2API.AuraVolume |
tintInjection | Aura2API.AuraVolume |
Aura2API::CullableObject.UpdateBoundingSphere(Vector3 position, float radius) | Aura2API.CullableObject |
Aura2API::CullableObject.UpdateBoundingSphere(BoundingSphere boundingSphere) | Aura2API.CullableObject |
useAsLightProbesProxyVolume | Aura2API.AuraVolume |
UsesTexture2DMasking | Aura2API.AuraVolume |
UsesTexture3DMasking | Aura2API.AuraVolume |
volumeShape | Aura2API.AuraVolume |


Aura 2: Aura2API.ColorCircularPickerAttribute Class Reference

  • ColorCircularPickerAttribute
Public Member Functions | Public Attributes | List of all members
Aura2API.ColorCircularPickerAttribute Class Reference

Custom attribute for enabling circular picker on Color properties More...

Inheritance diagram for Aura2API.ColorCircularPickerAttribute:

Public Member Functions

ColorCircularPickerAttribute (bool showLabel=false)
Enables circular picker on Color properties More...

Public Attributes

readonly bool showLabel
Enables the display of the name of the property More...

Detailed Description

Custom attribute for enabling circular picker on Color properties

Constructor & Destructor Documentation

◆ ColorCircularPickerAttribute()

Aura2API.ColorCircularPickerAttribute.ColorCircularPickerAttribute ( bool showLabel = false )

Enables circular picker on Color properties

Parameters
showLabel Enables the display of the name of the property

Member Data Documentation

◆ showLabel

readonly bool Aura2API.ColorCircularPickerAttribute.showLabel

Enables the display of the name of the property

The documentation for this class was generated from the following file:
  • ColorCircularPickerAttribute.cs


Aura 2: Member List

  • ColorCircularPickerAttribute
Aura2API.ColorCircularPickerAttribute Member List

This is the complete list of members for Aura2API.ColorCircularPickerAttribute, including all inherited members.

ColorCircularPickerAttribute(bool showLabel=false) | Aura2API.ColorCircularPickerAttribute
showLabel | Aura2API.ColorCircularPickerAttribute


Aura 2: Aura2API.CommonDataManager Class Reference

  • CommonDataManager
Public Member Functions | Properties | List of all members
Aura2API.CommonDataManager Class Reference

Handles the lights' and volumes' commond data managers More...

Public Member Functions

void | Dispose ()
Releases all the managed members More...
void | UpdateData ()
Updates all the data More...

Properties

LightsCommonDataManager | LightsCommonDataManager [get]
The manager that handles the lights' registration, maps collection and culling More...
VolumesCommonDataManager | VolumesCommonDataManager [get]
The manager that handles the lights' registration, maps collection and culling More...
AmbientLightingCommonDataManager | AmbientLightingCommonDataManager [get]
The manager that handles the ambient lighting data More...

Detailed Description

Handles the lights' and volumes' commond data managers

Member Function Documentation

◆ Dispose()

void Aura2API.CommonDataManager.Dispose ( )

Releases all the managed members

◆ UpdateData()

void Aura2API.CommonDataManager.UpdateData ( )

Updates all the data

Property Documentation

◆ AmbientLightingCommonDataManager

AmbientLightingCommonDataManager Aura2API.CommonDataManager.AmbientLightingCommonDataManager
get

The manager that handles the ambient lighting data

◆ LightsCommonDataManager

LightsCommonDataManager Aura2API.CommonDataManager.LightsCommonDataManager
get

The manager that handles the lights' registration, maps collection and culling

◆ VolumesCommonDataManager

VolumesCommonDataManager Aura2API.CommonDataManager.VolumesCommonDataManager
get

The manager that handles the lights' registration, maps collection and culling

The documentation for this class was generated from the following file:
  • CommonDataManager.cs


Aura 2: Member List

  • CommonDataManager
Aura2API.CommonDataManager Member List

This is the complete list of members for Aura2API.CommonDataManager, including all inherited members.

AmbientLightingCommonDataManager | Aura2API.CommonDataManager
Dispose() | Aura2API.CommonDataManager
LightsCommonDataManager | Aura2API.CommonDataManager
UpdateData() | Aura2API.CommonDataManager
VolumesCommonDataManager | Aura2API.CommonDataManager


Aura 2: Aura2API.CullableObject Class Reference

  • CullableObject
Public Member Functions | Properties | List of all members
Aura2API.CullableObject Class Reference

Class to inherit from when using an ObjectCuller More...

Inheritance diagram for Aura2API.CullableObject:
Aura2API.AuraLight Aura2API.AuraVolume

Public Member Functions

void | UpdateBoundingSphere (Vector3 position, float radius)
Updates the bounding sphere used to cull with the camera More...
void | UpdateBoundingSphere (BoundingSphere boundingSphere)
Updates the bounding sphere used to cull with the camera More...
bool | CheckFrustumOverlap (Plane[] frustumPlanes)

Properties

BoundingSphere BoundingSphere [get]
Accessor to the bounding sphere used to cull with the camera More...

Detailed Description

Class to inherit from when using an ObjectCuller

Member Function Documentation

◆ CheckFrustumOverlap()

bool Aura2API.CullableObject.CheckFrustumOverlap ( Plane [] frustumPlanes )

Parameters
frustumPlanes
Returns

◆ UpdateBoundingSphere() [1/2]

void Aura2API.CullableObject.UpdateBoundingSphere | ( | Vector3 | position,
 |  | float | radius
 | ) |  |

Updates the bounding sphere used to cull with the camera

Parameters
position | The new postition
radius | The new radius

◆ UpdateBoundingSphere() [2/2]

void Aura2API.CullableObject.UpdateBoundingSphere ( BoundingSphere boundingSphere )

Updates the bounding sphere used to cull with the camera

Parameters
boundingSphere The reference bounding sphere

Property Documentation

◆ BoundingSphere

BoundingSphere Aura2API.CullableObject.BoundingSphere
get

Accessor to the bounding sphere used to cull with the camera

The documentation for this class was generated from the following file:
  • CullableObject.cs


Aura 2: Member List

  • CullableObject
Aura2API.CullableObject Member List

This is the complete list of members for Aura2API.CullableObject, including all inherited members.

BoundingSphere | Aura2API.CullableObject
CheckFrustumOverlap(Plane[] frustumPlanes) | Aura2API.CullableObject
UpdateBoundingSphere(Vector3 position, float radius) | Aura2API.CullableObject
UpdateBoundingSphere(BoundingSphere boundingSphere) | Aura2API.CullableObject


Aura 2: Aura2API.DirectionalLightParameters Struct Reference

  • DirectionalLightParameters
Public Attributes | Properties | List of all members
Aura2API.DirectionalLightParameters Struct Reference

Struct containing parameters of a directional AuraLight More...

Public Attributes

Vector3 | color
int | useDefaultScattering
float | scatteringOverride
Vector3 | lightPosition
Vector3 | lightDirection
MatrixFloats | worldToLightMatrix
MatrixFloats | lightToWorldMatrix
int | shadowMapIndex
int | cookieMapIndex
Vector2 | cookieParameters
int | enableOutOfPhaseColor
Vector3 | outOfPhaseColor

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing parameters of a directional AuraLight

Property Documentation

◆ Size

int Aura2API.DirectionalLightParameters.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • DirectionalLightParameters.cs


Aura 2: Member List

  • DirectionalLightParameters
Aura2API.DirectionalLightParameters Member List

This is the complete list of members for Aura2API.DirectionalLightParameters, including all inherited members.

color (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
cookieMapIndex (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
cookieParameters (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
enableOutOfPhaseColor (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
lightDirection (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
lightPosition (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
lightToWorldMatrix (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
outOfPhaseColor (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
scatteringOverride (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
shadowMapIndex (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
Size | Aura2API.DirectionalLightParameters | static
useDefaultScattering (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |
worldToLightMatrix (defined in Aura2API.DirectionalLightParameters) | Aura2API.DirectionalLightParameters |


Aura 2: Aura2API.DirectionalLightsManager Class Reference

  • DirectionalLightsManager
Public Member Functions | Static Public Attributes | Properties | List of all members
Aura2API.DirectionalLightsManager Class Reference

Manager that handles directional AuraLights More...

Public Member Functions

void | Dispose ()
Disposes the members More...
void | Update ()
Updates the manager (collects shadows/cookies/data and packs them) More...

Static Public Attributes

static readonly Vector2Int cookieMapSize = new Vector2Int(256, 256)
The cookie map size More...

Properties

static Vector2Int | ShadowMapSize [get]
Accessor to the shadow map size (depending on the shadow cascade count) More...
List< AuraLight > | CandidateLights [get]
Accessor to the candidate lights More...
int | CandidateLightsCount [get]
Tells how many lights are candidate More...
bool | HasCandidateLights [get]
Tells if has candidate lights More...
ComputeBuffer | EmptyBuffer [get]
One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility) More...
ComputeBuffer | DataBuffer [get]
Accessor to the compute buffer containing the packed data of the visible lights More...

Detailed Description

Manager that handles directional AuraLights

Member Function Documentation

◆ Dispose()

void Aura2API.DirectionalLightsManager.Dispose ( )

Disposes the members

◆ Update()

void Aura2API.DirectionalLightsManager.Update ( )

Updates the manager (collects shadows/cookies/data and packs them)

Member Data Documentation

◆ cookieMapSize

readonly Vector2Int Aura2API.DirectionalLightsManager.cookieMapSize = new Vector2Int(256, 256)
static

The cookie map size

Property Documentation

◆ CandidateLights

List<AuraLight> Aura2API.DirectionalLightsManager.CandidateLights
get

Accessor to the candidate lights

◆ CandidateLightsCount

int Aura2API.DirectionalLightsManager.CandidateLightsCount
get

Tells how many lights are candidate

◆ DataBuffer

ComputeBuffer Aura2API.DirectionalLightsManager.DataBuffer
get

Accessor to the compute buffer containing the packed data of the visible lights

◆ EmptyBuffer

ComputeBuffer Aura2API.DirectionalLightsManager.EmptyBuffer
get

One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility)

◆ HasCandidateLights

bool Aura2API.DirectionalLightsManager.HasCandidateLights
get

Tells if has candidate lights

◆ ShadowMapSize

Vector2Int Aura2API.DirectionalLightsManager.ShadowMapSize
staticget

Accessor to the shadow map size (depending on the shadow cascade count)

The documentation for this class was generated from the following file:
  • DirectionalLightsManager.cs


Aura 2: Member List

  • DirectionalLightsManager
Aura2API.DirectionalLightsManager Member List

This is the complete list of members for Aura2API.DirectionalLightsManager, including all inherited members.

CandidateLights | Aura2API.DirectionalLightsManager |
CandidateLightsCount | Aura2API.DirectionalLightsManager |
cookieMapSize | Aura2API.DirectionalLightsManager | static
DataBuffer | Aura2API.DirectionalLightsManager |
Dispose() | Aura2API.DirectionalLightsManager |
EmptyBuffer | Aura2API.DirectionalLightsManager |
HasCandidateLights | Aura2API.DirectionalLightsManager |
ShadowMapSize | Aura2API.DirectionalLightsManager | static
Update() | Aura2API.DirectionalLightsManager |


Aura 2: Aura2API.DirectionalShadowDataCollector Class Reference

  • DirectionalShadowDataCollector
Public Member Functions | List of all members
Aura2API.DirectionalShadowDataCollector Class Reference

Texture2DArray composer used for collecting directional shadow data maps More...

Inheritance diagram for Aura2API.DirectionalShadowDataCollector:
Aura2API.Texture2DArrayComposer

Public Member Functions

DirectionalShadowDataCollector ()
Constructor More...
- Public Member Functions inherited from Aura2API.Texture2DArrayComposer
Texture2DArrayComposer (int sizeX, int sizeY, TextureFormat format, bool bypassSrgb)
Constructor More...
void | RaiseTextureUpdatedEvent ()
Raises the OnTextureUpdated event More...
bool | AddTexture (Texture texture)
Adds a new candidate Texture More...
bool | RemoveTexture (Texture texture)
Remove a Texture from the candidate Textures list More...
bool | RemoveTexture (int id)
Remove a Texture from the candidate Textures list More...
void | Generate ()
Launches the Texture2DArray generation (already handles NeedsToUpdateVolumeTexture and alwaysGenerateOnUpdate parameters check) More...
int | GetTextureIndex (Texture texture)
Returns the ID of the Texture inside the Texture2DArray More...
void | ClearTexturesList ()
Clears the candidate Textures list More...
void | Resize (int sizeX, int sizeY)
Changes the size of the Texture2DArray to be generated (candidate Texture list will be cleared) More...

Additional Inherited Members

- Public Attributes inherited from Aura2API.Texture2DArrayComposer
bool | alwaysGenerateOnUpdate
Forces the Texture2DArray to be re-generated everytime Generate() is called. More...
- Properties inherited from Aura2API.Texture2DArrayComposer
int | RequiredSizeX [get]
The horizontal size of the Texture2DArray More...
int | RequiredSizeY [get]
The vertical size of the Texture2DArray More...
int | TextureCount [get]
Returns the amount of candidate Textures More...
Texture2DArray | Texture [get]
Accessor to the generated Texture2DArray More...
bool | HasTexture [get]
Tells if a Texture2DArray has been generated More...
bool | NeedsToUpdateTexture [get]
Tells if changes were made and Generate() should be called More...
- Events inherited from Aura2API.Texture2DArrayComposer
EventHandler | OnTextureUpdated

Detailed Description

Texture2DArray composer used for collecting directional shadow data maps

Constructor & Destructor Documentation

◆ DirectionalShadowDataCollector()

Aura2API.DirectionalShadowDataCollector.DirectionalShadowDataCollector ( )

Constructor

Parameters
sizeX | The width of the built Texture2DArray
sizeY | The height of the built Texture2DArray
The documentation for this class was generated from the following file:
  • DirectionalShadowDataCollector.cs


Aura 2: Member List

  • DirectionalShadowDataCollector
Aura2API.DirectionalShadowDataCollector Member List

This is the complete list of members for Aura2API.DirectionalShadowDataCollector, including all inherited members.

AddTexture(Texture texture) | Aura2API.Texture2DArrayComposer
alwaysGenerateOnUpdate | Aura2API.Texture2DArrayComposer
ClearTexturesList() | Aura2API.Texture2DArrayComposer
DirectionalShadowDataCollector() | Aura2API.DirectionalShadowDataCollector
Generate() | Aura2API.Texture2DArrayComposer
GetTextureIndex(Texture texture) | Aura2API.Texture2DArrayComposer
HasTexture | Aura2API.Texture2DArrayComposer
NeedsToUpdateTexture | Aura2API.Texture2DArrayComposer
OnTextureUpdated (defined in Aura2API.Texture2DArrayComposer) | Aura2API.Texture2DArrayComposer
RaiseTextureUpdatedEvent() | Aura2API.Texture2DArrayComposer
RemoveTexture(Texture texture) | Aura2API.Texture2DArrayComposer
RemoveTexture(int id) | Aura2API.Texture2DArrayComposer
RequiredSizeX | Aura2API.Texture2DArrayComposer
RequiredSizeY | Aura2API.Texture2DArrayComposer
Resize(int sizeX, int sizeY) | Aura2API.Texture2DArrayComposer
Texture | Aura2API.Texture2DArrayComposer
Texture2DArrayComposer(int sizeX, int sizeY, TextureFormat format, bool bypassSrgb) | Aura2API.Texture2DArrayComposer
TextureCount | Aura2API.Texture2DArrayComposer


Aura 2: Aura2API.DynamicNoiseParameters Struct Reference

  • DynamicNoiseParameters
Public Attributes | List of all members
Aura2API.DynamicNoiseParameters Struct Reference

Collection of parameters for 4D dynamic noise mask to be used in a volume More...

Public Attributes

bool | enable
Enables the dynamic noise computation More...
float | speed
The speed of the mutation More...
TransformParameters transform
Allows to set base position, rotation and scale and animate them More...

Detailed Description

Collection of parameters for 4D dynamic noise mask to be used in a volume

Member Data Documentation

◆ enable

bool Aura2API.DynamicNoiseParameters.enable

Enables the dynamic noise computation

◆ speed

float Aura2API.DynamicNoiseParameters.speed

The speed of the mutation

◆ transform

TransformParameters Aura2API.DynamicNoiseParameters.transform

Allows to set base position, rotation and scale and animate them

The documentation for this struct was generated from the following file:
  • DynamicNoiseParameters.cs


Aura 2: Member List

  • DynamicNoiseParameters
Aura2API.DynamicNoiseParameters Member List

This is the complete list of members for Aura2API.DynamicNoiseParameters, including all inherited members.

enable | Aura2API.DynamicNoiseParameters
speed | Aura2API.DynamicNoiseParameters
transform | Aura2API.DynamicNoiseParameters


Aura 2: Aura2API.Frustum Class Reference

  • Frustum
Public Member Functions | Public Attributes | List of all members
Aura2API.Frustum Class Reference

Ranged camera frustum inside which the volumetric data will be computed More...

Public Member Functions

Frustum (FrustumSettings frustumSettings, Camera camera, AuraCamera auraComponent)
Constructor More...
void | ComputeData ()
Computes the volumetric data More...
void | Dispose ()
Disposes the managed members More...
void | SetFrustumGridResolution (Vector3Int frustumGridResolution)
Sets a new frustum resolution More...

Public Attributes

ComputeShader _computeVisibleCellsComputeShader
Compute Shader in charge of ruling out the invisible cells of the volumetric grid More...

Detailed Description

Ranged camera frustum inside which the volumetric data will be computed

Constructor & Destructor Documentation

◆ Frustum()

Aura2API.Frustum.Frustum | ( | FrustumSettings | frustumSettings,
 |  | Camera | camera,
 |  | AuraCamera | auraComponent
 | ) |  |

Constructor

Member Function Documentation

◆ ComputeData()

void Aura2API.Frustum.ComputeData ( )

Computes the volumetric data

◆ Dispose()

void Aura2API.Frustum.Dispose ( )

Disposes the managed members

◆ SetFrustumGridResolution()

void Aura2API.Frustum.SetFrustumGridResolution ( Vector3Int frustumGridResolution )

Sets a new frustum resolution

Parameters
frustumGridResolution The desired resolution

Member Data Documentation

◆ _computeVisibleCellsComputeShader

ComputeShader Aura2API.Frustum._computeVisibleCellsComputeShader

Compute Shader in charge of ruling out the invisible cells of the volumetric grid

The documentation for this class was generated from the following file:
  • Frustum.cs


Aura 2: Member List

  • Frustum
Aura2API.Frustum Member List

This is the complete list of members for Aura2API.Frustum, including all inherited members.

_computeVisibleCellsComputeShader | Aura2API.Frustum
ComputeData() | Aura2API.Frustum
Dispose() | Aura2API.Frustum
Frustum(FrustumSettings frustumSettings, Camera camera, AuraCamera auraComponent) | Aura2API.Frustum
SetFrustumGridResolution(Vector3Int frustumGridResolution) | Aura2API.Frustum


Aura 2: Aura2API.FrustumSettings Class Reference

  • FrustumSettings
Public Member Functions | Public Attributes | Properties | Events | List of all members
Aura2API.FrustumSettings Class Reference

Collection of settings for the data computation More...

Public Member Functions

void | LoadBaseSettings (AuraBaseSettings baseSettings)
Replaces the current frustum base settings More...
void | LoadQualitySettings (AuraQualitySettings qualitySettings)
Replaces the current quality settings More...
void | RaiseOnQualityChanged ()
Raises the OnFrustumQualityChanged event More...

Public Attributes

AuraBaseSettings baseSettings
The ambient injection settings More...
AuraQualitySettings qualitySettings
The quality of the data computation More...

Properties

AuraBaseSettings | BaseSettings [get, set]
The ambient injection settings More...
AuraQualitySettings | QualitySettings [get, set]
The quality of the data computation More...

Events

Action OnFrustumQualityChanged
Event raised when the frustum quality preset has been changed More...

Detailed Description

Collection of settings for the data computation

Member Function Documentation

◆ LoadBaseSettings()

void Aura2API.FrustumSettings.LoadBaseSettings ( AuraBaseSettings baseSettings )

Replaces the current frustum base settings

Parameters
baseSettings the replacing frustum base settings

◆ LoadQualitySettings()

void Aura2API.FrustumSettings.LoadQualitySettings ( AuraQualitySettings qualitySettings )

Replaces the current quality settings

Parameters
qualitySettings the replacing quality settings

◆ RaiseOnQualityChanged()

void Aura2API.FrustumSettings.RaiseOnQualityChanged ( )

Raises the OnFrustumQualityChanged event

Member Data Documentation

◆ baseSettings

AuraBaseSettings Aura2API.FrustumSettings.baseSettings

The ambient injection settings

◆ qualitySettings

AuraQualitySettings Aura2API.FrustumSettings.qualitySettings

The quality of the data computation

Property Documentation

◆ BaseSettings

AuraBaseSettings Aura2API.FrustumSettings.BaseSettings
getset

The ambient injection settings

◆ QualitySettings

AuraQualitySettings Aura2API.FrustumSettings.QualitySettings
getset

The quality of the data computation

Event Documentation

◆ OnFrustumQualityChanged

Action Aura2API.FrustumSettings.OnFrustumQualityChanged

Event raised when the frustum quality preset has been changed

The documentation for this class was generated from the following file:
  • FrustumSettings.cs


Aura 2: Member List

  • FrustumSettings
Aura2API.FrustumSettings Member List

This is the complete list of members for Aura2API.FrustumSettings, including all inherited members.

baseSettings | Aura2API.FrustumSettings
BaseSettings | Aura2API.FrustumSettings
LoadBaseSettings(AuraBaseSettings baseSettings) | Aura2API.FrustumSettings
LoadQualitySettings(AuraQualitySettings qualitySettings) | Aura2API.FrustumSettings
OnFrustumQualityChanged | Aura2API.FrustumSettings
QualitySettings | Aura2API.FrustumSettings
qualitySettings | Aura2API.FrustumSettings
RaiseOnQualityChanged() | Aura2API.FrustumSettings


Aura 2: Aura2API.FrustumSettingsParameters Struct Reference

  • FrustumSettingsParameters
Public Member Functions | Public Attributes | List of all members
Aura2API.FrustumSettingsParameters Struct Reference

Collection of settings defining the computation of the volumetric data More...

Public Member Functions

void Init ()
Initializes the struct to default values More...

Public Attributes

bool | enableVolumes
Enables the computation of volumes More...
bool | enableVolumesTextureMask
Enables the computation of volumes' texture mask More...
bool | enableVolumesNoiseMask
Enables the computation of volumes' noise mask More...
bool | enableDirectionalLights
Enables the computation of directional lights More...
bool | enableDirectionalLightsShadows
Enables the computation of directional lights' shadow More...
bool | enableSpotLights
Enables the computation of spot lights More...
bool | enableSpotLightsShadows
Enables the computation of spot lights' shadow More...
bool | enablePointLights
Enables the computation of point lights More...
bool | enablePointLightsShadows
Enables the computation of point lights' shadow More...
bool | enableLightsCookies
Enables the computation of lights' cookie More...
bool | enableOcclusionCulling
Enables depth occlusion culling More...
OcclusionCullingAccuracy occlusionCullingAccuracy
The accuracy of the occlusion search More...
bool | enableTemporalReprojection
Enables temporal reprojection More...
float | temporalReprojectionFactor
Amount of reprojection with the previous frame More...
Vector3Int | resolution
The resolution of the frustum grid More...
float | farClipPlaneDistance
The maximum distance where the volumetric data will be computed More...

Detailed Description

Collection of settings defining the computation of the volumetric data

Member Function Documentation

◆ Init()

void Aura2API.FrustumSettingsParameters.Init ( )

Initializes the struct to default values

Member Data Documentation

◆ enableDirectionalLights

bool Aura2API.FrustumSettingsParameters.enableDirectionalLights

Enables the computation of directional lights

◆ enableDirectionalLightsShadows

bool Aura2API.FrustumSettingsParameters.enableDirectionalLightsShadows

Enables the computation of directional lights' shadow

◆ enableLightsCookies

bool Aura2API.FrustumSettingsParameters.enableLightsCookies

Enables the computation of lights' cookie

◆ enableOcclusionCulling

bool Aura2API.FrustumSettingsParameters.enableOcclusionCulling

Enables depth occlusion culling

◆ enablePointLights

bool Aura2API.FrustumSettingsParameters.enablePointLights

Enables the computation of point lights

◆ enablePointLightsShadows

bool Aura2API.FrustumSettingsParameters.enablePointLightsShadows

Enables the computation of point lights' shadow

◆ enableSpotLights

bool Aura2API.FrustumSettingsParameters.enableSpotLights

Enables the computation of spot lights

◆ enableSpotLightsShadows

bool Aura2API.FrustumSettingsParameters.enableSpotLightsShadows

Enables the computation of spot lights' shadow

◆ enableTemporalReprojection

bool Aura2API.FrustumSettingsParameters.enableTemporalReprojection

Enables temporal reprojection

◆ enableVolumes

bool Aura2API.FrustumSettingsParameters.enableVolumes

Enables the computation of volumes

◆ enableVolumesNoiseMask

bool Aura2API.FrustumSettingsParameters.enableVolumesNoiseMask

Enables the computation of volumes' noise mask

◆ enableVolumesTextureMask

bool Aura2API.FrustumSettingsParameters.enableVolumesTextureMask

Enables the computation of volumes' texture mask

◆ farClipPlaneDistance

float Aura2API.FrustumSettingsParameters.farClipPlaneDistance

The maximum distance where the volumetric data will be computed

◆ occlusionCullingAccuracy

OcclusionCullingAccuracy Aura2API.FrustumSettingsParameters.occlusionCullingAccuracy

The accuracy of the occlusion search

◆ resolution

Vector3Int Aura2API.FrustumSettingsParameters.resolution

The resolution of the frustum grid

◆ temporalReprojectionFactor

float Aura2API.FrustumSettingsParameters.temporalReprojectionFactor

Amount of reprojection with the previous frame

The documentation for this struct was generated from the following file:
  • FrustumSettingsParameters.cs


Aura 2: Member List

  • FrustumSettingsParameters
Aura2API.FrustumSettingsParameters Member List

This is the complete list of members for Aura2API.FrustumSettingsParameters, including all inherited members.

enableDirectionalLights | Aura2API.FrustumSettingsParameters
enableDirectionalLightsShadows | Aura2API.FrustumSettingsParameters
enableLightsCookies | Aura2API.FrustumSettingsParameters
enableOcclusionCulling | Aura2API.FrustumSettingsParameters
enablePointLights | Aura2API.FrustumSettingsParameters
enablePointLightsShadows | Aura2API.FrustumSettingsParameters
enableSpotLights | Aura2API.FrustumSettingsParameters
enableSpotLightsShadows | Aura2API.FrustumSettingsParameters
enableTemporalReprojection | Aura2API.FrustumSettingsParameters
enableVolumes | Aura2API.FrustumSettingsParameters
enableVolumesNoiseMask | Aura2API.FrustumSettingsParameters
enableVolumesTextureMask | Aura2API.FrustumSettingsParameters
farClipPlaneDistance | Aura2API.FrustumSettingsParameters
Init() | Aura2API.FrustumSettingsParameters
occlusionCullingAccuracy | Aura2API.FrustumSettingsParameters
resolution | Aura2API.FrustumSettingsParameters
temporalReprojectionFactor | Aura2API.FrustumSettingsParameters


Aura 2: Aura2API.FrustumSettingsToId Class Reference

  • FrustumSettingsToId
Public Member Functions | List of all members
Aura2API.FrustumSettingsToId Class Reference

Collects all the settings and compute the flag Id to be used as kernel id of the computeDataComputeShader More...

Public Member Functions

FrustumSettingsToId (FrustumSettings settings, AuraCamera auraComponent, VolumesManager volumesManager, SpotLightsManager spotLightsManager, PointLightsManager pointLightsManager)
int | GetKernelId ()
Returns a unique int relative to the combinaison of the different parameters More...
int | GetKernelId (Camera camera)
Returns the kernel Id that should be used for compute shader, checks for single pass stereo as well More...
void | ComputeFlags ()
Recomputes the bitmask of the options More...
bool | HasFlags (FrustumParameters flags)
Tells if the specified flags combinaision is found inside the parameters bitmask More...

Detailed Description

Collects all the settings and compute the flag Id to be used as kernel id of the computeDataComputeShader

Member Function Documentation

◆ ComputeFlags()

void Aura2API.FrustumSettingsToId.ComputeFlags ( )

Recomputes the bitmask of the options

◆ GetKernelId() [1/2]

int Aura2API.FrustumSettingsToId.GetKernelId ( )

Returns a unique int relative to the combinaison of the different parameters

Parameters
recomputeFlags Forces the Id recomputation. Default : false
Returns
A unique int relative to the combinaison of the different parameters

Returns the kernel Id that should be used for compute shader

Returns
The kernel Id

◆ GetKernelId() [2/2]

int Aura2API.FrustumSettingsToId.GetKernelId ( Camera camera )

Returns the kernel Id that should be used for compute shader, checks for single pass stereo as well

Returns
The kernel Id

◆ HasFlags()

bool Aura2API.FrustumSettingsToId.HasFlags ( FrustumParameters flags )

Tells if the specified flags combinaision is found inside the parameters bitmask

Parameters
flags A combinaison of flags
Returns
Is the flags combinaison found in the parameters bitmask
The documentation for this class was generated from the following file:
  • FrustumSettingsToId.cs


Aura 2: Member List

  • FrustumSettingsToId
Aura2API.FrustumSettingsToId Member List

This is the complete list of members for Aura2API.FrustumSettingsToId, including all inherited members.

ComputeFlags() | Aura2API.FrustumSettingsToId
FrustumSettingsToId(FrustumSettings settings, AuraCamera auraComponent, VolumesManager volumesManager, SpotLightsManager spotLightsManager, PointLightsManager pointLightsManager) (defined in Aura2API.FrustumSettingsToId) | Aura2API.FrustumSettingsToId
GetKernelId() | Aura2API.FrustumSettingsToId
GetKernelId(Camera camera) | Aura2API.FrustumSettingsToId
HasFlags(FrustumParameters flags) | Aura2API.FrustumSettingsToId


Aura 2: Aura2API.LevelsData Struct Reference

  • LevelsData
Public Attributes | Properties | List of all members
Aura2API.LevelsData Struct Reference

Ordered struct of Levels operation parameters to be sent to the compute shader More...

Public Attributes

float | levelLowThreshold
Offsets the bottom values (similar to Levels in Photoshop) More...
float | levelHiThreshold
Offsets the top values (similar to Levels in Photoshop) More...
float | outputLowValue
Output value of the bottom threshold (similar to Levels in Photoshop, except that it is unclamped here) More...
float | outputHiValue
Output value of the top threshold (similar to Levels in Photoshop, except that it is unclamped here) More...
float | contrast
Contrast intensity More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Ordered struct of Levels operation parameters to be sent to the compute shader

Member Data Documentation

◆ contrast

float Aura2API.LevelsData.contrast

Contrast intensity

◆ levelHiThreshold

float Aura2API.LevelsData.levelHiThreshold

Offsets the top values (similar to Levels in Photoshop)

◆ levelLowThreshold

float Aura2API.LevelsData.levelLowThreshold

Offsets the bottom values (similar to Levels in Photoshop)

◆ outputHiValue

float Aura2API.LevelsData.outputHiValue

Output value of the top threshold (similar to Levels in Photoshop, except that it is unclamped here)

◆ outputLowValue

float Aura2API.LevelsData.outputLowValue

Output value of the bottom threshold (similar to Levels in Photoshop, except that it is unclamped here)

Property Documentation

◆ Size

int Aura2API.LevelsData.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • LevelsData.cs


Aura 2: Member List

  • LevelsData
Aura2API.LevelsData Member List

This is the complete list of members for Aura2API.LevelsData, including all inherited members.

contrast | Aura2API.LevelsData |
levelHiThreshold | Aura2API.LevelsData |
levelLowThreshold | Aura2API.LevelsData |
outputHiValue | Aura2API.LevelsData |
outputLowValue | Aura2API.LevelsData |
Size | Aura2API.LevelsData | static


Aura 2: Aura2API.LevelsParameters Struct Reference

  • LevelsParameters
Public Member Functions | Public Attributes | Properties | List of all members
Aura2API.LevelsParameters Struct Reference

Collection of parameters for Levels adjustement. Similar to the same tool in Photoshop. More...

Public Member Functions

void SetDefaultValues ()
Set default values More...

Public Attributes

float | levelLowThreshold
Offsets the bottom values (similar to Levels in Photoshop) More...
float | levelHiThreshold
Offsets the top values (similar to Levels in Photoshop) More...
float | outputLowValue
Output value of the bottom threshold (similar to Levels in Photoshop, except that it is unclamped here) More...
float | outputHiValue
Output value of the top threshold (similar to Levels in Photoshop, except that it is unclamped here) More...
float | contrast
Contrast intensity More...
bool | saturateOutputValues
Tells if output values should be clamped between 0 and 1; More...

Properties

LevelsData | Data [get]
Packs the data and returns them More...
static LevelsParameters | Default [get]
Returns a LevelsParameters with default values More...
static LevelsParameters | One [get]
Returns a LevelsParameters with all values to One More...
static LevelsParameters | Zero [get]
Returns a LevelsParameters with all values to Zero More...

Detailed Description

Collection of parameters for Levels adjustement. Similar to the same tool in Photoshop.

Member Function Documentation

◆ SetDefaultValues()

void Aura2API.LevelsParameters.SetDefaultValues ( )

Set default values

Member Data Documentation

◆ contrast

float Aura2API.LevelsParameters.contrast

Contrast intensity

◆ levelHiThreshold

float Aura2API.LevelsParameters.levelHiThreshold

Offsets the top values (similar to Levels in Photoshop)

◆ levelLowThreshold

float Aura2API.LevelsParameters.levelLowThreshold

Offsets the bottom values (similar to Levels in Photoshop)

◆ outputHiValue

float Aura2API.LevelsParameters.outputHiValue

Output value of the top threshold (similar to Levels in Photoshop, except that it is unclamped here)

◆ outputLowValue

float Aura2API.LevelsParameters.outputLowValue

Output value of the bottom threshold (similar to Levels in Photoshop, except that it is unclamped here)

◆ saturateOutputValues

bool Aura2API.LevelsParameters.saturateOutputValues

Tells if output values should be clamped between 0 and 1;

Property Documentation

◆ Data

LevelsData Aura2API.LevelsParameters.Data
get

Packs the data and returns them

◆ Default

LevelsParameters Aura2API.LevelsParameters.Default
staticget

Returns a LevelsParameters with default values

◆ One

LevelsParameters Aura2API.LevelsParameters.One
staticget

Returns a LevelsParameters with all values to One

◆ Zero

LevelsParameters Aura2API.LevelsParameters.Zero
staticget

Returns a LevelsParameters with all values to Zero

The documentation for this struct was generated from the following file:
  • LevelsParameters.cs


Aura 2: Member List

  • LevelsParameters
Aura2API.LevelsParameters Member List

This is the complete list of members for Aura2API.LevelsParameters, including all inherited members.

contrast | Aura2API.LevelsParameters |
Data | Aura2API.LevelsParameters |
Default | Aura2API.LevelsParameters | static
levelHiThreshold | Aura2API.LevelsParameters |
levelLowThreshold | Aura2API.LevelsParameters |
One | Aura2API.LevelsParameters | static
outputHiValue | Aura2API.LevelsParameters |
outputLowValue | Aura2API.LevelsParameters |
saturateOutputValues | Aura2API.LevelsParameters |
SetDefaultValues() | Aura2API.LevelsParameters |
Zero | Aura2API.LevelsParameters | static


Aura 2: Aura2API.LightsCommonDataManager Class Reference

  • LightsCommonDataManager
Public Member Functions | Properties | Events | List of all members
Aura2API.LightsCommonDataManager Class Reference

Handles the lights' registration and maps collection More...

Public Member Functions

LightsCommonDataManager ()
Constructor More...
void | Dispose ()
Releases all the managed members More...
void | Update ()
Updates all the data More...
void | RegisterLight (AuraLight auraLight)
Registers the Aura light to the global manager More...

Properties

List< AuraLight > | RegisteredDirectionalLightsList [get]
Accessor to the list of registered directional Aura Lights More...
DirectionalLightsManager | DirectionalLightsManager [get]
Handles the collection and packing of the directional Aura lights' data More...
bool | HasRegisteredDirectionalLights [get]
Tells if has registered directional lights More...
bool | HasDirectionalShadowCasters [get]
Tells if there are any shadow caster More...
Texture2DArray | DirectionalShadowMapsArray [get]
Accessor to the Texture2DArray containing the stacked shadow maps More...
Texture2DArray | DirectionalShadowDataArray [get]
Accessor to the Texture2DArray containing the stacked shadow data maps More...
bool | HasDirectionalCookieCasters [get]
Tells if there are any cookie caster More...
Texture2DArray | DirectionalCookieMapsArray [get]
Accessor to the Texture2DArray containing the stacked cookie maps More...
List< AuraLight > | RegisteredSpotLightsList [get]
Accessor to the list of registered spot Aura Lights More...
bool | HasRegisteredSpotLights [get]
Tells if has registered spot lights More...
bool | HasSpotShadowCasters [get]
Tells if there are any shadow caster More...
Texture2DArray | SpotShadowMapsArray [get]
Accessor to the Texture2DArray containing the stacked shadow maps More...
bool | HasSpotCookieCasters [get]
Tells if there are any cookie caster More...
Texture2DArray | SpotCookieMapsArray [get]
Accessor to the Texture2DArray containing the stacked cookie maps More...
List< AuraLight > | RegisteredPointLightsList [get]
Accessor to the list of registered point Aura Lights More...
bool | HasRegisteredPointLights [get]
Tells if has registered point lights More...
bool | HasPointShadowCasters [get]
Tells if there are any shadow caster More...
Texture2DArray | PointShadowMapsArray [get]
Accessor to the Texture2DArray containing the stacked shadow maps More...
bool | HasPointCookieCasters [get]
Tells if there are any cookie caster More...
Texture2DArray | PointCookieMapsArray [get]
Accessor to the Texture2DArray containing the stacked cookie maps More...

Events

Action | OnCascadesCountChanged
Event raised when the number of shadow cascades changes More...
Action< AuraLight > | OnRegisterSpotLight
Event raised when a spot light is being registred More...
Action< AuraLight > | OnUnregisterSpotLight
Event raised when a spot light is being unregistred More...
Action< AuraLight > | OnRegisterPointLight
Event raised when a point light is being registred More...
Action< AuraLight > | OnUnregisterPointLight
Event raised when a point light is being unregistred More...

Detailed Description

Handles the lights' registration and maps collection

Constructor & Destructor Documentation

◆ LightsCommonDataManager()

Aura2API.LightsCommonDataManager.LightsCommonDataManager ( )

Constructor

Member Function Documentation

◆ Dispose()

void Aura2API.LightsCommonDataManager.Dispose ( )

Releases all the managed members

◆ RegisterLight()

void Aura2API.LightsCommonDataManager.RegisterLight ( AuraLight auraLight )

Registers the Aura light to the global manager

Parameters
auraLight The Aura Light to register

◆ Update()

void Aura2API.LightsCommonDataManager.Update ( )

Updates all the data

Property Documentation

◆ DirectionalCookieMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.DirectionalCookieMapsArray
get

Accessor to the Texture2DArray containing the stacked cookie maps

◆ DirectionalLightsManager

DirectionalLightsManager Aura2API.LightsCommonDataManager.DirectionalLightsManager
get

Handles the collection and packing of the directional Aura lights' data

◆ DirectionalShadowDataArray

Texture2DArray Aura2API.LightsCommonDataManager.DirectionalShadowDataArray
get

Accessor to the Texture2DArray containing the stacked shadow data maps

◆ DirectionalShadowMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.DirectionalShadowMapsArray
get

Accessor to the Texture2DArray containing the stacked shadow maps

◆ HasDirectionalCookieCasters

bool Aura2API.LightsCommonDataManager.HasDirectionalCookieCasters
get

Tells if there are any cookie caster

◆ HasDirectionalShadowCasters

bool Aura2API.LightsCommonDataManager.HasDirectionalShadowCasters
get

Tells if there are any shadow caster

◆ HasPointCookieCasters

bool Aura2API.LightsCommonDataManager.HasPointCookieCasters
get

Tells if there are any cookie caster

◆ HasPointShadowCasters

bool Aura2API.LightsCommonDataManager.HasPointShadowCasters
get

Tells if there are any shadow caster

◆ HasRegisteredDirectionalLights

bool Aura2API.LightsCommonDataManager.HasRegisteredDirectionalLights
get

Tells if has registered directional lights

◆ HasRegisteredPointLights

bool Aura2API.LightsCommonDataManager.HasRegisteredPointLights
get

Tells if has registered point lights

◆ HasRegisteredSpotLights

bool Aura2API.LightsCommonDataManager.HasRegisteredSpotLights
get

Tells if has registered spot lights

◆ HasSpotCookieCasters

bool Aura2API.LightsCommonDataManager.HasSpotCookieCasters
get

Tells if there are any cookie caster

◆ HasSpotShadowCasters

bool Aura2API.LightsCommonDataManager.HasSpotShadowCasters
get

Tells if there are any shadow caster

◆ PointCookieMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.PointCookieMapsArray
get

Accessor to the Texture2DArray containing the stacked cookie maps

◆ PointShadowMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.PointShadowMapsArray
get

Accessor to the Texture2DArray containing the stacked shadow maps

◆ RegisteredDirectionalLightsList

List<AuraLight> Aura2API.LightsCommonDataManager.RegisteredDirectionalLightsList
get

Accessor to the list of registered directional Aura Lights

◆ RegisteredPointLightsList

List<AuraLight> Aura2API.LightsCommonDataManager.RegisteredPointLightsList
get

Accessor to the list of registered point Aura Lights

◆ RegisteredSpotLightsList

List<AuraLight> Aura2API.LightsCommonDataManager.RegisteredSpotLightsList
get

Accessor to the list of registered spot Aura Lights

◆ SpotCookieMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.SpotCookieMapsArray
get

Accessor to the Texture2DArray containing the stacked cookie maps

◆ SpotShadowMapsArray

Texture2DArray Aura2API.LightsCommonDataManager.SpotShadowMapsArray
get

Accessor to the Texture2DArray containing the stacked shadow maps

Event Documentation

◆ OnCascadesCountChanged

Action Aura2API.LightsCommonDataManager.OnCascadesCountChanged

Event raised when the number of shadow cascades changes

◆ OnRegisterPointLight

Action<AuraLight> Aura2API.LightsCommonDataManager.OnRegisterPointLight

Event raised when a point light is being registred

◆ OnRegisterSpotLight

Action<AuraLight> Aura2API.LightsCommonDataManager.OnRegisterSpotLight

Event raised when a spot light is being registred

◆ OnUnregisterPointLight

Action<AuraLight> Aura2API.LightsCommonDataManager.OnUnregisterPointLight

Event raised when a point light is being unregistred

◆ OnUnregisterSpotLight

Action<AuraLight> Aura2API.LightsCommonDataManager.OnUnregisterSpotLight

Event raised when a spot light is being unregistred

The documentation for this class was generated from the following file:
  • LightsCommonDataManager.cs


Aura 2: Member List

  • LightsCommonDataManager
Aura2API.LightsCommonDataManager Member List

This is the complete list of members for Aura2API.LightsCommonDataManager, including all inherited members.

DirectionalCookieMapsArray | Aura2API.LightsCommonDataManager
DirectionalLightsManager | Aura2API.LightsCommonDataManager
DirectionalShadowDataArray | Aura2API.LightsCommonDataManager
DirectionalShadowMapsArray | Aura2API.LightsCommonDataManager
Dispose() | Aura2API.LightsCommonDataManager
HasDirectionalCookieCasters | Aura2API.LightsCommonDataManager
HasDirectionalShadowCasters | Aura2API.LightsCommonDataManager
HasPointCookieCasters | Aura2API.LightsCommonDataManager
HasPointShadowCasters | Aura2API.LightsCommonDataManager
HasRegisteredDirectionalLights | Aura2API.LightsCommonDataManager
HasRegisteredPointLights | Aura2API.LightsCommonDataManager
HasRegisteredSpotLights | Aura2API.LightsCommonDataManager
HasSpotCookieCasters | Aura2API.LightsCommonDataManager
HasSpotShadowCasters | Aura2API.LightsCommonDataManager
LightsCommonDataManager() | Aura2API.LightsCommonDataManager
OnCascadesCountChanged | Aura2API.LightsCommonDataManager
OnRegisterPointLight | Aura2API.LightsCommonDataManager
OnRegisterSpotLight | Aura2API.LightsCommonDataManager
OnUnregisterPointLight | Aura2API.LightsCommonDataManager
OnUnregisterSpotLight | Aura2API.LightsCommonDataManager
PointCookieMapsArray | Aura2API.LightsCommonDataManager
PointShadowMapsArray | Aura2API.LightsCommonDataManager
RegisteredDirectionalLightsList | Aura2API.LightsCommonDataManager
RegisteredPointLightsList | Aura2API.LightsCommonDataManager
RegisteredSpotLightsList | Aura2API.LightsCommonDataManager
RegisterLight(AuraLight auraLight) | Aura2API.LightsCommonDataManager
SpotCookieMapsArray | Aura2API.LightsCommonDataManager
SpotShadowMapsArray | Aura2API.LightsCommonDataManager
Update() | Aura2API.LightsCommonDataManager


Aura 2: Aura2API.MatrixFloats Struct Reference

  • MatrixFloats
Static Public Member Functions | Public Attributes | Properties | List of all members
Aura2API.MatrixFloats Struct Reference

Ordered struct of Vector4 representing a matrix to be sent to the compute shader More...

Static Public Member Functions

static MatrixFloats ToMatrixFloats (Matrix4x4 matrix)
Converts a Matrix4x4 to MatrixFloats format More...

Public Attributes

Vector4 | a
Matric column A More...
Vector4 | b
Matric column B More...
Vector4 | c
Matric column C More...
Vector4 | d
Matric column D More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Ordered struct of Vector4 representing a matrix to be sent to the compute shader

Member Function Documentation

◆ ToMatrixFloats()

static MatrixFloats Aura2API.MatrixFloats.ToMatrixFloats ( Matrix4x4 matrix )
static

Converts a Matrix4x4 to MatrixFloats format

Parameters
matrix The matrix to be converted
Returns
The matrix converted into the MatrixFloats format

Member Data Documentation

◆ a

Vector4 Aura2API.MatrixFloats.a

Matric column A

◆ b

Vector4 Aura2API.MatrixFloats.b

Matric column B

◆ c

Vector4 Aura2API.MatrixFloats.c

Matric column C

◆ d

Vector4 Aura2API.MatrixFloats.d

Matric column D

Property Documentation

◆ Size

int Aura2API.MatrixFloats.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • MatrixFloats.cs


Aura 2: Member List

  • MatrixFloats
Aura2API.MatrixFloats Member List

This is the complete list of members for Aura2API.MatrixFloats, including all inherited members.

a | Aura2API.MatrixFloats |
b | Aura2API.MatrixFloats |
c | Aura2API.MatrixFloats |
d | Aura2API.MatrixFloats |
Size | Aura2API.MatrixFloats | static
ToMatrixFloats(Matrix4x4 matrix) | Aura2API.MatrixFloats | static


Aura 2: Aura2API.PointLightParameters Struct Reference

  • PointLightParameters
Public Attributes | Properties | List of all members
Aura2API.PointLightParameters Struct Reference

Struct containing parameters of a point AuraLight More...

Public Attributes

Vector3 | color
int | useDefaultScattering
float | scatteringOverride
Vector3 | lightPosition
float | lightRange
Vector2 | distanceFalloffParameters
MatrixFloats | worldToShadowMatrix
int | shadowMapIndex
float | shadowStrength
int | cookieMapIndex
Vector3 | cookieParameters

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing parameters of a point AuraLight

Property Documentation

◆ Size

int Aura2API.PointLightParameters.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • PointLightParameters.cs


Aura 2: Member List

  • PointLightParameters
Aura2API.PointLightParameters Member List

This is the complete list of members for Aura2API.PointLightParameters, including all inherited members.

color (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
cookieMapIndex (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
cookieParameters (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
distanceFalloffParameters (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
lightPosition (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
lightRange (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
scatteringOverride (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
shadowMapIndex (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
shadowStrength (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
Size | Aura2API.PointLightParameters | static
useDefaultScattering (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |
worldToShadowMatrix (defined in Aura2API.PointLightParameters) | Aura2API.PointLightParameters |


Aura 2: Aura2API.PointLightsManager Class Reference

  • PointLightsManager
Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
Aura2API.PointLightsManager Class Reference

Manager that handles point AuraLights More...

Public Member Functions

PointLightsManager (Camera camera, FrustumSettings frustumSettings)
Constructor More...
void Dispose ()
Disposes the members More...

Public Attributes

FrustumSettings _frustumSettings
Settings of the frustum More...

Static Public Attributes

static readonly Vector2Int | shadowMapSize = new Vector2Int(512, 256)
The shadow map size More...
static readonly Vector2Int | cookieMapSize = new Vector2Int(512, 256)
The cookie map size More...

Properties

ComputeBuffer | EmptyBuffer [get]
One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility) More...
ComputeBuffer | Buffer [get]
Accessor to the compute buffer containing the packed data of the visible lights More...
bool | HasVisibleLights [get]
Tells if there are visible/unculled lights More...

Detailed Description

Manager that handles point AuraLights

Constructor & Destructor Documentation

◆ PointLightsManager()

Aura2API.PointLightsManager.PointLightsManager | ( | Camera | camera,
 |  | FrustumSettings | frustumSettings
 | ) |  |

Constructor

Parameters
camera | The reference camera, for culling purposes
frustumSettings | The frustum settings

Member Function Documentation

◆ Dispose()

void Aura2API.PointLightsManager.Dispose ( )

Disposes the members

Member Data Documentation

◆ _frustumSettings

FrustumSettings Aura2API.PointLightsManager._frustumSettings

Settings of the frustum

◆ cookieMapSize

readonly Vector2Int Aura2API.PointLightsManager.cookieMapSize = new Vector2Int(512, 256)
static

The cookie map size

◆ shadowMapSize

readonly Vector2Int Aura2API.PointLightsManager.shadowMapSize = new Vector2Int(512, 256)
static

The shadow map size

Property Documentation

◆ Buffer

ComputeBuffer Aura2API.PointLightsManager.Buffer
get

Accessor to the compute buffer containing the packed data of the visible lights

◆ EmptyBuffer

ComputeBuffer Aura2API.PointLightsManager.EmptyBuffer
get

One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility)

◆ HasVisibleLights

bool Aura2API.PointLightsManager.HasVisibleLights
get

Tells if there are visible/unculled lights

The documentation for this class was generated from the following file:
  • PointLightsManager.cs


Aura 2: Member List

  • PointLightsManager
Aura2API.PointLightsManager Member List

This is the complete list of members for Aura2API.PointLightsManager, including all inherited members.

_frustumSettings | Aura2API.PointLightsManager |
Buffer | Aura2API.PointLightsManager |
cookieMapSize | Aura2API.PointLightsManager | static
Dispose() | Aura2API.PointLightsManager |
EmptyBuffer | Aura2API.PointLightsManager |
HasVisibleLights | Aura2API.PointLightsManager |
PointLightsManager(Camera camera, FrustumSettings frustumSettings) | Aura2API.PointLightsManager |
shadowMapSize | Aura2API.PointLightsManager | static


Aura 2: Aura2API.ShadowmapsCollector Class Reference

  • ShadowmapsCollector
Public Member Functions | List of all members
Aura2API.ShadowmapsCollector Class Reference

Texture2DArray composer used for collecting shadow maps More...

Inheritance diagram for Aura2API.ShadowmapsCollector:
Aura2API.Texture2DArrayComposer

Public Member Functions

ShadowmapsCollector (int sizeX, int sizeY)
Constructor More...
- Public Member Functions inherited from Aura2API.Texture2DArrayComposer
Texture2DArrayComposer (int sizeX, int sizeY, TextureFormat format, bool bypassSrgb)
Constructor More...
void | RaiseTextureUpdatedEvent ()
Raises the OnTextureUpdated event More...
bool | AddTexture (Texture texture)
Adds a new candidate Texture More...
bool | RemoveTexture (Texture texture)
Remove a Texture from the candidate Textures list More...
bool | RemoveTexture (int id)
Remove a Texture from the candidate Textures list More...
void | Generate ()
Launches the Texture2DArray generation (already handles NeedsToUpdateVolumeTexture and alwaysGenerateOnUpdate parameters check) More...
int | GetTextureIndex (Texture texture)
Returns the ID of the Texture inside the Texture2DArray More...
void | ClearTexturesList ()
Clears the candidate Textures list More...
void | Resize (int sizeX, int sizeY)
Changes the size of the Texture2DArray to be generated (candidate Texture list will be cleared) More...

Additional Inherited Members

- Public Attributes inherited from Aura2API.Texture2DArrayComposer
bool | alwaysGenerateOnUpdate
Forces the Texture2DArray to be re-generated everytime Generate() is called. More...
- Properties inherited from Aura2API.Texture2DArrayComposer
int | RequiredSizeX [get]
The horizontal size of the Texture2DArray More...
int | RequiredSizeY [get]
The vertical size of the Texture2DArray More...
int | TextureCount [get]
Returns the amount of candidate Textures More...
Texture2DArray | Texture [get]
Accessor to the generated Texture2DArray More...
bool | HasTexture [get]
Tells if a Texture2DArray has been generated More...
bool | NeedsToUpdateTexture [get]
Tells if changes were made and Generate() should be called More...
- Events inherited from Aura2API.Texture2DArrayComposer
EventHandler | OnTextureUpdated

Detailed Description

Texture2DArray composer used for collecting shadow maps

Constructor & Destructor Documentation

◆ ShadowmapsCollector()

Aura2API.ShadowmapsCollector.ShadowmapsCollector | ( | int | sizeX,
 |  | int | sizeY
 | ) |  |

Constructor

Parameters
sizeX | The width of the built Texture2DArray
sizeY | The height of the built Texture2DArray
The documentation for this class was generated from the following file:
  • ShadowmapsCollector.cs


Aura 2: Member List

  • ShadowmapsCollector
Aura2API.ShadowmapsCollector Member List

This is the complete list of members for Aura2API.ShadowmapsCollector, including all inherited members.

AddTexture(Texture texture) | Aura2API.Texture2DArrayComposer
alwaysGenerateOnUpdate | Aura2API.Texture2DArrayComposer
ClearTexturesList() | Aura2API.Texture2DArrayComposer
Generate() | Aura2API.Texture2DArrayComposer
GetTextureIndex(Texture texture) | Aura2API.Texture2DArrayComposer
HasTexture | Aura2API.Texture2DArrayComposer
NeedsToUpdateTexture | Aura2API.Texture2DArrayComposer
OnTextureUpdated (defined in Aura2API.Texture2DArrayComposer) | Aura2API.Texture2DArrayComposer
RaiseTextureUpdatedEvent() | Aura2API.Texture2DArrayComposer
RemoveTexture(Texture texture) | Aura2API.Texture2DArrayComposer
RemoveTexture(int id) | Aura2API.Texture2DArrayComposer
RequiredSizeX | Aura2API.Texture2DArrayComposer
RequiredSizeY | Aura2API.Texture2DArrayComposer
Resize(int sizeX, int sizeY) | Aura2API.Texture2DArrayComposer
ShadowmapsCollector(int sizeX, int sizeY) | Aura2API.ShadowmapsCollector
Texture | Aura2API.Texture2DArrayComposer
Texture2DArrayComposer(int sizeX, int sizeY, TextureFormat format, bool bypassSrgb) | Aura2API.Texture2DArrayComposer
TextureCount | Aura2API.Texture2DArrayComposer


Aura 2: Aura2API.SphericalHarmonicsCoefficients Struct Reference

  • SphericalHarmonicsCoefficients
Public Attributes | Properties | List of all members
Aura2API.SphericalHarmonicsCoefficients Struct Reference

Struct containing spherical harmonics coefficients to use probes in shaders More...

Public Attributes

SphericalHarmonicsFirstBandCoefficients | firstBandCoefficients
Vector4 | shBr
Vector4 | shBg
Vector4 | shBb
Vector4 | shC

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing spherical harmonics coefficients to use probes in shaders

Property Documentation

◆ Size

int Aura2API.SphericalHarmonicsCoefficients.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • SphericalHarmonicsCoefficients.cs


Aura 2: Member List

  • SphericalHarmonicsCoefficients
Aura2API.SphericalHarmonicsCoefficients Member List

This is the complete list of members for Aura2API.SphericalHarmonicsCoefficients, including all inherited members.

firstBandCoefficients (defined in Aura2API.SphericalHarmonicsCoefficients) | Aura2API.SphericalHarmonicsCoefficients |
shBb (defined in Aura2API.SphericalHarmonicsCoefficients) | Aura2API.SphericalHarmonicsCoefficients |
shBg (defined in Aura2API.SphericalHarmonicsCoefficients) | Aura2API.SphericalHarmonicsCoefficients |
shBr (defined in Aura2API.SphericalHarmonicsCoefficients) | Aura2API.SphericalHarmonicsCoefficients |
shC (defined in Aura2API.SphericalHarmonicsCoefficients) | Aura2API.SphericalHarmonicsCoefficients |
Size | Aura2API.SphericalHarmonicsCoefficients | static


Aura 2: Aura2API.SphericalHarmonicsFirstBandCoefficients Struct Reference

  • SphericalHarmonicsFirstBandCoefficients
Public Attributes | Properties | List of all members
Aura2API.SphericalHarmonicsFirstBandCoefficients Struct Reference

Struct containing spherical harmonics coefficients to use probes in shaders More...

Public Attributes

Vector4 | shAr
Vector4 | shAg
Vector4 | shAb

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing spherical harmonics coefficients to use probes in shaders

Property Documentation

◆ Size

int Aura2API.SphericalHarmonicsFirstBandCoefficients.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • SphericalHarmonicsFirstBandCoefficients.cs


Aura 2: Member List

  • SphericalHarmonicsFirstBandCoefficients
Aura2API.SphericalHarmonicsFirstBandCoefficients Member List

This is the complete list of members for Aura2API.SphericalHarmonicsFirstBandCoefficients, including all inherited members.

shAb (defined in Aura2API.SphericalHarmonicsFirstBandCoefficients) | Aura2API.SphericalHarmonicsFirstBandCoefficients |
shAg (defined in Aura2API.SphericalHarmonicsFirstBandCoefficients) | Aura2API.SphericalHarmonicsFirstBandCoefficients |
shAr (defined in Aura2API.SphericalHarmonicsFirstBandCoefficients) | Aura2API.SphericalHarmonicsFirstBandCoefficients |
Size | Aura2API.SphericalHarmonicsFirstBandCoefficients | static


Aura 2: Aura2API.SpotLightParameters Struct Reference

  • SpotLightParameters
Public Attributes | Properties | List of all members
Aura2API.SpotLightParameters Struct Reference

Struct containing parameters of a spot AuraLight More...

Public Attributes

Vector3 | color
int | useDefaultScattering
float | scatteringOverride
Vector3 | lightPosition
Vector3 | lightDirection
float | lightRange
float | lightCosHalfAngle
Vector2 | angularFalloffParameters
Vector2 | distanceFalloffParameters
MatrixFloats | worldToShadowMatrix
int | shadowMapIndex
float | shadowStrength
int | cookieMapIndex
Vector3 | cookieParameters

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing parameters of a spot AuraLight

Property Documentation

◆ Size

int Aura2API.SpotLightParameters.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • SpotLightParameters.cs


Aura 2: Member List

  • SpotLightParameters
Aura2API.SpotLightParameters Member List

This is the complete list of members for Aura2API.SpotLightParameters, including all inherited members.

angularFalloffParameters (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
color (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
cookieMapIndex (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
cookieParameters (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
distanceFalloffParameters (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
lightCosHalfAngle (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
lightDirection (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
lightPosition (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
lightRange (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
scatteringOverride (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
shadowMapIndex (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
shadowStrength (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
Size | Aura2API.SpotLightParameters | static
useDefaultScattering (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |
worldToShadowMatrix (defined in Aura2API.SpotLightParameters) | Aura2API.SpotLightParameters |


Aura 2: Aura2API.SpotLightsManager Class Reference

  • SpotLightsManager
Public Member Functions | Public Attributes | Static Public Attributes | Properties | List of all members
Aura2API.SpotLightsManager Class Reference

Manager that handles spot AuraLights More...

Public Member Functions

SpotLightsManager (Camera camera, FrustumSettings frustumSettings)
Constructor More...
void Dispose ()
Disposes the members More...

Public Attributes

FrustumSettings _frustumSettings
Settings of the frustum More...

Static Public Attributes

static readonly Vector2Int | shadowMapSize = new Vector2Int(256, 256)
The shadow map size More...
static readonly Vector2Int | cookieMapSize = new Vector2Int(256, 256)
The cookie map size More...

Properties

ComputeBuffer | EmptyBuffer [get]
One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility) More...
ComputeBuffer | Buffer [get]
Accessor to the compute buffer containing the packed data of the visible lights More...
bool | HasVisibleLights [get]
Tells if there are visible/unculled lights More...

Detailed Description

Manager that handles spot AuraLights

Constructor & Destructor Documentation

◆ SpotLightsManager()

Aura2API.SpotLightsManager.SpotLightsManager | ( | Camera | camera,
 |  | FrustumSettings | frustumSettings
 | ) |  |

Constructor

Parameters
camera | The reference camera, for culling purposes
frustumSettings | The frustum settings

Member Function Documentation

◆ Dispose()

void Aura2API.SpotLightsManager.Dispose ( )

Disposes the members

Member Data Documentation

◆ _frustumSettings

FrustumSettings Aura2API.SpotLightsManager._frustumSettings

Settings of the frustum

◆ cookieMapSize

readonly Vector2Int Aura2API.SpotLightsManager.cookieMapSize = new Vector2Int(256, 256)
static

The cookie map size

◆ shadowMapSize

readonly Vector2Int Aura2API.SpotLightsManager.shadowMapSize = new Vector2Int(256, 256)
static

The shadow map size

Property Documentation

◆ Buffer

ComputeBuffer Aura2API.SpotLightsManager.Buffer
get

Accessor to the compute buffer containing the packed data of the visible lights

◆ EmptyBuffer

ComputeBuffer Aura2API.SpotLightsManager.EmptyBuffer
get

One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility)

◆ HasVisibleLights

bool Aura2API.SpotLightsManager.HasVisibleLights
get

Tells if there are visible/unculled lights

The documentation for this class was generated from the following file:
  • SpotLightsManager.cs


Aura 2: Member List

  • SpotLightsManager
Aura2API.SpotLightsManager Member List

This is the complete list of members for Aura2API.SpotLightsManager, including all inherited members.

_frustumSettings | Aura2API.SpotLightsManager |
Buffer | Aura2API.SpotLightsManager |
cookieMapSize | Aura2API.SpotLightsManager | static
Dispose() | Aura2API.SpotLightsManager |
EmptyBuffer | Aura2API.SpotLightsManager |
HasVisibleLights | Aura2API.SpotLightsManager |
shadowMapSize | Aura2API.SpotLightsManager | static
SpotLightsManager(Camera camera, FrustumSettings frustumSettings) | Aura2API.SpotLightsManager |


Aura 2: Aura2API.SwappableRenderTexture Class Reference

  • SwappableRenderTexture
Public Member Functions | Properties | List of all members
Aura2API.SwappableRenderTexture Class Reference

Double buffering render texture More...

Public Member Functions

SwappableRenderTexture (int width, int height, int depth, RenderTextureFormat format, RenderTextureReadWrite sRgbSampling, TextureWrapMode wrapMode, FilterMode filterMode)
Constructor for a 3D swappable RenderTexture More...
SwappableRenderTexture (int width, int height, RenderTextureFormat format, RenderTextureReadWrite sRgbSampling, TextureWrapMode wrapMode, FilterMode filterMode)
Constructor for a 2D swappable RenderTexture More...
void | Swap ()
Swaps the textures More...
void | Release ()
Releases the textures More...

Properties

RenderTexture | ReadBuffer [get]
Accessor to the read texture More...
RenderTexture | WriteBuffer [get]
Accessor to the write texture More...

Detailed Description

Double buffering render texture

Constructor & Destructor Documentation

◆ SwappableRenderTexture() [1/2]

Aura2API.SwappableRenderTexture.SwappableRenderTexture | ( | int | width,
 |  | int | height,
 |  | int | depth,
 |  | RenderTextureFormat | format,
 |  | RenderTextureReadWrite | sRgbSampling,
 |  | TextureWrapMode | wrapMode,
 |  | FilterMode | filterMode
 | ) |  |

Constructor for a 3D swappable RenderTexture

Parameters
width | The width of the textures
height | The height of the textures
depth | The depth of the textures
format | The format of the textures
sRgbSampling | The color space of the textures
wrapMode | The wrap mode of the textures
filterMode | The filter mode of the textures

◆ SwappableRenderTexture() [2/2]

Aura2API.SwappableRenderTexture.SwappableRenderTexture | ( | int | width,
 |  | int | height,
 |  | RenderTextureFormat | format,
 |  | RenderTextureReadWrite | sRgbSampling,
 |  | TextureWrapMode | wrapMode,
 |  | FilterMode | filterMode
 | ) |  |

Constructor for a 2D swappable RenderTexture

Parameters
width | The width of the textures
height | The height of the textures
format | The format of the textures
sRgbSampling | The color space of the textures
wrapMode | The wrap mode of the textures
filterMode | The filter mode of the textures

Member Function Documentation

◆ Release()

void Aura2API.SwappableRenderTexture.Release ( )

Releases the textures

◆ Swap()

void Aura2API.SwappableRenderTexture.Swap ( )

Swaps the textures

Property Documentation

◆ ReadBuffer

RenderTexture Aura2API.SwappableRenderTexture.ReadBuffer
get

Accessor to the read texture

◆ WriteBuffer

RenderTexture Aura2API.SwappableRenderTexture.WriteBuffer
get

Accessor to the write texture

The documentation for this class was generated from the following file:
  • SwappableRenderTexture.cs


Aura 2: Member List

  • SwappableRenderTexture
Aura2API.SwappableRenderTexture Member List

This is the complete list of members for Aura2API.SwappableRenderTexture, including all inherited members.

ReadBuffer | Aura2API.SwappableRenderTexture
Release() | Aura2API.SwappableRenderTexture
Swap() | Aura2API.SwappableRenderTexture
SwappableRenderTexture(int width, int height, int depth, RenderTextureFormat format, RenderTextureReadWrite sRgbSampling, TextureWrapMode wrapMode, FilterMode filterMode) | Aura2API.SwappableRenderTexture
SwappableRenderTexture(int width, int height, RenderTextureFormat format, RenderTextureReadWrite sRgbSampling, TextureWrapMode wrapMode, FilterMode filterMode) | Aura2API.SwappableRenderTexture
WriteBuffer | Aura2API.SwappableRenderTexture


Aura 2: Aura2API.Texture2DArrayComposer Class Reference

  • Texture2DArrayComposer
Public Member Functions | Public Attributes | Properties | Events | List of all members
Aura2API.Texture2DArrayComposer Class Reference

Builds a Texture2DArray out of a collection of Textures More...

Inheritance diagram for Aura2API.Texture2DArrayComposer:
Aura2API.DirectionalShadowDataCollector Aura2API.ShadowmapsCollector

Public Member Functions

Texture2DArrayComposer (int sizeX, int sizeY, TextureFormat format, bool bypassSrgb)
Constructor More...
void | RaiseTextureUpdatedEvent ()
Raises the OnTextureUpdated event More...
bool | AddTexture (Texture texture)
Adds a new candidate Texture More...
bool | RemoveTexture (Texture texture)
Remove a Texture from the candidate Textures list More...
bool | RemoveTexture (int id)
Remove a Texture from the candidate Textures list More...
void | Generate ()
Launches the Texture2DArray generation (already handles NeedsToUpdateVolumeTexture and alwaysGenerateOnUpdate parameters check) More...
int | GetTextureIndex (Texture texture)
Returns the ID of the Texture inside the Texture2DArray More...
void | ClearTexturesList ()
Clears the candidate Textures list More...
void | Resize (int sizeX, int sizeY)
Changes the size of the Texture2DArray to be generated (candidate Texture list will be cleared) More...

Public Attributes

bool alwaysGenerateOnUpdate
Forces the Texture2DArray to be re-generated everytime Generate() is called. More...

Properties

int | RequiredSizeX [get]
The horizontal size of the Texture2DArray More...
int | RequiredSizeY [get]
The vertical size of the Texture2DArray More...
int | TextureCount [get]
Returns the amount of candidate Textures More...
Texture2DArray | Texture [get]
Accessor to the generated Texture2DArray More...
bool | HasTexture [get]
Tells if a Texture2DArray has been generated More...
bool | NeedsToUpdateTexture [get]
Tells if changes were made and Generate() should be called More...

Events

EventHandler OnTextureUpdated

Detailed Description

Builds a Texture2DArray out of a collection of Textures

Constructor & Destructor Documentation

◆ Texture2DArrayComposer()

Aura2API.Texture2DArrayComposer.Texture2DArrayComposer | ( | int | sizeX,
 |  | int | sizeY,
 |  | TextureFormat | format,
 |  | bool | bypassSrgb
 | ) |  |

Constructor

Parameters
sizeX | The horizontal size of the Texture2DArray
sizeY | The vertical size of the Texture2DArray
format | The format of the Texture2DArray
bypassSrgb | The color space of the Texture2DArray

Member Function Documentation

◆ AddTexture()

bool Aura2API.Texture2DArrayComposer.AddTexture ( Texture texture )

Adds a new candidate Texture

Parameters
texture The Texture to be added
Returns
True if successfully added, false otherwise

◆ ClearTexturesList()

void Aura2API.Texture2DArrayComposer.ClearTexturesList ( )

Clears the candidate Textures list

◆ Generate()

void Aura2API.Texture2DArrayComposer.Generate ( )

Launches the Texture2DArray generation (already handles NeedsToUpdateVolumeTexture and alwaysGenerateOnUpdate parameters check)

◆ GetTextureIndex()

int Aura2API.Texture2DArrayComposer.GetTextureIndex ( Texture texture )

Returns the ID of the Texture inside the Texture2DArray

Parameters
texture The queried Texture
Returns
The index of the Texture in the Texture2DArray, -1 if not found

◆ RaiseTextureUpdatedEvent()

void Aura2API.Texture2DArrayComposer.RaiseTextureUpdatedEvent ( )

Raises the OnTextureUpdated event

◆ RemoveTexture() [1/2]

bool Aura2API.Texture2DArrayComposer.RemoveTexture ( Texture texture )

Remove a Texture from the candidate Textures list

Parameters
texture The Texture to remove
Returns
True if successfully added, false otherwise

◆ RemoveTexture() [2/2]

bool Aura2API.Texture2DArrayComposer.RemoveTexture ( int id )

Remove a Texture from the candidate Textures list

Parameters
id The index of the texture to remove
Returns
True if successfully added, false otherwise

◆ Resize()

void Aura2API.Texture2DArrayComposer.Resize | ( | int | sizeX,
 |  | int | sizeY
 | ) |  |

Changes the size of the Texture2DArray to be generated (candidate Texture list will be cleared)

Parameters
sizeX | The new horizontal size
sizeY | The new vertical size

Member Data Documentation

◆ alwaysGenerateOnUpdate

bool Aura2API.Texture2DArrayComposer.alwaysGenerateOnUpdate

Forces the Texture2DArray to be re-generated everytime Generate() is called.

Property Documentation

◆ HasTexture

bool Aura2API.Texture2DArrayComposer.HasTexture
get

Tells if a Texture2DArray has been generated

◆ NeedsToUpdateTexture

bool Aura2API.Texture2DArrayComposer.NeedsToUpdateTexture
get

Tells if changes were made and Generate() should be called

◆ RequiredSizeX

int Aura2API.Texture2DArrayComposer.RequiredSizeX
get

The horizontal size of the Texture2DArray

◆ RequiredSizeY

int Aura2API.Texture2DArrayComposer.RequiredSizeY
get

The vertical size of the Texture2DArray

◆ Texture

Texture2DArray Aura2API.Texture2DArrayComposer.Texture
get

Accessor to the generated Texture2DArray

◆ TextureCount

int Aura2API.Texture2DArrayComposer.TextureCount
get

Returns the amount of candidate Textures

The documentation for this class was generated from the following file:
  • Texture2DArrayComposer.cs


Aura 2: Member List

  • Texture2DArrayComposer
Aura2API.Texture2DArrayComposer Member List

This is the complete list of members for Aura2API.Texture2DArrayComposer, including all inherited members.

AddTexture(Texture texture) | Aura2API.Texture2DArrayComposer
alwaysGenerateOnUpdate | Aura2API.Texture2DArrayComposer
ClearTexturesList() | Aura2API.Texture2DArrayComposer
Generate() | Aura2API.Texture2DArrayComposer
GetTextureIndex(Texture texture) | Aura2API.Texture2DArrayComposer
HasTexture | Aura2API.Texture2DArrayComposer
NeedsToUpdateTexture | Aura2API.Texture2DArrayComposer
OnTextureUpdated (defined in Aura2API.Texture2DArrayComposer) | Aura2API.Texture2DArrayComposer
RaiseTextureUpdatedEvent() | Aura2API.Texture2DArrayComposer
RemoveTexture(Texture texture) | Aura2API.Texture2DArrayComposer
RemoveTexture(int id) | Aura2API.Texture2DArrayComposer
RequiredSizeX | Aura2API.Texture2DArrayComposer
RequiredSizeY | Aura2API.Texture2DArrayComposer
Resize(int sizeX, int sizeY) | Aura2API.Texture2DArrayComposer
Texture | Aura2API.Texture2DArrayComposer
Texture2DArrayComposer(int sizeX, int sizeY, TextureFormat format, bool bypassSrgb) | Aura2API.Texture2DArrayComposer
TextureCount | Aura2API.Texture2DArrayComposer


Aura 2: Aura2API.Texture2DMask Struct Reference

  • Texture2DMask
Public Member Functions | Public Attributes | List of all members
Aura2API.Texture2DMask Struct Reference

Texture2D mask to be used in a AuraVolume More...

Public Member Functions

void SetDefaultValues ()
Sets default values More...

Public Attributes

bool | enable
Enables the texture mask More...
Texture2D | texture
The source Texture2D More...
int | textureIndex
Index of the texture inside the atlas More...
TransformParameters transform
Allows to set base position, rotation and scale More...

Detailed Description

Texture2D mask to be used in a AuraVolume

Member Function Documentation

◆ SetDefaultValues()

void Aura2API.Texture2DMask.SetDefaultValues ( )

Sets default values

Member Data Documentation

◆ enable

bool Aura2API.Texture2DMask.enable

Enables the texture mask

◆ texture

Texture2D Aura2API.Texture2DMask.texture

The source Texture2D

◆ textureIndex

int Aura2API.Texture2DMask.textureIndex

Index of the texture inside the atlas

◆ transform

TransformParameters Aura2API.Texture2DMask.transform

Allows to set base position, rotation and scale

The documentation for this struct was generated from the following file:
  • Texture2DMask.cs


Aura 2: Member List

  • Texture2DMask
Aura2API.Texture2DMask Member List

This is the complete list of members for Aura2API.Texture2DMask, including all inherited members.

enable | Aura2API.Texture2DMask
SetDefaultValues() | Aura2API.Texture2DMask
texture | Aura2API.Texture2DMask
textureIndex | Aura2API.Texture2DMask
transform | Aura2API.Texture2DMask


Aura 2: Aura2API.Texture3DMask Struct Reference

  • Texture3DMask
Public Member Functions | Public Attributes | List of all members
Aura2API.Texture3DMask Struct Reference

Texture3D mask to be used in a AuraVolume More...

Public Member Functions

void SetDefaultValues ()
Sets default values More...

Public Attributes

bool | enable
Enables the texture mask More...
Texture3D | texture
The source Texture3D More...
int | textureIndex
Index of the texture inside the atlas More...
TransformParameters transform
Allows to set base position, rotation and scale More...

Detailed Description

Texture3D mask to be used in a AuraVolume

Member Function Documentation

◆ SetDefaultValues()

void Aura2API.Texture3DMask.SetDefaultValues ( )

Sets default values

Member Data Documentation

◆ enable

bool Aura2API.Texture3DMask.enable

Enables the texture mask

◆ texture

Texture3D Aura2API.Texture3DMask.texture

The source Texture3D

◆ textureIndex

int Aura2API.Texture3DMask.textureIndex

Index of the texture inside the atlas

◆ transform

TransformParameters Aura2API.Texture3DMask.transform

Allows to set base position, rotation and scale

The documentation for this struct was generated from the following file:
  • Texture3DMask.cs


Aura 2: Member List

  • Texture3DMask
Aura2API.Texture3DMask Member List

This is the complete list of members for Aura2API.Texture3DMask, including all inherited members.

enable | Aura2API.Texture3DMask
SetDefaultValues() | Aura2API.Texture3DMask
texture | Aura2API.Texture3DMask
textureIndex | Aura2API.Texture3DMask
transform | Aura2API.Texture3DMask


Aura 2: Aura2API.Texture3DPreviewAttribute Class Reference

  • Texture3DPreviewAttribute
Public Member Functions | Public Attributes | List of all members
Aura2API.Texture3DPreviewAttribute Class Reference

Attribute enabling Texture3D preview in a Monobehaviour component in the Inspector More...

Inheritance diagram for Aura2API.Texture3DPreviewAttribute:

Public Member Functions

Texture3DPreviewAttribute (bool showField=true)
Declare this attribute in front of the Texture3D field to enable previewing in a Monobehaviour component in the Inspector More...

Public Attributes

readonly bool showField
Allows to show the field (when user drags/drops another Texture3D for example) or not (when Texture3D is changed in code only for example) More...

Detailed Description

Attribute enabling Texture3D preview in a Monobehaviour component in the Inspector

Constructor & Destructor Documentation

◆ Texture3DPreviewAttribute()

Aura2API.Texture3DPreviewAttribute.Texture3DPreviewAttribute ( bool showField = true )

Declare this attribute in front of the Texture3D field to enable previewing in a Monobehaviour component in the Inspector

Parameters
showField Shows or not the Texture3D field on top of the preview (default = true)

Member Data Documentation

◆ showField

readonly bool Aura2API.Texture3DPreviewAttribute.showField

Allows to show the field (when user drags/drops another Texture3D for example) or not (when Texture3D is changed in code only for example)

The documentation for this class was generated from the following file:
  • Texture3DPreviewAttribute.cs


Aura 2: Member List

  • Texture3DPreviewAttribute
Aura2API.Texture3DPreviewAttribute Member List

This is the complete list of members for Aura2API.Texture3DPreviewAttribute, including all inherited members.

showField | Aura2API.Texture3DPreviewAttribute
Texture3DPreviewAttribute(bool showField=true) | Aura2API.Texture3DPreviewAttribute


Aura 2: Aura2API.TextureBuffers Class Reference

  • TextureBuffers
Public Member Functions | Properties | List of all members
Aura2API.TextureBuffers Class Reference

Collection of texture buffers which contain the computed volumetric data More...

Public Member Functions

void | ReleaseAllBuffers ()
Releases all texture buffers More...
void | ReleaseVolumeTextureBuffers ()
Releases the volume texture buffers More...
void | ReleaseOcclusionTextureBuffer ()
Releases the occlusion texture buffer More...
void | ReleaseSliceTextureBuffer ()
Releases the occlusion texture buffer More...
void | ReleaseAllLightProbesBuffers ()
Releases all light probes coefficients buffers More...
void | ReleaseLightProbesCoefficientsTextureBuffer ()
Releases the light probes coefficients texture buffer More...
void | ReleaseLightProbesCoefficientsBuffer ()
Releases the light probes coefficients texture buffer More...

Properties

Vector3Int | VolumetricBuffersResolution [get, set]
The resolution of the volumetric buffers More...
bool | VolumetricBuffersResolutionIsValid [get]
Tells if the resolution of the volumetric buffers is set More...
Vector3Int | LightProbesCoefficientsTextureResolution [get]
The resolution of the light probes buffers More...
bool | LightProbesCoefficientsTextureResolutionIsValid [get]
Tells if the resolution of the light probes buffers is set More...
SwappableRenderTexture | DataVolumeTexture [get]
Accessor to the volumetric data buffer (containing the lighting (RGB) and the density (A)) More...
RenderTexture | FogVolumeTexture [get]
Accessor to the volumetric accumulated buffer (containing the accumulated lighting) More...
SwappableRenderTexture | OcclusionTexture [get]
Accessor to the buffer containing the maximum depth More...
SwappableRenderTexture | SliceTexture [get]
The Texture2D buffer containing the maximum amount of slices per cell More...
RenderTexture | LightProbesCoefficientsTexture [get]
Accessor to the volumetric light probes coefficients texture More...
SphericalHarmonicsFirstBandCoefficients [] | LightProbesCoefficients [get]
Accessor to the light probes coefficients array More...
ComputeBuffer | LightProbesCoefficientsComputeBuffer [get]
Accessor to the light probes coefficients compute buffer More...

Detailed Description

Collection of texture buffers which contain the computed volumetric data

Member Function Documentation

◆ ReleaseAllBuffers()

void Aura2API.TextureBuffers.ReleaseAllBuffers ( )

Releases all texture buffers

◆ ReleaseAllLightProbesBuffers()

void Aura2API.TextureBuffers.ReleaseAllLightProbesBuffers ( )

Releases all light probes coefficients buffers

◆ ReleaseLightProbesCoefficientsBuffer()

void Aura2API.TextureBuffers.ReleaseLightProbesCoefficientsBuffer ( )

Releases the light probes coefficients texture buffer

◆ ReleaseLightProbesCoefficientsTextureBuffer()

void Aura2API.TextureBuffers.ReleaseLightProbesCoefficientsTextureBuffer ( )

Releases the light probes coefficients texture buffer

◆ ReleaseOcclusionTextureBuffer()

void Aura2API.TextureBuffers.ReleaseOcclusionTextureBuffer ( )

Releases the occlusion texture buffer

◆ ReleaseSliceTextureBuffer()

void Aura2API.TextureBuffers.ReleaseSliceTextureBuffer ( )

Releases the occlusion texture buffer

◆ ReleaseVolumeTextureBuffers()

void Aura2API.TextureBuffers.ReleaseVolumeTextureBuffers ( )

Releases the volume texture buffers

Property Documentation

◆ DataVolumeTexture

SwappableRenderTexture Aura2API.TextureBuffers.DataVolumeTexture
get

Accessor to the volumetric data buffer (containing the lighting (RGB) and the density (A))

◆ FogVolumeTexture

RenderTexture Aura2API.TextureBuffers.FogVolumeTexture
get

Accessor to the volumetric accumulated buffer (containing the accumulated lighting)

◆ LightProbesCoefficients

SphericalHarmonicsFirstBandCoefficients [] Aura2API.TextureBuffers.LightProbesCoefficients
get

Accessor to the light probes coefficients array

◆ LightProbesCoefficientsComputeBuffer

ComputeBuffer Aura2API.TextureBuffers.LightProbesCoefficientsComputeBuffer
get

Accessor to the light probes coefficients compute buffer

◆ LightProbesCoefficientsTexture

RenderTexture Aura2API.TextureBuffers.LightProbesCoefficientsTexture
get

Accessor to the volumetric light probes coefficients texture

◆ LightProbesCoefficientsTextureResolution

Vector3Int Aura2API.TextureBuffers.LightProbesCoefficientsTextureResolution
get

The resolution of the light probes buffers

◆ LightProbesCoefficientsTextureResolutionIsValid

bool Aura2API.TextureBuffers.LightProbesCoefficientsTextureResolutionIsValid
get

Tells if the resolution of the light probes buffers is set

◆ OcclusionTexture

SwappableRenderTexture Aura2API.TextureBuffers.OcclusionTexture
get

Accessor to the buffer containing the maximum depth

◆ SliceTexture

SwappableRenderTexture Aura2API.TextureBuffers.SliceTexture
get

The Texture2D buffer containing the maximum amount of slices per cell

◆ VolumetricBuffersResolution

Vector3Int Aura2API.TextureBuffers.VolumetricBuffersResolution
getset

The resolution of the volumetric buffers

◆ VolumetricBuffersResolutionIsValid

bool Aura2API.TextureBuffers.VolumetricBuffersResolutionIsValid
get

Tells if the resolution of the volumetric buffers is set

The documentation for this class was generated from the following file:
  • TextureBuffers.cs


Aura 2: Member List

  • TextureBuffers
Aura2API.TextureBuffers Member List

This is the complete list of members for Aura2API.TextureBuffers, including all inherited members.

DataVolumeTexture | Aura2API.TextureBuffers
FogVolumeTexture | Aura2API.TextureBuffers
LightProbesCoefficients | Aura2API.TextureBuffers
LightProbesCoefficientsComputeBuffer | Aura2API.TextureBuffers
LightProbesCoefficientsTexture | Aura2API.TextureBuffers
LightProbesCoefficientsTextureResolution | Aura2API.TextureBuffers
LightProbesCoefficientsTextureResolutionIsValid | Aura2API.TextureBuffers
OcclusionTexture | Aura2API.TextureBuffers
ReleaseAllBuffers() | Aura2API.TextureBuffers
ReleaseAllLightProbesBuffers() | Aura2API.TextureBuffers
ReleaseLightProbesCoefficientsBuffer() | Aura2API.TextureBuffers
ReleaseLightProbesCoefficientsTextureBuffer() | Aura2API.TextureBuffers
ReleaseOcclusionTextureBuffer() | Aura2API.TextureBuffers
ReleaseSliceTextureBuffer() | Aura2API.TextureBuffers
ReleaseVolumeTextureBuffers() | Aura2API.TextureBuffers
SliceTexture | Aura2API.TextureBuffers
VolumetricBuffersResolution | Aura2API.TextureBuffers
VolumetricBuffersResolutionIsValid | Aura2API.TextureBuffers


Aura 2: Aura2API.TextureMaskData Struct Reference

  • TextureMaskData
Public Attributes | Properties | List of all members
Aura2API.TextureMaskData Struct Reference

Ordered struct of texture mask parameters to be sent to the compute shader More...

Public Attributes

MatrixFloats transform
The tranform of the texture More...
int index
The index of the texture in the composed volumetric texture. The "enable" parameter is included in this as it is set to -1 if enable == false More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Ordered struct of texture mask parameters to be sent to the compute shader

Member Data Documentation

◆ index

int Aura2API.TextureMaskData.index

The index of the texture in the composed volumetric texture. The "enable" parameter is included in this as it is set to -1 if enable == false

◆ transform

MatrixFloats Aura2API.TextureMaskData.transform

The tranform of the texture

Property Documentation

◆ Size

int Aura2API.TextureMaskData.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • TextureMaskData.cs


Aura 2: Member List

  • TextureMaskData
Aura2API.TextureMaskData Member List

This is the complete list of members for Aura2API.TextureMaskData, including all inherited members.

index | Aura2API.TextureMaskData |
Size | Aura2API.TextureMaskData | static
transform | Aura2API.TextureMaskData |


Aura 2: Aura2API.TransformParameters Struct Reference

  • TransformParameters
Public Attributes | Properties | List of all members
Aura2API.TransformParameters Struct Reference

Used for transforming reference position for textures/noise inside volumes More...

Public Attributes

Space | space
Referential to use for transformations and animations More...
Vector3 | position
Position of the volume in the selected referencial More...
Vector3 | rotation
Rotation of the volume in the selected referencial More...
Vector3 | scale
Scale of the volume in the selected referencial More...

Properties

Matrix4x4 Matrix [get]
The resulting transformation matrix More...

Detailed Description

Used for transforming reference position for textures/noise inside volumes

Member Data Documentation

◆ position

Vector3 Aura2API.TransformParameters.position

Position of the volume in the selected referencial

◆ rotation

Vector3 Aura2API.TransformParameters.rotation

Rotation of the volume in the selected referencial

◆ scale

Vector3 Aura2API.TransformParameters.scale

Scale of the volume in the selected referencial

◆ space

Space Aura2API.TransformParameters.space

Referential to use for transformations and animations

Property Documentation

◆ Matrix

Matrix4x4 Aura2API.TransformParameters.Matrix
get

The resulting transformation matrix

The documentation for this struct was generated from the following file:
  • TransformParameters.cs


Aura 2: Member List

  • TransformParameters
Aura2API.TransformParameters Member List

This is the complete list of members for Aura2API.TransformParameters, including all inherited members.

Matrix | Aura2API.TransformParameters
position | Aura2API.TransformParameters
rotation | Aura2API.TransformParameters
scale | Aura2API.TransformParameters
space | Aura2API.TransformParameters


Aura 2: Aura2API.VisibleCellData Struct Reference

  • VisibleCellData
Properties | List of all members
Aura2API.VisibleCellData Struct Reference

Struct containing data size of a visible cell inside the volume More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Struct containing data size of a visible cell inside the volume

Property Documentation

◆ Size

int Aura2API.VisibleCellData.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • VisibleCellData.cs


Aura 2: Member List

  • VisibleCellData
Aura2API.VisibleCellData Member List

This is the complete list of members for Aura2API.VisibleCellData, including all inherited members.

Size Aura2API.VisibleCellData static


Aura 2: Aura2API.VolumeData Struct Reference

  • VolumeData
Public Attributes | Properties | List of all members
Aura2API.VolumeData Struct Reference

Ordered struct of volume parameters to be sent to the compute shader More...

Public Attributes

MatrixFloats transform
Transform of the volume More...
int | shape
Id of the shape of the volume More...
float | falloffExponent
Exponent the fading gradient will be raised to More...
float | xPositiveFade
Normalized size of the fading on the borders, on the positive local X axis More...
float | xNegativeFade
Normalized size of the fading on the borders, on the negative local X axis More...
float | yPositiveFade
Normalized size of the fading on the borders, on the positive local Y axis More...
float | yNegativeFade
Normalized size of the fading on the borders, on the negative local Y axis More...
float | zPositiveFade
Normalized size of the fading on the borders, on the positive local Z axis More...
float | zNegativeFade
Normalized size of the fading on the borders, on the negative local Z axis More...
int | useAsLightProbesProxyVolume
Use the volume to show light probes lighting More...
float | lightProbesMultiplier
Light probes lighting multiplier More...
TextureMaskData texture2DMaskData
Texture2D mask parameters More...
TextureMaskData texture3DMaskData
Texture3D mask parameters More...
VolumeDynamicNoiseData noiseData
Noise parameters More...
int | injectDensity
Enables density injection More...
float | densityValue
Density injection strength More...
LevelsData densityTexture2DMaskLevelsParameters
Density Texture2D mask levels parameters More...
LevelsData densityTexture3DMaskLevelsParameters
Density Texture3D mask levels parameters More...
LevelsData densityNoiseLevelsParameters
Density noise mask levels parameters More...
int | injectScattering
Enables scattering injection More...
float | scatteringValue
Scattering injection strength More...
LevelsData scatteringTexture2DMaskLevelsParameters
Scattering Texture2D mask levels parameters More...
LevelsData scatteringTexture3DMaskLevelsParameters
Scattering Texture3D mask levels parameters More...
LevelsData scatteringNoiseLevelsParameters
Scattering noise mask levels parameters More...
int | injectColor
Enables color injection More...
Vector3 | colorValue
Color value * injection strength More...
LevelsData colorTexture2DMaskLevelsParameters
Color Texture2D mask levels parameters More...
LevelsData colorTexture3DMaskLevelsParameters
Color Texture3D mask levels parameters More...
LevelsData colorNoiseLevelsParameters
Color noise mask levels parameters More...
int | injectTint
Enables tint injection More...
Vector3 | tintColor
Tint value More...
LevelsData tintTexture2DMaskLevelsParameters
Tint Texture2D mask levels parameters More...
LevelsData tintTexture3DMaskLevelsParameters
Tint Texture3D mask levels parameters More...
LevelsData tintNoiseLevelsParameters
Tint noise mask levels parameters More...
int | injectAmbient
Enables ambient lighting injection More...
float | ambientLightingValue
Ambient Lighting injection strength More...
LevelsData ambientTexture2DMaskLevelsParameters
Ambient Texture2D mask levels parameters More...
LevelsData ambientTexture3DMaskLevelsParameters
Ambient Texture3D mask levels parameters More...
LevelsData ambientNoiseLevelsParameters
Ambient noise mask levels parameters More...
int | injectBoost
Enables boost injection More...
float | boostValue
Boost injection strength More...
LevelsData boostTexture2DMaskLevelsParameters
Boost Texture2D mask levels parameters More...
LevelsData boostTexture3DMaskLevelsParameters
Boost Texture3D mask levels parameters More...
LevelsData boostNoiseLevelsParameters
Boost noise mask levels parameters More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Ordered struct of volume parameters to be sent to the compute shader

Member Data Documentation

◆ ambientLightingValue

float Aura2API.VolumeData.ambientLightingValue

Ambient Lighting injection strength

◆ ambientNoiseLevelsParameters

LevelsData Aura2API.VolumeData.ambientNoiseLevelsParameters

Ambient noise mask levels parameters

◆ ambientTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.ambientTexture2DMaskLevelsParameters

Ambient Texture2D mask levels parameters

◆ ambientTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.ambientTexture3DMaskLevelsParameters

Ambient Texture3D mask levels parameters

◆ boostNoiseLevelsParameters

LevelsData Aura2API.VolumeData.boostNoiseLevelsParameters

Boost noise mask levels parameters

◆ boostTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.boostTexture2DMaskLevelsParameters

Boost Texture2D mask levels parameters

◆ boostTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.boostTexture3DMaskLevelsParameters

Boost Texture3D mask levels parameters

◆ boostValue

float Aura2API.VolumeData.boostValue

Boost injection strength

◆ colorNoiseLevelsParameters

LevelsData Aura2API.VolumeData.colorNoiseLevelsParameters

Color noise mask levels parameters

◆ colorTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.colorTexture2DMaskLevelsParameters

Color Texture2D mask levels parameters

◆ colorTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.colorTexture3DMaskLevelsParameters

Color Texture3D mask levels parameters

◆ colorValue

Vector3 Aura2API.VolumeData.colorValue

Color value * injection strength

◆ densityNoiseLevelsParameters

LevelsData Aura2API.VolumeData.densityNoiseLevelsParameters

Density noise mask levels parameters

◆ densityTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.densityTexture2DMaskLevelsParameters

Density Texture2D mask levels parameters

◆ densityTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.densityTexture3DMaskLevelsParameters

Density Texture3D mask levels parameters

◆ densityValue

float Aura2API.VolumeData.densityValue

Density injection strength

◆ falloffExponent

float Aura2API.VolumeData.falloffExponent

Exponent the fading gradient will be raised to

◆ injectAmbient

int Aura2API.VolumeData.injectAmbient

Enables ambient lighting injection

◆ injectBoost

int Aura2API.VolumeData.injectBoost

Enables boost injection

◆ injectColor

int Aura2API.VolumeData.injectColor

Enables color injection

◆ injectDensity

int Aura2API.VolumeData.injectDensity

Enables density injection

◆ injectScattering

int Aura2API.VolumeData.injectScattering

Enables scattering injection

◆ injectTint

int Aura2API.VolumeData.injectTint

Enables tint injection

◆ lightProbesMultiplier

float Aura2API.VolumeData.lightProbesMultiplier

Light probes lighting multiplier

◆ noiseData

VolumeDynamicNoiseData Aura2API.VolumeData.noiseData

Noise parameters

◆ scatteringNoiseLevelsParameters

LevelsData Aura2API.VolumeData.scatteringNoiseLevelsParameters

Scattering noise mask levels parameters

◆ scatteringTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.scatteringTexture2DMaskLevelsParameters

Scattering Texture2D mask levels parameters

◆ scatteringTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.scatteringTexture3DMaskLevelsParameters

Scattering Texture3D mask levels parameters

◆ scatteringValue

float Aura2API.VolumeData.scatteringValue

Scattering injection strength

◆ shape

int Aura2API.VolumeData.shape

Id of the shape of the volume

◆ texture2DMaskData

TextureMaskData Aura2API.VolumeData.texture2DMaskData

Texture2D mask parameters

◆ texture3DMaskData

TextureMaskData Aura2API.VolumeData.texture3DMaskData

Texture3D mask parameters

◆ tintColor

Vector3 Aura2API.VolumeData.tintColor

Tint value

◆ tintNoiseLevelsParameters

LevelsData Aura2API.VolumeData.tintNoiseLevelsParameters

Tint noise mask levels parameters

◆ tintTexture2DMaskLevelsParameters

LevelsData Aura2API.VolumeData.tintTexture2DMaskLevelsParameters

Tint Texture2D mask levels parameters

◆ tintTexture3DMaskLevelsParameters

LevelsData Aura2API.VolumeData.tintTexture3DMaskLevelsParameters

Tint Texture3D mask levels parameters

◆ transform

MatrixFloats Aura2API.VolumeData.transform

Transform of the volume

◆ useAsLightProbesProxyVolume

int Aura2API.VolumeData.useAsLightProbesProxyVolume

Use the volume to show light probes lighting

◆ xNegativeFade

float Aura2API.VolumeData.xNegativeFade

Normalized size of the fading on the borders, on the negative local X axis

◆ xPositiveFade

float Aura2API.VolumeData.xPositiveFade

Normalized size of the fading on the borders, on the positive local X axis

◆ yNegativeFade

float Aura2API.VolumeData.yNegativeFade

Normalized size of the fading on the borders, on the negative local Y axis

◆ yPositiveFade

float Aura2API.VolumeData.yPositiveFade

Normalized size of the fading on the borders, on the positive local Y axis

◆ zNegativeFade

float Aura2API.VolumeData.zNegativeFade

Normalized size of the fading on the borders, on the negative local Z axis

◆ zPositiveFade

float Aura2API.VolumeData.zPositiveFade

Normalized size of the fading on the borders, on the positive local Z axis

Property Documentation

◆ Size

int Aura2API.VolumeData.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • VolumeData.cs


Aura 2: Member List

  • VolumeData
Aura2API.VolumeData Member List

This is the complete list of members for Aura2API.VolumeData, including all inherited members.

ambientLightingValue | Aura2API.VolumeData |
ambientNoiseLevelsParameters | Aura2API.VolumeData |
ambientTexture2DMaskLevelsParameters | Aura2API.VolumeData |
ambientTexture3DMaskLevelsParameters | Aura2API.VolumeData |
boostNoiseLevelsParameters | Aura2API.VolumeData |
boostTexture2DMaskLevelsParameters | Aura2API.VolumeData |
boostTexture3DMaskLevelsParameters | Aura2API.VolumeData |
boostValue | Aura2API.VolumeData |
colorNoiseLevelsParameters | Aura2API.VolumeData |
colorTexture2DMaskLevelsParameters | Aura2API.VolumeData |
colorTexture3DMaskLevelsParameters | Aura2API.VolumeData |
colorValue | Aura2API.VolumeData |
densityNoiseLevelsParameters | Aura2API.VolumeData |
densityTexture2DMaskLevelsParameters | Aura2API.VolumeData |
densityTexture3DMaskLevelsParameters | Aura2API.VolumeData |
densityValue | Aura2API.VolumeData |
falloffExponent | Aura2API.VolumeData |
injectAmbient | Aura2API.VolumeData |
injectBoost | Aura2API.VolumeData |
injectColor | Aura2API.VolumeData |
injectDensity | Aura2API.VolumeData |
injectScattering | Aura2API.VolumeData |
injectTint | Aura2API.VolumeData |
lightProbesMultiplier | Aura2API.VolumeData |
noiseData | Aura2API.VolumeData |
scatteringNoiseLevelsParameters | Aura2API.VolumeData |
scatteringTexture2DMaskLevelsParameters | Aura2API.VolumeData |
scatteringTexture3DMaskLevelsParameters | Aura2API.VolumeData |
scatteringValue | Aura2API.VolumeData |
shape | Aura2API.VolumeData |
Size | Aura2API.VolumeData | static
texture2DMaskData | Aura2API.VolumeData |
texture3DMaskData | Aura2API.VolumeData |
tintColor | Aura2API.VolumeData |
tintNoiseLevelsParameters | Aura2API.VolumeData |
tintTexture2DMaskLevelsParameters | Aura2API.VolumeData |
tintTexture3DMaskLevelsParameters | Aura2API.VolumeData |
transform | Aura2API.VolumeData |
useAsLightProbesProxyVolume | Aura2API.VolumeData |
xNegativeFade | Aura2API.VolumeData |
xPositiveFade | Aura2API.VolumeData |
yNegativeFade | Aura2API.VolumeData |
yPositiveFade | Aura2API.VolumeData |
zNegativeFade | Aura2API.VolumeData |
zPositiveFade | Aura2API.VolumeData |


Aura 2: Aura2API.VolumeDynamicNoiseData Struct Reference

  • VolumeDynamicNoiseData
Public Attributes | Properties | List of all members
Aura2API.VolumeDynamicNoiseData Struct Reference

Ordered struct of noise parameters to be sent to the compute shader More...

Public Attributes

int | enable
Enables the dynamic noise computation More...
MatrixFloats transform
The tranform of the noise More...
float | speed
The speed of the noise mutation More...

Properties

static int Size [get]
The bytes size of the struct More...

Detailed Description

Ordered struct of noise parameters to be sent to the compute shader

Member Data Documentation

◆ enable

int Aura2API.VolumeDynamicNoiseData.enable

Enables the dynamic noise computation

◆ speed

float Aura2API.VolumeDynamicNoiseData.speed

The speed of the noise mutation

◆ transform

MatrixFloats Aura2API.VolumeDynamicNoiseData.transform

The tranform of the noise

Property Documentation

◆ Size

int Aura2API.VolumeDynamicNoiseData.Size
staticget

The bytes size of the struct

The documentation for this struct was generated from the following file:
  • VolumeDynamicNoiseData.cs


Aura 2: Member List

  • VolumeDynamicNoiseData
Aura2API.VolumeDynamicNoiseData Member List

This is the complete list of members for Aura2API.VolumeDynamicNoiseData, including all inherited members.

enable | Aura2API.VolumeDynamicNoiseData |
Size | Aura2API.VolumeDynamicNoiseData | static
speed | Aura2API.VolumeDynamicNoiseData |
transform | Aura2API.VolumeDynamicNoiseData |


Aura 2: Aura2API.VolumeGradient Struct Reference

  • VolumeGradient
Public Attributes | List of all members
Aura2API.VolumeGradient Struct Reference

More...

Public Attributes

float | falloffExponent
Exponent of the fading gradient More...
float | xPositiveCubeFade
Normalized size of the fading on the borders, on the positive local X axis More...
float | xNegativeCubeFade
Normalized size of the fading on the borders, on the negative local X axis More...
float | yPositiveCubeFade
Normalized size of the fading on the borders, on the positive local Y axis More...
float | yNegativeCubeFade
Normalized size of the fading on the borders, on the negative local Y axis More...
float | zPositiveCubeFade
Normalized size of the fading on the borders, on the positive local Z axis More...
float | zNegativeCubeFade
Normalized size of the fading on the borders, on the negative local Z axis More...
float | angularConeFade
Normalized size of the fading on the borders, depending on the angle More...
float | distanceConeFade
Normalized size of the fading on the borders, on the positive local Z axis More...
float | widthCylinderFade
Normalized size of the fading on the borders, depending on the distance with the barycenter More...
float | yNegativeCylinderFade
Normalized size of the fading on the borders, on the negative local Y axis More...
float | yPositiveCylinderFade
Normalized size of the fading on the borders, on the positive local Y axis More...
float | distanceSphereFade
Normalized size of the fading on the borders, depending on the distance with the center More...

Detailed Description

Member Data Documentation

◆ angularConeFade

float Aura2API.VolumeGradient.angularConeFade

Normalized size of the fading on the borders, depending on the angle

◆ distanceConeFade

float Aura2API.VolumeGradient.distanceConeFade

Normalized size of the fading on the borders, on the positive local Z axis

◆ distanceSphereFade

float Aura2API.VolumeGradient.distanceSphereFade

Normalized size of the fading on the borders, depending on the distance with the center

◆ falloffExponent

float Aura2API.VolumeGradient.falloffExponent

Exponent of the fading gradient

◆ widthCylinderFade

float Aura2API.VolumeGradient.widthCylinderFade

Normalized size of the fading on the borders, depending on the distance with the barycenter

◆ xNegativeCubeFade

float Aura2API.VolumeGradient.xNegativeCubeFade

Normalized size of the fading on the borders, on the negative local X axis

◆ xPositiveCubeFade

float Aura2API.VolumeGradient.xPositiveCubeFade

Normalized size of the fading on the borders, on the positive local X axis

◆ yNegativeCubeFade

float Aura2API.VolumeGradient.yNegativeCubeFade

Normalized size of the fading on the borders, on the negative local Y axis

◆ yNegativeCylinderFade

float Aura2API.VolumeGradient.yNegativeCylinderFade

Normalized size of the fading on the borders, on the negative local Y axis

◆ yPositiveCubeFade

float Aura2API.VolumeGradient.yPositiveCubeFade

Normalized size of the fading on the borders, on the positive local Y axis

◆ yPositiveCylinderFade

float Aura2API.VolumeGradient.yPositiveCylinderFade

Normalized size of the fading on the borders, on the positive local Y axis

◆ zNegativeCubeFade

float Aura2API.VolumeGradient.zNegativeCubeFade

Normalized size of the fading on the borders, on the negative local Z axis

◆ zPositiveCubeFade

float Aura2API.VolumeGradient.zPositiveCubeFade

Normalized size of the fading on the borders, on the positive local Z axis

The documentation for this struct was generated from the following file:
  • VolumeGradient.cs


Aura 2: Member List

  • VolumeGradient
Aura2API.VolumeGradient Member List

This is the complete list of members for Aura2API.VolumeGradient, including all inherited members.

angularConeFade | Aura2API.VolumeGradient
distanceConeFade | Aura2API.VolumeGradient
distanceSphereFade | Aura2API.VolumeGradient
falloffExponent | Aura2API.VolumeGradient
widthCylinderFade | Aura2API.VolumeGradient
xNegativeCubeFade | Aura2API.VolumeGradient
xPositiveCubeFade | Aura2API.VolumeGradient
yNegativeCubeFade | Aura2API.VolumeGradient
yNegativeCylinderFade | Aura2API.VolumeGradient
yPositiveCubeFade | Aura2API.VolumeGradient
yPositiveCylinderFade | Aura2API.VolumeGradient
zNegativeCubeFade | Aura2API.VolumeGradient
zPositiveCubeFade | Aura2API.VolumeGradient


Aura 2: Aura2API.VolumeInjectionColorParameters Struct Reference

  • VolumeInjectionColorParameters
Public Attributes | List of all members
Aura2API.VolumeInjectionColorParameters Struct Reference

Volume injection parameters for color More...

Public Attributes

VolumeInjectionCommonParameters injectionParameters
Injection parameters More...
Color color
Color of the injection More...

Detailed Description

Volume injection parameters for color

Member Data Documentation

◆ color

Color Aura2API.VolumeInjectionColorParameters.color

Color of the injection

◆ injectionParameters

VolumeInjectionCommonParameters Aura2API.VolumeInjectionColorParameters.injectionParameters

Injection parameters

The documentation for this struct was generated from the following file:
  • VolumeInjectionColorParameters.cs


Aura 2: Member List

  • VolumeInjectionColorParameters
Aura2API.VolumeInjectionColorParameters Member List

This is the complete list of members for Aura2API.VolumeInjectionColorParameters, including all inherited members.

color | Aura2API.VolumeInjectionColorParameters
injectionParameters | Aura2API.VolumeInjectionColorParameters


Aura 2: Aura2API.VolumeInjectionCommonParameters Struct Reference

  • VolumeInjectionCommonParameters
Public Attributes | List of all members
Aura2API.VolumeInjectionCommonParameters Struct Reference

Base volume injection parameters for density/scattering/color More...

Public Attributes

bool | enable
Enables the injection More...
float | strength
Sets the strength of the injection More...
bool | useNoiseMask
Applies the Noise Mask More...
bool | useNoiseMaskLevels
Enables levels on the Noise Mask More...
LevelsParameters noiseMaskLevelParameters
Levels parameters for the noise mask. Similar to the Levels adjustement tool in Photoshop More...
bool | useTexture2DMask
Applies the Texture2D Mask More...
bool | useTexture2DMaskLevels
Enables levels on the Texture2D Mask More...
LevelsParameters texture2DMaskLevelParameters
Levels parameters for the Texture2D mask. Similar to the Levels adjustement tool in Photoshop More...
bool | useTexture3DMask
Applies the Texture3D Mask More...
bool | useTexture3DMaskLevels
Enables levels on the Texture3D Mask More...
LevelsParameters texture3DMaskLevelParameters
Levels parameters for the Texture3D mask. Similar to the Levels adjustement tool in Photoshop More...

Detailed Description

Base volume injection parameters for density/scattering/color

Member Data Documentation

◆ enable

bool Aura2API.VolumeInjectionCommonParameters.enable

Enables the injection

◆ noiseMaskLevelParameters

LevelsParameters Aura2API.VolumeInjectionCommonParameters.noiseMaskLevelParameters

Levels parameters for the noise mask. Similar to the Levels adjustement tool in Photoshop

◆ strength

float Aura2API.VolumeInjectionCommonParameters.strength

Sets the strength of the injection

◆ texture2DMaskLevelParameters

LevelsParameters Aura2API.VolumeInjectionCommonParameters.texture2DMaskLevelParameters

Levels parameters for the Texture2D mask. Similar to the Levels adjustement tool in Photoshop

◆ texture3DMaskLevelParameters

LevelsParameters Aura2API.VolumeInjectionCommonParameters.texture3DMaskLevelParameters

Levels parameters for the Texture3D mask. Similar to the Levels adjustement tool in Photoshop

◆ useNoiseMask

bool Aura2API.VolumeInjectionCommonParameters.useNoiseMask

Applies the Noise Mask

◆ useNoiseMaskLevels

bool Aura2API.VolumeInjectionCommonParameters.useNoiseMaskLevels

Enables levels on the Noise Mask

◆ useTexture2DMask

bool Aura2API.VolumeInjectionCommonParameters.useTexture2DMask

Applies the Texture2D Mask

◆ useTexture2DMaskLevels

bool Aura2API.VolumeInjectionCommonParameters.useTexture2DMaskLevels

Enables levels on the Texture2D Mask

◆ useTexture3DMask

bool Aura2API.VolumeInjectionCommonParameters.useTexture3DMask

Applies the Texture3D Mask

◆ useTexture3DMaskLevels

bool Aura2API.VolumeInjectionCommonParameters.useTexture3DMaskLevels

Enables levels on the Texture3D Mask

The documentation for this struct was generated from the following file:
  • VolumeInjectionCommonParameters.cs


Aura 2: Member List

  • VolumeInjectionCommonParameters
Aura2API.VolumeInjectionCommonParameters Member List

This is the complete list of members for Aura2API.VolumeInjectionCommonParameters, including all inherited members.

enable | Aura2API.VolumeInjectionCommonParameters
noiseMaskLevelParameters | Aura2API.VolumeInjectionCommonParameters
strength | Aura2API.VolumeInjectionCommonParameters
texture2DMaskLevelParameters | Aura2API.VolumeInjectionCommonParameters
texture3DMaskLevelParameters | Aura2API.VolumeInjectionCommonParameters
useNoiseMask | Aura2API.VolumeInjectionCommonParameters
useNoiseMaskLevels | Aura2API.VolumeInjectionCommonParameters
useTexture2DMask | Aura2API.VolumeInjectionCommonParameters
useTexture2DMaskLevels | Aura2API.VolumeInjectionCommonParameters
useTexture3DMask | Aura2API.VolumeInjectionCommonParameters
useTexture3DMaskLevels | Aura2API.VolumeInjectionCommonParameters


Aura 2: Aura2API.VolumeInjectionParameters Struct Reference

  • VolumeInjectionParameters
Public Attributes | List of all members
Aura2API.VolumeInjectionParameters Struct Reference

Volume injection parameters for density/scattering More...

Public Attributes

VolumeInjectionCommonParameters injectionParameters
Injection parameters More...

Detailed Description

Volume injection parameters for density/scattering

Member Data Documentation

◆ injectionParameters

VolumeInjectionCommonParameters Aura2API.VolumeInjectionParameters.injectionParameters

Injection parameters

The documentation for this struct was generated from the following file:
  • VolumeInjectionParameters.cs


Aura 2: Member List

  • VolumeInjectionParameters
Aura2API.VolumeInjectionParameters Member List

This is the complete list of members for Aura2API.VolumeInjectionParameters, including all inherited members.

injectionParameters Aura2API.VolumeInjectionParameters


Aura 2: Aura2API.VolumeInjectionShape Struct Reference

  • VolumeInjectionShape
Public Attributes | List of all members
Aura2API.VolumeInjectionShape Struct Reference

Public Attributes

VolumeType shape
Shape of the volume More...
VolumeGradient fading
Fading parameters for the borders of the shape More...

Member Data Documentation

◆ fading

VolumeGradient Aura2API.VolumeInjectionShape.fading

Fading parameters for the borders of the shape

◆ shape

VolumeType Aura2API.VolumeInjectionShape.shape

Shape of the volume

The documentation for this struct was generated from the following file:
  • VolumeInjectionShape.cs


Aura 2: Member List

  • VolumeInjectionShape
Aura2API.VolumeInjectionShape Member List

This is the complete list of members for Aura2API.VolumeInjectionShape, including all inherited members.

fading | Aura2API.VolumeInjectionShape
shape | Aura2API.VolumeInjectionShape


Aura 2: Aura2API.VolumesCommonDataManager Class Reference

  • VolumesCommonDataManager
Public Member Functions | Static Public Attributes | Properties | Events | List of all members
Aura2API.VolumesCommonDataManager Class Reference

Handles the volumes' registration and maps collection More...

Public Member Functions

void RegisterVolume (AuraVolume auraVolume)
Registers the Aura Volume to the global manager More...

Static Public Attributes

static readonly int | texture3DMaskSize = 16
The size of the Texture3D masks More...
static readonly int | texture2DMaskSize = 512
The size of the Texture2D masks More...

Properties

List< AuraVolume > | RegisteredVolumesList [get]
Accessor to the list of registered Aura Volumes More...
List< AuraVolume > | RegisteredLightProbesProxyVolumesList [get]
Accessor to the list of registered Aura Volumes used as Light Probes Proxy Volume More...
bool | HasRegisteredVolumes [get]
Tells if has registered volumes More...
bool | HasRegisteredLightProbesProxyVolumes [get]
Tells if has registered Aura Volumes used as Light Probes Proxy Volume More...
bool | HasTexture2DMasks [get]
Tells if there are any Texture2D mask More...
Texture2DArray | Texture2DMasksAtlas [get]
Accessor to the Texture2DArray containing the Texture2D masks More...
bool | HasTexture3DMasks [get]
Tells if there are any Texture3D mask More...
Texture3D | Texture3DMasksAtlas [get]
Accessor to the Texture3D containing the Texture3D masks More...

Events

Action< AuraVolume > | OnRegisterVolume
Event raised when a volume is being registred More...
Action< AuraVolume > | OnUnregisterVolume
Event raised when a volume is being unregistred More...

Detailed Description

Handles the volumes' registration and maps collection

Member Function Documentation

◆ RegisterVolume()

void Aura2API.VolumesCommonDataManager.RegisterVolume ( AuraVolume auraVolume )

Registers the Aura Volume to the global manager

Parameters
auravolume The Aura Volume to register

Member Data Documentation

◆ texture2DMaskSize

readonly int Aura2API.VolumesCommonDataManager.texture2DMaskSize = 512
static

The size of the Texture2D masks

◆ texture3DMaskSize

readonly int Aura2API.VolumesCommonDataManager.texture3DMaskSize = 16
static

The size of the Texture3D masks

Property Documentation

◆ HasRegisteredLightProbesProxyVolumes

bool Aura2API.VolumesCommonDataManager.HasRegisteredLightProbesProxyVolumes
get

Tells if has registered Aura Volumes used as Light Probes Proxy Volume

◆ HasRegisteredVolumes

bool Aura2API.VolumesCommonDataManager.HasRegisteredVolumes
get

Tells if has registered volumes

◆ HasTexture2DMasks

bool Aura2API.VolumesCommonDataManager.HasTexture2DMasks
get

Tells if there are any Texture2D mask

◆ HasTexture3DMasks

bool Aura2API.VolumesCommonDataManager.HasTexture3DMasks
get

Tells if there are any Texture3D mask

◆ RegisteredLightProbesProxyVolumesList

List<AuraVolume> Aura2API.VolumesCommonDataManager.RegisteredLightProbesProxyVolumesList
get

Accessor to the list of registered Aura Volumes used as Light Probes Proxy Volume

◆ RegisteredVolumesList

List<AuraVolume> Aura2API.VolumesCommonDataManager.RegisteredVolumesList
get

Accessor to the list of registered Aura Volumes

◆ Texture2DMasksAtlas

Texture2DArray Aura2API.VolumesCommonDataManager.Texture2DMasksAtlas
get

Accessor to the Texture2DArray containing the Texture2D masks

◆ Texture3DMasksAtlas

Texture3D Aura2API.VolumesCommonDataManager.Texture3DMasksAtlas
get

Accessor to the Texture3D containing the Texture3D masks

Event Documentation

◆ OnRegisterVolume

Action<AuraVolume> Aura2API.VolumesCommonDataManager.OnRegisterVolume

Event raised when a volume is being registred

◆ OnUnregisterVolume

Action<AuraVolume> Aura2API.VolumesCommonDataManager.OnUnregisterVolume

Event raised when a volume is being unregistred

The documentation for this class was generated from the following file:
  • VolumesCommonDataManager.cs


Aura 2: Member List

  • VolumesCommonDataManager
Aura2API.VolumesCommonDataManager Member List

This is the complete list of members for Aura2API.VolumesCommonDataManager, including all inherited members.

HasRegisteredLightProbesProxyVolumes | Aura2API.VolumesCommonDataManager |
HasRegisteredVolumes | Aura2API.VolumesCommonDataManager |
HasTexture2DMasks | Aura2API.VolumesCommonDataManager |
HasTexture3DMasks | Aura2API.VolumesCommonDataManager |
OnRegisterVolume | Aura2API.VolumesCommonDataManager |
OnUnregisterVolume | Aura2API.VolumesCommonDataManager |
RegisteredLightProbesProxyVolumesList | Aura2API.VolumesCommonDataManager |
RegisteredVolumesList | Aura2API.VolumesCommonDataManager |
RegisterVolume(AuraVolume auraVolume) | Aura2API.VolumesCommonDataManager |
Texture2DMasksAtlas | Aura2API.VolumesCommonDataManager |
texture2DMaskSize | Aura2API.VolumesCommonDataManager | static
Texture3DMasksAtlas | Aura2API.VolumesCommonDataManager |
texture3DMaskSize | Aura2API.VolumesCommonDataManager | static


Aura 2: Aura2API.VolumesManager Class Reference

  • VolumesManager
Public Member Functions | Public Attributes | Properties | List of all members
Aura2API.VolumesManager Class Reference

Manages the volumes, collects and packs data and volumetric textures More...

Public Member Functions

VolumesManager (Camera camera, FrustumSettings frustumSettings)
Constructor More...
void Dispose ()
Releases unmanaged objects and unregisters events More...

Public Attributes

FrustumSettings _frustumSettings
Settings of the frustum More...

Properties

ComputeBuffer | EmptyBuffer [get]
One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility) More...
ComputeBuffer | Buffer [get]
The compute buffer in charge of passing the volumes' data to the compute shaders More...
bool | HasVisibleVolumes [get]
Is one or more volume(s) inside the ranged frustum? More...

Detailed Description

Manages the volumes, collects and packs data and volumetric textures

Constructor & Destructor Documentation

◆ VolumesManager()

Aura2API.VolumesManager.VolumesManager | ( | Camera | camera,
 |  | FrustumSettings | frustumSettings
 | ) |  |

Constructor

Parameters
camera | The reference camera, for culling purposes
frustumSettings | The frustum settings

Member Function Documentation

◆ Dispose()

void Aura2API.VolumesManager.Dispose ( )

Releases unmanaged objects and unregisters events

Member Data Documentation

◆ _frustumSettings

FrustumSettings Aura2API.VolumesManager._frustumSettings

Settings of the frustum

Property Documentation

◆ Buffer

ComputeBuffer Aura2API.VolumesManager.Buffer
get

The compute buffer in charge of passing the volumes' data to the compute shaders

◆ EmptyBuffer

ComputeBuffer Aura2API.VolumesManager.EmptyBuffer
get

One count buffer used to assign to the compute shader when the branch path is unused (for cross platform compatibility)

◆ HasVisibleVolumes

bool Aura2API.VolumesManager.HasVisibleVolumes
get

Is one or more volume(s) inside the ranged frustum?

The documentation for this class was generated from the following file:
  • VolumesManager.cs


Aura 2: Member List

  • VolumesManager
Aura2API.VolumesManager Member List

This is the complete list of members for Aura2API.VolumesManager, including all inherited members.

_frustumSettings | Aura2API.VolumesManager
Buffer | Aura2API.VolumesManager
Dispose() | Aura2API.VolumesManager
EmptyBuffer | Aura2API.VolumesManager
HasVisibleVolumes | Aura2API.VolumesManager
VolumesManager(Camera camera, FrustumSettings frustumSettings) | Aura2API.VolumesManager


Aura 2: Class Index

Class Index
a | c | d | f | l | m | p | s | t | v
a
CullableObject (Aura2API) LevelsParameters (Aura2API) SpotLightParameters (Aura2API) VolumeData (Aura2API)
d
LightsCommonDataManager (Aura2API) SpotLightsManager (Aura2API) VolumeDynamicNoiseData (Aura2API)
AmbientLightingCommonDataManager (Aura2API)
m
SwappableRenderTexture (Aura2API) VolumeGradient (Aura2API)
AuraBaseSettings (Aura2API) DirectionalLightParameters (Aura2API)
t
VolumeInjectionColorParameters (Aura2API)
AuraCamera (Aura2API) DirectionalLightsManager (Aura2API) MatrixFloats (Aura2API) VolumeInjectionCommonParameters (Aura2API)
AuraLight (Aura2API) DirectionalShadowDataCollector (Aura2API)
p
Texture2DArrayComposer (Aura2API) VolumeInjectionParameters (Aura2API)
AuraQualitySettings (Aura2API) DynamicNoiseParameters (Aura2API) Texture2DMask (Aura2API) VolumeInjectionShape (Aura2API)
AuraResourcesCollection (Aura2API)
f
PointLightParameters (Aura2API) Texture3DMask (Aura2API) VolumesCommonDataManager (Aura2API)
AuraSprite (Aura2API) PointLightsManager (Aura2API) Texture3DPreviewAttribute (Aura2API) VolumesManager (Aura2API)
AuraVolume (Aura2API) Frustum (Aura2API)
s
TextureBuffers (Aura2API)
c
FrustumSettings (Aura2API) TextureMaskData (Aura2API)
FrustumSettingsParameters (Aura2API) ShadowmapsCollector (Aura2API) TransformParameters (Aura2API)
ColorCircularPickerAttribute (Aura2API) FrustumSettingsToId (Aura2API) SphericalHarmonicsCoefficients (Aura2API)
v
CommonDataManager (Aura2API)
l
SphericalHarmonicsFirstBandCoefficients (Aura2API)
VisibleCellData (Aura2API)
LevelsData (Aura2API)
a | c | d | f | l | m | p | s | t | v


Aura 2: Class Hierarchy

Class Hierarchy
This inheritance list is sorted roughly, but not completely, alphabetically:
[detail level 123]
C Aura2API.AmbientLightingCommonDataManager | Handles the ambient lighting data
C Aura2API.CommonDataManager | Handles the lights' and volumes' commond data managers
C Aura2API.DirectionalLightParameters | Struct containing parameters of a directional AuraLight
C Aura2API.DirectionalLightsManager | Manager that handles directional AuraLights
C Aura2API.DynamicNoiseParameters | Collection of parameters for 4D dynamic noise mask to be used in a volume
C Aura2API.Frustum | Ranged camera frustum inside which the volumetric data will be computed
C Aura2API.FrustumSettings | Collection of settings for the data computation
C Aura2API.FrustumSettingsParameters | Collection of settings defining the computation of the volumetric data
C Aura2API.FrustumSettingsToId | Collects all the settings and compute the flag Id to be used as kernel id of the computeDataComputeShader
C Aura2API.LevelsData | Ordered struct of Levels operation parameters to be sent to the compute shader
C Aura2API.LevelsParameters | Collection of parameters for Levels adjustement. Similar to the same tool in Photoshop.
C Aura2API.LightsCommonDataManager | Handles the lights' registration and maps collection
C Aura2API.MatrixFloats | Ordered struct of Vector4 representing a matrix to be sent to the compute shader
▼C MonoBehaviour |
C Aura2API.AuraCamera | Main component to assign on a GameObject with a Camera component
C Aura2API.AuraSprite | Component allowing the sprites to work with the Aura system
▼C Aura2API.CullableObject | Class to inherit from when using an ObjectCuller
C Aura2API.AuraLight | Component to assign on a GameObject with a Light component if you want this Light to be taken into account in Aura
C Aura2API.AuraVolume | Component allowing the volume injection of density/scattering/light
C Aura2API.PointLightParameters | Struct containing parameters of a point AuraLight
C Aura2API.PointLightsManager | Manager that handles point AuraLights
▼C PropertyAttribute |
C Aura2API.ColorCircularPickerAttribute | Custom attribute for enabling circular picker on Color properties
C Aura2API.Texture3DPreviewAttribute | Attribute enabling Texture3D preview in a Monobehaviour component in the Inspector
▼C ScriptableObject |
C Aura2API.AuraBaseSettings | Base injection settings for the data computation
C Aura2API.AuraQualitySettings | Quality settings for Aura2 computation
C Aura2API.AuraResourcesCollection |
C Aura2API.SphericalHarmonicsCoefficients | Struct containing spherical harmonics coefficients to use probes in shaders
C Aura2API.SphericalHarmonicsFirstBandCoefficients | Struct containing spherical harmonics coefficients to use probes in shaders
C Aura2API.SpotLightParameters | Struct containing parameters of a spot AuraLight
C Aura2API.SpotLightsManager | Manager that handles spot AuraLights
C Aura2API.SwappableRenderTexture | Double buffering render texture
▼C Aura2API.Texture2DArrayComposer | Builds a Texture2DArray out of a collection of Textures
C Aura2API.DirectionalShadowDataCollector | Texture2DArray composer used for collecting directional shadow data maps
C Aura2API.ShadowmapsCollector | Texture2DArray composer used for collecting shadow maps
C Aura2API.Texture2DMask | Texture2D mask to be used in a AuraVolume
C Aura2API.Texture3DMask | Texture3D mask to be used in a AuraVolume
C Aura2API.TextureBuffers | Collection of texture buffers which contain the computed volumetric data
C Aura2API.TextureMaskData | Ordered struct of texture mask parameters to be sent to the compute shader
C Aura2API.TransformParameters | Used for transforming reference position for textures/noise inside volumes
C Aura2API.VisibleCellData | Struct containing data size of a visible cell inside the volume
C Aura2API.VolumeData | Ordered struct of volume parameters to be sent to the compute shader
C Aura2API.VolumeDynamicNoiseData | Ordered struct of noise parameters to be sent to the compute shader
C Aura2API.VolumeGradient |
C Aura2API.VolumeInjectionColorParameters | Volume injection parameters for color
C Aura2API.VolumeInjectionCommonParameters | Base volume injection parameters for density/scattering/color
C Aura2API.VolumeInjectionParameters | Volume injection parameters for density/scattering
C Aura2API.VolumeInjectionShape |
C Aura2API.VolumesCommonDataManager | Handles the volumes' registration and maps collection
C Aura2API.VolumesManager | Manages the volumes, collects and packs data and volumetric textures


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- _ -

  • _computeVisibleCellsComputeShader : Aura2API.Frustum
  • _frustum : Aura2API.AuraCamera
  • _frustumSettings : Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • a : Aura2API.MatrixFloats
  • AddTexture() : Aura2API.Texture2DArrayComposer
  • alwaysGenerateOnUpdate : Aura2API.Texture2DArrayComposer
  • ambientInjection : Aura2API.AuraVolume
  • AmbientLightingCommonDataManager : Aura2API.CommonDataManager
  • ambientLightingStrength : Aura2API.AuraBaseSettings
  • ambientLightingValue : Aura2API.VolumeData
  • ambientNoiseLevelsParameters : Aura2API.VolumeData
  • ambientTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • ambientTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • angularConeFade : Aura2API.VolumeGradient
  • applyBlurFilterComputeShader : Aura2API.AuraResourcesCollection
  • applyDenoisingFilterComputeShader : Aura2API.AuraResourcesCollection


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • b : Aura2API.MatrixFloats
  • baseSettings : Aura2API.FrustumSettings
  • BaseSettings : Aura2API.FrustumSettings
  • blueNoiseTextureArray : Aura2API.AuraResourcesCollection
  • boostInjection : Aura2API.AuraVolume
  • boostNoiseLevelsParameters : Aura2API.VolumeData
  • boostTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • boostTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • boostValue : Aura2API.VolumeData
  • BoundingSphere : Aura2API.CullableObject
  • Bounds : Aura2API.AuraVolume
  • Buffer : Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • c : Aura2API.MatrixFloats
  • CameraComponent : Aura2API.AuraCamera
  • CandidateLights : Aura2API.DirectionalLightsManager
  • CandidateLightsCount : Aura2API.DirectionalLightsManager
  • CastsCookie : Aura2API.AuraLight
  • CastsShadows : Aura2API.AuraLight
  • CheckFrustumOverlap() : Aura2API.CullableObject
  • ClearTexturesList() : Aura2API.Texture2DArrayComposer
  • Coefficients : Aura2API.AmbientLightingCommonDataManager
  • color : Aura2API.AuraBaseSettings , Aura2API.VolumeInjectionColorParameters
  • ColorCircularPickerAttribute() : Aura2API.ColorCircularPickerAttribute
  • colorNoiseLevelsParameters : Aura2API.VolumeData
  • colorStrength : Aura2API.AuraBaseSettings
  • colorTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • colorTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • colorValue : Aura2API.VolumeData
  • CommonDataManager : Aura2API.AuraCamera
  • computeAccumulationComputeShader : Aura2API.AuraResourcesCollection
  • ComputeData() : Aura2API.Frustum
  • computeDataComputeShader : Aura2API.AuraResourcesCollection
  • ComputeFlags() : Aura2API.FrustumSettingsToId
  • computeMaximumDepthComputeShader : Aura2API.AuraResourcesCollection
  • computeVisibleCellsComputeShader : Aura2API.AuraResourcesCollection
  • contrast : Aura2API.LevelsData , Aura2API.LevelsParameters
  • cookieMapRenderTexture : Aura2API.AuraLight
  • cookieMapSize : Aura2API.DirectionalLightsManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • CreateGameObject() : Aura2API.AuraCamera , Aura2API.AuraLight , Aura2API.AuraSprite , Aura2API.AuraVolume
  • customAngularFalloffPower : Aura2API.AuraLight
  • customAngularFalloffThreshold : Aura2API.AuraLight
  • customCookieDistanceFalloffEndThreshold : Aura2API.AuraLight
  • customCookieDistanceFalloffPower : Aura2API.AuraLight
  • customCookieDistanceFalloffStartThreshold : Aura2API.AuraLight
  • customDistanceFalloffPower : Aura2API.AuraLight
  • customDistanceFalloffThreshold : Aura2API.AuraLight


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • d : Aura2API.MatrixFloats
  • Data : Aura2API.LevelsParameters
  • DataBuffer : Aura2API.DirectionalLightsManager
  • DataVolumeTexture : Aura2API.TextureBuffers
  • debugOcclusionCulling : Aura2API.AuraQualitySettings
  • Default : Aura2API.LevelsParameters
  • defaultSprite : Aura2API.AuraResourcesCollection
  • DeltaTtime : Aura2API.AuraCamera
  • density : Aura2API.AuraBaseSettings
  • densityInjection : Aura2API.AuraVolume
  • densityNoiseLevelsParameters : Aura2API.VolumeData
  • densityTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • densityTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • densityValue : Aura2API.VolumeData
  • depthBiasCoefficient : Aura2API.AuraQualitySettings
  • DirectionalCookieMapsArray : Aura2API.LightsCommonDataManager
  • DirectionalLightsManager : Aura2API.LightsCommonDataManager
  • DirectionalShadowDataArray : Aura2API.LightsCommonDataManager
  • DirectionalShadowDataCollector() : Aura2API.DirectionalShadowDataCollector
  • DirectionalShadowMapsArray : Aura2API.LightsCommonDataManager
  • displayVolumetricLightingBuffer : Aura2API.AuraQualitySettings
  • Dispose() : Aura2API.CommonDataManager , Aura2API.DirectionalLightsManager , Aura2API.Frustum , Aura2API.LightsCommonDataManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager
  • distanceConeFade : Aura2API.VolumeGradient
  • distanceSphereFade : Aura2API.VolumeGradient
  • dummyTexture : Aura2API.AuraResourcesCollection
  • dummyTexture3D : Aura2API.AuraResourcesCollection
  • dummyTextureArray : Aura2API.AuraResourcesCollection


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • EmptyBuffer : Aura2API.DirectionalLightsManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager
  • enable : Aura2API.DynamicNoiseParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask , Aura2API.VolumeDynamicNoiseData , Aura2API.VolumeInjectionCommonParameters
  • enableAmbientLighting : Aura2API.AuraQualitySettings
  • enableAutomaticStereoResizing : Aura2API.AuraQualitySettings
  • enableDirectionalLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableDirectionalLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableDithering : Aura2API.AuraQualitySettings
  • enableLightProbes : Aura2API.AuraQualitySettings
  • enableLightsCookies : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableOcclusionCulling : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableOutOfPhaseColor : Aura2API.AuraLight
  • enablePointLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enablePointLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableSpotLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableSpotLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableTemporalReprojection : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumes : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumesNoiseMask : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumesTexture2DMask : Aura2API.AuraQualitySettings
  • enableVolumesTexture3DMask : Aura2API.AuraQualitySettings
  • enableVolumesTextureMask : Aura2API.FrustumSettingsParameters
  • EXPERIMENTAL_blurFilterGaussianDeviation : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_blurFilterRange : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_blurFilterType : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_denoisingFilterRange : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_enableBlurFilter : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_enableDenoisingFilter : Aura2API.AuraQualitySettings
  • extinction : Aura2API.AuraBaseSettings


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • fading : Aura2API.VolumeInjectionShape
  • falloffExponent : Aura2API.VolumeData , Aura2API.VolumeGradient
  • farClipPlaneDistance : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • FogVolumeTexture : Aura2API.TextureBuffers
  • FrameId : Aura2API.AuraCamera
  • Frustum() : Aura2API.Frustum
  • frustumGridResolution : Aura2API.AuraQualitySettings
  • frustumSettings : Aura2API.AuraCamera


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • Generate() : Aura2API.Texture2DArrayComposer
  • GetData() : Aura2API.AuraVolume
  • GetDirectionnalParameters() : Aura2API.AuraLight
  • GetFrustumGridResolution() : Aura2API.AuraQualitySettings
  • GetKernelId() : Aura2API.FrustumSettingsToId
  • GetPointParameters() : Aura2API.AuraLight
  • GetSpotParameters() : Aura2API.AuraLight
  • GetTextureIndex() : Aura2API.Texture2DArrayComposer
  • GlobalStrength : Aura2API.AmbientLightingCommonDataManager


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • HasCandidateLights : Aura2API.DirectionalLightsManager
  • HasDirectionalCookieCasters : Aura2API.LightsCommonDataManager
  • HasDirectionalShadowCasters : Aura2API.LightsCommonDataManager
  • HasFlags() : Aura2API.FrustumSettingsToId
  • HasPointCookieCasters : Aura2API.LightsCommonDataManager
  • HasPointShadowCasters : Aura2API.LightsCommonDataManager
  • HasRegisteredDirectionalLights : Aura2API.LightsCommonDataManager
  • HasRegisteredLightProbesProxyVolumes : Aura2API.VolumesCommonDataManager
  • HasRegisteredPointLights : Aura2API.LightsCommonDataManager
  • HasRegisteredSpotLights : Aura2API.LightsCommonDataManager
  • HasRegisteredVolumes : Aura2API.VolumesCommonDataManager
  • HasSpotCookieCasters : Aura2API.LightsCommonDataManager
  • HasSpotShadowCasters : Aura2API.LightsCommonDataManager
  • HasTexture : Aura2API.Texture2DArrayComposer
  • HasTexture2DMasks : Aura2API.VolumesCommonDataManager
  • HasTexture3DMasks : Aura2API.VolumesCommonDataManager
  • HasVisibleLights : Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • HasVisibleVolumes : Aura2API.VolumesManager


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • index : Aura2API.TextureMaskData
  • Init() : Aura2API.FrustumSettingsParameters
  • injectAmbient : Aura2API.VolumeData
  • injectBoost : Aura2API.VolumeData
  • injectColor : Aura2API.VolumeData
  • injectDensity : Aura2API.VolumeData
  • injectionParameters : Aura2API.VolumeInjectionColorParameters , Aura2API.VolumeInjectionParameters
  • injectScattering : Aura2API.VolumeData
  • injectTint : Aura2API.VolumeData
  • IsInitialized : Aura2API.AuraCamera


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • levelHiThreshold : Aura2API.LevelsData , Aura2API.LevelsParameters
  • levelLowThreshold : Aura2API.LevelsData , Aura2API.LevelsParameters
  • LightComponent : Aura2API.AuraLight
  • lightInjection : Aura2API.AuraVolume
  • LightProbesCoefficients : Aura2API.TextureBuffers
  • LightProbesCoefficientsComputeBuffer : Aura2API.TextureBuffers
  • LightProbesCoefficientsTexture : Aura2API.TextureBuffers
  • LightProbesCoefficientsTextureResolution : Aura2API.TextureBuffers
  • LightProbesCoefficientsTextureResolutionIsValid : Aura2API.TextureBuffers
  • lightProbesMultiplier : Aura2API.AuraVolume , Aura2API.VolumeData
  • LightsCommonDataManager : Aura2API.CommonDataManager , Aura2API.LightsCommonDataManager
  • LoadBaseSettings() : Aura2API.FrustumSettings
  • LoadQualitySettings() : Aura2API.FrustumSettings


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • Matrix : Aura2API.TransformParameters


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NeedsToUpdateTexture : Aura2API.Texture2DArrayComposer
  • noiseData : Aura2API.VolumeData
  • noiseMask : Aura2API.AuraVolume
  • noiseMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • occlusionCullingAccuracy : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • OcclusionTexture : Aura2API.TextureBuffers
  • OnCascadesCountChanged : Aura2API.LightsCommonDataManager
  • One : Aura2API.LevelsParameters
  • OnFrustumQualityChanged : Aura2API.FrustumSettings
  • OnRegisterPointLight : Aura2API.LightsCommonDataManager
  • OnRegisterSpotLight : Aura2API.LightsCommonDataManager
  • OnRegisterVolume : Aura2API.VolumesCommonDataManager
  • OnUninitialize : Aura2API.AuraLight , Aura2API.AuraVolume
  • OnUnregisterPointLight : Aura2API.LightsCommonDataManager
  • OnUnregisterSpotLight : Aura2API.LightsCommonDataManager
  • OnUnregisterVolume : Aura2API.VolumesCommonDataManager
  • outOfPhaseColor : Aura2API.AuraLight
  • outOfPhaseColorStrength : Aura2API.AuraLight
  • outputHiValue : Aura2API.LevelsData , Aura2API.LevelsParameters
  • outputLowValue : Aura2API.LevelsData , Aura2API.LevelsParameters
  • overrideColor : Aura2API.AuraLight
  • overrideScattering : Aura2API.AuraLight
  • overridingColor : Aura2API.AuraLight
  • overridingScattering : Aura2API.AuraLight


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • PointCookieMapsArray : Aura2API.LightsCommonDataManager
  • PointLightsManager() : Aura2API.PointLightsManager
  • PointShadowMapsArray : Aura2API.LightsCommonDataManager
  • position : Aura2API.TransformParameters
  • postProcessShader : Aura2API.AuraResourcesCollection
  • processOcclusionMapShader : Aura2API.AuraResourcesCollection


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- q -

  • QualitySettings : Aura2API.FrustumSettings
  • qualitySettings : Aura2API.FrustumSettings


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RaiseOnQualityChanged() : Aura2API.FrustumSettings
  • RaiseTextureUpdatedEvent() : Aura2API.Texture2DArrayComposer
  • ReadBuffer : Aura2API.SwappableRenderTexture
  • RegisteredDirectionalLightsList : Aura2API.LightsCommonDataManager
  • RegisteredLightProbesProxyVolumesList : Aura2API.VolumesCommonDataManager
  • RegisteredPointLightsList : Aura2API.LightsCommonDataManager
  • RegisteredSpotLightsList : Aura2API.LightsCommonDataManager
  • RegisteredVolumesList : Aura2API.VolumesCommonDataManager
  • RegisterLight() : Aura2API.LightsCommonDataManager
  • RegisterVolume() : Aura2API.VolumesCommonDataManager
  • Release() : Aura2API.SwappableRenderTexture
  • ReleaseAllBuffers() : Aura2API.TextureBuffers
  • ReleaseAllLightProbesBuffers() : Aura2API.TextureBuffers
  • ReleaseLightProbesCoefficientsBuffer() : Aura2API.TextureBuffers
  • ReleaseLightProbesCoefficientsTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseOcclusionTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseSliceTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseVolumeTextureBuffers() : Aura2API.TextureBuffers
  • RemoveTexture() : Aura2API.Texture2DArrayComposer
  • renderLightProbesTextureComputeShader : Aura2API.AuraResourcesCollection
  • RequiredSizeX : Aura2API.Texture2DArrayComposer
  • RequiredSizeY : Aura2API.Texture2DArrayComposer
  • Resize() : Aura2API.Texture2DArrayComposer
  • resolution : Aura2API.FrustumSettingsParameters
  • rotation : Aura2API.TransformParameters


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • saturateOutputValues : Aura2API.LevelsParameters
  • scale : Aura2API.TransformParameters
  • scattering : Aura2API.AuraBaseSettings
  • scatteringBias : Aura2API.AuraLight
  • scatteringInjection : Aura2API.AuraVolume
  • scatteringNoiseLevelsParameters : Aura2API.VolumeData
  • scatteringTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • scatteringTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • scatteringValue : Aura2API.VolumeData
  • SetCookieMapIndex() : Aura2API.AuraLight
  • SetDefaultValues() : Aura2API.LevelsParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • SetFrustumGridResolution() : Aura2API.AuraCamera , Aura2API.AuraQualitySettings , Aura2API.Frustum
  • SetLightProbesProxyGridResolution() : Aura2API.AuraCamera
  • SetShadowMapIndex() : Aura2API.AuraLight
  • shadowDataRenderTexture : Aura2API.AuraLight
  • shadowMapRenderTexture : Aura2API.AuraLight
  • ShadowmapsCollector() : Aura2API.ShadowmapsCollector
  • ShadowMapSize : Aura2API.DirectionalLightsManager
  • shadowMapSize : Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • shape : Aura2API.VolumeData , Aura2API.VolumeInjectionShape
  • ShoukdComputeTexture2DMasking : Aura2API.AuraVolume
  • ShouldComputeNoise : Aura2API.AuraVolume
  • ShouldComputeTexture3DMasking : Aura2API.AuraVolume
  • showField : Aura2API.Texture3DPreviewAttribute
  • showLabel : Aura2API.ColorCircularPickerAttribute
  • Size : Aura2API.DirectionalLightParameters , Aura2API.LevelsData , Aura2API.MatrixFloats , Aura2API.PointLightParameters , Aura2API.SphericalHarmonicsCoefficients , Aura2API.SphericalHarmonicsFirstBandCoefficients , Aura2API.SpotLightParameters , Aura2API.TextureMaskData , Aura2API.VisibleCellData , Aura2API.VolumeData , Aura2API.VolumeDynamicNoiseData
  • SliceTexture : Aura2API.TextureBuffers
  • space : Aura2API.TransformParameters
  • speed : Aura2API.DynamicNoiseParameters , Aura2API.VolumeDynamicNoiseData
  • SpotCookieMapsArray : Aura2API.LightsCommonDataManager
  • SpotLightsManager() : Aura2API.SpotLightsManager
  • SpotShadowMapsArray : Aura2API.LightsCommonDataManager
  • spriteLitShader : Aura2API.AuraResourcesCollection
  • spriteUnlitShader : Aura2API.AuraResourcesCollection
  • storeDirectionalShadowDataShader : Aura2API.AuraResourcesCollection
  • storeDirectionalSpotCookieMapShader : Aura2API.AuraResourcesCollection
  • storePointCookieMapShader : Aura2API.AuraResourcesCollection
  • storePointShadowMapMesh : Aura2API.AuraResourcesCollection
  • storePointShadowMapShader : Aura2API.AuraResourcesCollection
  • strength : Aura2API.AuraLight , Aura2API.VolumeInjectionCommonParameters
  • Swap() : Aura2API.SwappableRenderTexture
  • SwappableRenderTexture() : Aura2API.SwappableRenderTexture


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • temporalReprojectionFactor : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • Texture : Aura2API.Texture2DArrayComposer
  • texture : Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • Texture2DArrayComposer() : Aura2API.Texture2DArrayComposer
  • texture2DMask : Aura2API.AuraVolume
  • texture2DMaskData : Aura2API.VolumeData
  • texture2DMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters
  • Texture2DMasksAtlas : Aura2API.VolumesCommonDataManager
  • texture2DMaskSize : Aura2API.VolumesCommonDataManager
  • texture3DFiltering : Aura2API.AuraQualitySettings
  • texture3DMask : Aura2API.AuraVolume
  • texture3DMaskData : Aura2API.VolumeData
  • texture3DMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters
  • Texture3DMasksAtlas : Aura2API.VolumesCommonDataManager
  • texture3DMaskSize : Aura2API.VolumesCommonDataManager
  • Texture3DPreviewAttribute() : Aura2API.Texture3DPreviewAttribute
  • TextureCount : Aura2API.Texture2DArrayComposer
  • textureIndex : Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • Time : Aura2API.AuraCamera
  • tint : Aura2API.AuraBaseSettings
  • tintColor : Aura2API.VolumeData
  • tintInjection : Aura2API.AuraVolume
  • tintNoiseLevelsParameters : Aura2API.VolumeData
  • tintStrength : Aura2API.AuraBaseSettings
  • tintTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • tintTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • ToMatrixFloats() : Aura2API.MatrixFloats
  • transform : Aura2API.DynamicNoiseParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask , Aura2API.TextureMaskData , Aura2API.VolumeData , Aura2API.VolumeDynamicNoiseData
  • Type : Aura2API.AuraLight


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • Update() : Aura2API.AmbientLightingCommonDataManager , Aura2API.DirectionalLightsManager , Aura2API.LightsCommonDataManager
  • UpdateBoundingSphere() : Aura2API.CullableObject
  • UpdateData() : Aura2API.CommonDataManager
  • useAmbientLighting : Aura2API.AuraBaseSettings
  • useAsLightProbesProxyVolume : Aura2API.AuraVolume , Aura2API.VolumeData
  • useColor : Aura2API.AuraBaseSettings
  • useColorTemperatureTint : Aura2API.AuraLight
  • useCookie : Aura2API.AuraLight
  • useDensity : Aura2API.AuraBaseSettings
  • useExtinction : Aura2API.AuraBaseSettings
  • useNoiseMask : Aura2API.VolumeInjectionCommonParameters
  • useNoiseMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useScattering : Aura2API.AuraBaseSettings , Aura2API.AuraLight
  • useShadow : Aura2API.AuraLight
  • UsesTexture2DMasking : Aura2API.AuraVolume
  • UsesTexture3DMasking : Aura2API.AuraVolume
  • useTexture2DMask : Aura2API.VolumeInjectionCommonParameters
  • useTexture2DMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useTexture3DMask : Aura2API.VolumeInjectionCommonParameters
  • useTexture3DMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useTint : Aura2API.AuraBaseSettings


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • VolumesCommonDataManager : Aura2API.CommonDataManager
  • volumeShape : Aura2API.AuraVolume
  • VolumesManager() : Aura2API.VolumesManager
  • VolumetricBuffersResolution : Aura2API.TextureBuffers
  • VolumetricBuffersResolutionIsValid : Aura2API.TextureBuffers


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • widthCylinderFade : Aura2API.VolumeGradient
  • WriteBuffer : Aura2API.SwappableRenderTexture


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • xNegativeCubeFade : Aura2API.VolumeGradient
  • xNegativeFade : Aura2API.VolumeData
  • xPositiveCubeFade : Aura2API.VolumeGradient
  • xPositiveFade : Aura2API.VolumeData


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • yNegativeCubeFade : Aura2API.VolumeGradient
  • yNegativeCylinderFade : Aura2API.VolumeGradient
  • yNegativeFade : Aura2API.VolumeData
  • yPositiveCubeFade : Aura2API.VolumeGradient
  • yPositiveCylinderFade : Aura2API.VolumeGradient
  • yPositiveFade : Aura2API.VolumeData


Aura 2: Class Members

Here is a list of all documented class members with links to the class documentation for each member:

- z -

  • Zero : Aura2API.LevelsParameters
  • zNegativeCubeFade : Aura2API.VolumeGradient
  • zNegativeFade : Aura2API.VolumeData
  • zPositiveCubeFade : Aura2API.VolumeGradient
  • zPositiveFade : Aura2API.VolumeData


Aura 2: Class Members - Functions

- a -

  • AddTexture() : Aura2API.Texture2DArrayComposer

- c -

  • CheckFrustumOverlap() : Aura2API.CullableObject
  • ClearTexturesList() : Aura2API.Texture2DArrayComposer
  • ColorCircularPickerAttribute() : Aura2API.ColorCircularPickerAttribute
  • ComputeData() : Aura2API.Frustum
  • ComputeFlags() : Aura2API.FrustumSettingsToId
  • CreateGameObject() : Aura2API.AuraCamera , Aura2API.AuraLight , Aura2API.AuraSprite , Aura2API.AuraVolume

- d -

  • DirectionalShadowDataCollector() : Aura2API.DirectionalShadowDataCollector
  • Dispose() : Aura2API.CommonDataManager , Aura2API.DirectionalLightsManager , Aura2API.Frustum , Aura2API.LightsCommonDataManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager

- f -

  • Frustum() : Aura2API.Frustum

- g -

  • Generate() : Aura2API.Texture2DArrayComposer
  • GetData() : Aura2API.AuraVolume
  • GetDirectionnalParameters() : Aura2API.AuraLight
  • GetFrustumGridResolution() : Aura2API.AuraQualitySettings
  • GetKernelId() : Aura2API.FrustumSettingsToId
  • GetPointParameters() : Aura2API.AuraLight
  • GetSpotParameters() : Aura2API.AuraLight
  • GetTextureIndex() : Aura2API.Texture2DArrayComposer

- h -

  • HasFlags() : Aura2API.FrustumSettingsToId

- i -

  • Init() : Aura2API.FrustumSettingsParameters

- l -

  • LightsCommonDataManager() : Aura2API.LightsCommonDataManager
  • LoadBaseSettings() : Aura2API.FrustumSettings
  • LoadQualitySettings() : Aura2API.FrustumSettings

- p -

  • PointLightsManager() : Aura2API.PointLightsManager

- r -

  • RaiseOnQualityChanged() : Aura2API.FrustumSettings
  • RaiseTextureUpdatedEvent() : Aura2API.Texture2DArrayComposer
  • RegisterLight() : Aura2API.LightsCommonDataManager
  • RegisterVolume() : Aura2API.VolumesCommonDataManager
  • Release() : Aura2API.SwappableRenderTexture
  • ReleaseAllBuffers() : Aura2API.TextureBuffers
  • ReleaseAllLightProbesBuffers() : Aura2API.TextureBuffers
  • ReleaseLightProbesCoefficientsBuffer() : Aura2API.TextureBuffers
  • ReleaseLightProbesCoefficientsTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseOcclusionTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseSliceTextureBuffer() : Aura2API.TextureBuffers
  • ReleaseVolumeTextureBuffers() : Aura2API.TextureBuffers
  • RemoveTexture() : Aura2API.Texture2DArrayComposer
  • Resize() : Aura2API.Texture2DArrayComposer

- s -

  • SetCookieMapIndex() : Aura2API.AuraLight
  • SetDefaultValues() : Aura2API.LevelsParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • SetFrustumGridResolution() : Aura2API.AuraCamera , Aura2API.AuraQualitySettings , Aura2API.Frustum
  • SetLightProbesProxyGridResolution() : Aura2API.AuraCamera
  • SetShadowMapIndex() : Aura2API.AuraLight
  • ShadowmapsCollector() : Aura2API.ShadowmapsCollector
  • SpotLightsManager() : Aura2API.SpotLightsManager
  • Swap() : Aura2API.SwappableRenderTexture
  • SwappableRenderTexture() : Aura2API.SwappableRenderTexture

- t -

  • Texture2DArrayComposer() : Aura2API.Texture2DArrayComposer
  • Texture3DPreviewAttribute() : Aura2API.Texture3DPreviewAttribute
  • ToMatrixFloats() : Aura2API.MatrixFloats

- u -

  • Update() : Aura2API.AmbientLightingCommonDataManager , Aura2API.DirectionalLightsManager , Aura2API.LightsCommonDataManager
  • UpdateBoundingSphere() : Aura2API.CullableObject
  • UpdateData() : Aura2API.CommonDataManager

- v -

  • VolumesManager() : Aura2API.VolumesManager


Aura 2: Class Members - Variables

- _ -

  • _computeVisibleCellsComputeShader : Aura2API.Frustum
  • _frustum : Aura2API.AuraCamera
  • _frustumSettings : Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager


Aura 2: Class Members - Variables

- a -

  • a : Aura2API.MatrixFloats
  • alwaysGenerateOnUpdate : Aura2API.Texture2DArrayComposer
  • ambientInjection : Aura2API.AuraVolume
  • ambientLightingStrength : Aura2API.AuraBaseSettings
  • ambientLightingValue : Aura2API.VolumeData
  • ambientNoiseLevelsParameters : Aura2API.VolumeData
  • ambientTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • ambientTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • angularConeFade : Aura2API.VolumeGradient
  • applyBlurFilterComputeShader : Aura2API.AuraResourcesCollection
  • applyDenoisingFilterComputeShader : Aura2API.AuraResourcesCollection


Aura 2: Class Members - Variables

- b -

  • b : Aura2API.MatrixFloats
  • baseSettings : Aura2API.FrustumSettings
  • blueNoiseTextureArray : Aura2API.AuraResourcesCollection
  • boostInjection : Aura2API.AuraVolume
  • boostNoiseLevelsParameters : Aura2API.VolumeData
  • boostTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • boostTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • boostValue : Aura2API.VolumeData


Aura 2: Class Members - Variables

- c -

  • c : Aura2API.MatrixFloats
  • color : Aura2API.AuraBaseSettings , Aura2API.VolumeInjectionColorParameters
  • colorNoiseLevelsParameters : Aura2API.VolumeData
  • colorStrength : Aura2API.AuraBaseSettings
  • colorTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • colorTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • colorValue : Aura2API.VolumeData
  • computeAccumulationComputeShader : Aura2API.AuraResourcesCollection
  • computeDataComputeShader : Aura2API.AuraResourcesCollection
  • computeMaximumDepthComputeShader : Aura2API.AuraResourcesCollection
  • computeVisibleCellsComputeShader : Aura2API.AuraResourcesCollection
  • contrast : Aura2API.LevelsData , Aura2API.LevelsParameters
  • cookieMapRenderTexture : Aura2API.AuraLight
  • cookieMapSize : Aura2API.DirectionalLightsManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • customAngularFalloffPower : Aura2API.AuraLight
  • customAngularFalloffThreshold : Aura2API.AuraLight
  • customCookieDistanceFalloffEndThreshold : Aura2API.AuraLight
  • customCookieDistanceFalloffPower : Aura2API.AuraLight
  • customCookieDistanceFalloffStartThreshold : Aura2API.AuraLight
  • customDistanceFalloffPower : Aura2API.AuraLight
  • customDistanceFalloffThreshold : Aura2API.AuraLight


Aura 2: Class Members - Variables

- d -

  • d : Aura2API.MatrixFloats
  • debugOcclusionCulling : Aura2API.AuraQualitySettings
  • defaultSprite : Aura2API.AuraResourcesCollection
  • density : Aura2API.AuraBaseSettings
  • densityInjection : Aura2API.AuraVolume
  • densityNoiseLevelsParameters : Aura2API.VolumeData
  • densityTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • densityTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • densityValue : Aura2API.VolumeData
  • depthBiasCoefficient : Aura2API.AuraQualitySettings
  • displayVolumetricLightingBuffer : Aura2API.AuraQualitySettings
  • distanceConeFade : Aura2API.VolumeGradient
  • distanceSphereFade : Aura2API.VolumeGradient
  • dummyTexture : Aura2API.AuraResourcesCollection
  • dummyTexture3D : Aura2API.AuraResourcesCollection
  • dummyTextureArray : Aura2API.AuraResourcesCollection


Aura 2: Class Members - Variables

- e -

  • enable : Aura2API.DynamicNoiseParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask , Aura2API.VolumeDynamicNoiseData , Aura2API.VolumeInjectionCommonParameters
  • enableAmbientLighting : Aura2API.AuraQualitySettings
  • enableAutomaticStereoResizing : Aura2API.AuraQualitySettings
  • enableDirectionalLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableDirectionalLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableDithering : Aura2API.AuraQualitySettings
  • enableLightProbes : Aura2API.AuraQualitySettings
  • enableLightsCookies : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableOcclusionCulling : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableOutOfPhaseColor : Aura2API.AuraLight
  • enablePointLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enablePointLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableSpotLights : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableSpotLightsShadows : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableTemporalReprojection : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumes : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumesNoiseMask : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • enableVolumesTexture2DMask : Aura2API.AuraQualitySettings
  • enableVolumesTexture3DMask : Aura2API.AuraQualitySettings
  • enableVolumesTextureMask : Aura2API.FrustumSettingsParameters
  • EXPERIMENTAL_blurFilterGaussianDeviation : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_blurFilterRange : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_blurFilterType : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_denoisingFilterRange : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_enableBlurFilter : Aura2API.AuraQualitySettings
  • EXPERIMENTAL_enableDenoisingFilter : Aura2API.AuraQualitySettings
  • extinction : Aura2API.AuraBaseSettings


Aura 2: Class Members - Variables

- f -

  • fading : Aura2API.VolumeInjectionShape
  • falloffExponent : Aura2API.VolumeData , Aura2API.VolumeGradient
  • farClipPlaneDistance : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • frustumGridResolution : Aura2API.AuraQualitySettings
  • frustumSettings : Aura2API.AuraCamera


Aura 2: Class Members - Variables

- i -

  • index : Aura2API.TextureMaskData
  • injectAmbient : Aura2API.VolumeData
  • injectBoost : Aura2API.VolumeData
  • injectColor : Aura2API.VolumeData
  • injectDensity : Aura2API.VolumeData
  • injectionParameters : Aura2API.VolumeInjectionColorParameters , Aura2API.VolumeInjectionParameters
  • injectScattering : Aura2API.VolumeData
  • injectTint : Aura2API.VolumeData


Aura 2: Class Members - Variables

- l -

  • levelHiThreshold : Aura2API.LevelsData , Aura2API.LevelsParameters
  • levelLowThreshold : Aura2API.LevelsData , Aura2API.LevelsParameters
  • lightInjection : Aura2API.AuraVolume
  • lightProbesMultiplier : Aura2API.AuraVolume , Aura2API.VolumeData


Aura 2: Class Members - Variables

- n -

  • noiseData : Aura2API.VolumeData
  • noiseMask : Aura2API.AuraVolume
  • noiseMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters


Aura 2: Class Members - Variables

- o -

  • occlusionCullingAccuracy : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • outOfPhaseColor : Aura2API.AuraLight
  • outOfPhaseColorStrength : Aura2API.AuraLight
  • outputHiValue : Aura2API.LevelsData , Aura2API.LevelsParameters
  • outputLowValue : Aura2API.LevelsData , Aura2API.LevelsParameters
  • overrideColor : Aura2API.AuraLight
  • overrideScattering : Aura2API.AuraLight
  • overridingColor : Aura2API.AuraLight
  • overridingScattering : Aura2API.AuraLight


Aura 2: Class Members - Variables

- p -

  • position : Aura2API.TransformParameters
  • postProcessShader : Aura2API.AuraResourcesCollection
  • processOcclusionMapShader : Aura2API.AuraResourcesCollection


Aura 2: Class Members - Variables

- q -

  • qualitySettings : Aura2API.FrustumSettings


Aura 2: Class Members - Variables

- r -

  • renderLightProbesTextureComputeShader : Aura2API.AuraResourcesCollection
  • resolution : Aura2API.FrustumSettingsParameters
  • rotation : Aura2API.TransformParameters


Aura 2: Class Members - Variables

- s -

  • saturateOutputValues : Aura2API.LevelsParameters
  • scale : Aura2API.TransformParameters
  • scattering : Aura2API.AuraBaseSettings
  • scatteringBias : Aura2API.AuraLight
  • scatteringInjection : Aura2API.AuraVolume
  • scatteringNoiseLevelsParameters : Aura2API.VolumeData
  • scatteringTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • scatteringTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • scatteringValue : Aura2API.VolumeData
  • shadowDataRenderTexture : Aura2API.AuraLight
  • shadowMapRenderTexture : Aura2API.AuraLight
  • shadowMapSize : Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • shape : Aura2API.VolumeData , Aura2API.VolumeInjectionShape
  • showField : Aura2API.Texture3DPreviewAttribute
  • showLabel : Aura2API.ColorCircularPickerAttribute
  • space : Aura2API.TransformParameters
  • speed : Aura2API.DynamicNoiseParameters , Aura2API.VolumeDynamicNoiseData
  • spriteLitShader : Aura2API.AuraResourcesCollection
  • spriteUnlitShader : Aura2API.AuraResourcesCollection
  • storeDirectionalShadowDataShader : Aura2API.AuraResourcesCollection
  • storeDirectionalSpotCookieMapShader : Aura2API.AuraResourcesCollection
  • storePointCookieMapShader : Aura2API.AuraResourcesCollection
  • storePointShadowMapMesh : Aura2API.AuraResourcesCollection
  • storePointShadowMapShader : Aura2API.AuraResourcesCollection
  • strength : Aura2API.AuraLight , Aura2API.VolumeInjectionCommonParameters


Aura 2: Class Members - Variables

- t -

  • temporalReprojectionFactor : Aura2API.AuraQualitySettings , Aura2API.FrustumSettingsParameters
  • texture : Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • texture2DMask : Aura2API.AuraVolume
  • texture2DMaskData : Aura2API.VolumeData
  • texture2DMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters
  • texture2DMaskSize : Aura2API.VolumesCommonDataManager
  • texture3DFiltering : Aura2API.AuraQualitySettings
  • texture3DMask : Aura2API.AuraVolume
  • texture3DMaskData : Aura2API.VolumeData
  • texture3DMaskLevelParameters : Aura2API.VolumeInjectionCommonParameters
  • texture3DMaskSize : Aura2API.VolumesCommonDataManager
  • textureIndex : Aura2API.Texture2DMask , Aura2API.Texture3DMask
  • tint : Aura2API.AuraBaseSettings
  • tintColor : Aura2API.VolumeData
  • tintInjection : Aura2API.AuraVolume
  • tintNoiseLevelsParameters : Aura2API.VolumeData
  • tintStrength : Aura2API.AuraBaseSettings
  • tintTexture2DMaskLevelsParameters : Aura2API.VolumeData
  • tintTexture3DMaskLevelsParameters : Aura2API.VolumeData
  • transform : Aura2API.DynamicNoiseParameters , Aura2API.Texture2DMask , Aura2API.Texture3DMask , Aura2API.TextureMaskData , Aura2API.VolumeData , Aura2API.VolumeDynamicNoiseData


Aura 2: Class Members - Variables

- u -

  • useAmbientLighting : Aura2API.AuraBaseSettings
  • useAsLightProbesProxyVolume : Aura2API.AuraVolume , Aura2API.VolumeData
  • useColor : Aura2API.AuraBaseSettings
  • useColorTemperatureTint : Aura2API.AuraLight
  • useCookie : Aura2API.AuraLight
  • useDensity : Aura2API.AuraBaseSettings
  • useExtinction : Aura2API.AuraBaseSettings
  • useNoiseMask : Aura2API.VolumeInjectionCommonParameters
  • useNoiseMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useScattering : Aura2API.AuraBaseSettings , Aura2API.AuraLight
  • useShadow : Aura2API.AuraLight
  • useTexture2DMask : Aura2API.VolumeInjectionCommonParameters
  • useTexture2DMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useTexture3DMask : Aura2API.VolumeInjectionCommonParameters
  • useTexture3DMaskLevels : Aura2API.VolumeInjectionCommonParameters
  • useTint : Aura2API.AuraBaseSettings


Aura 2: Class Members - Variables

- v -

  • volumeShape : Aura2API.AuraVolume


Aura 2: Class Members - Variables

- w -

  • widthCylinderFade : Aura2API.VolumeGradient


Aura 2: Class Members - Variables

- x -

  • xNegativeCubeFade : Aura2API.VolumeGradient
  • xNegativeFade : Aura2API.VolumeData
  • xPositiveCubeFade : Aura2API.VolumeGradient
  • xPositiveFade : Aura2API.VolumeData


Aura 2: Class Members - Variables

- y -

  • yNegativeCubeFade : Aura2API.VolumeGradient
  • yNegativeCylinderFade : Aura2API.VolumeGradient
  • yNegativeFade : Aura2API.VolumeData
  • yPositiveCubeFade : Aura2API.VolumeGradient
  • yPositiveCylinderFade : Aura2API.VolumeGradient
  • yPositiveFade : Aura2API.VolumeData


Aura 2: Class Members - Variables

- z -

  • zNegativeCubeFade : Aura2API.VolumeGradient
  • zNegativeFade : Aura2API.VolumeData
  • zPositiveCubeFade : Aura2API.VolumeGradient
  • zPositiveFade : Aura2API.VolumeData


Aura 2: Class Members - Properties

- a -

  • AmbientLightingCommonDataManager : Aura2API.CommonDataManager

- b -

  • BaseSettings : Aura2API.FrustumSettings
  • BoundingSphere : Aura2API.CullableObject
  • Bounds : Aura2API.AuraVolume
  • Buffer : Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager

- c -

  • CameraComponent : Aura2API.AuraCamera
  • CandidateLights : Aura2API.DirectionalLightsManager
  • CandidateLightsCount : Aura2API.DirectionalLightsManager
  • CastsCookie : Aura2API.AuraLight
  • CastsShadows : Aura2API.AuraLight
  • Coefficients : Aura2API.AmbientLightingCommonDataManager
  • CommonDataManager : Aura2API.AuraCamera

- d -

  • Data : Aura2API.LevelsParameters
  • DataBuffer : Aura2API.DirectionalLightsManager
  • DataVolumeTexture : Aura2API.TextureBuffers
  • Default : Aura2API.LevelsParameters
  • DeltaTtime : Aura2API.AuraCamera
  • DirectionalCookieMapsArray : Aura2API.LightsCommonDataManager
  • DirectionalLightsManager : Aura2API.LightsCommonDataManager
  • DirectionalShadowDataArray : Aura2API.LightsCommonDataManager
  • DirectionalShadowMapsArray : Aura2API.LightsCommonDataManager

- e -

  • EmptyBuffer : Aura2API.DirectionalLightsManager , Aura2API.PointLightsManager , Aura2API.SpotLightsManager , Aura2API.VolumesManager

- f -

  • FogVolumeTexture : Aura2API.TextureBuffers
  • FrameId : Aura2API.AuraCamera

- g -

  • GlobalStrength : Aura2API.AmbientLightingCommonDataManager

- h -

  • HasCandidateLights : Aura2API.DirectionalLightsManager
  • HasDirectionalCookieCasters : Aura2API.LightsCommonDataManager
  • HasDirectionalShadowCasters : Aura2API.LightsCommonDataManager
  • HasPointCookieCasters : Aura2API.LightsCommonDataManager
  • HasPointShadowCasters : Aura2API.LightsCommonDataManager
  • HasRegisteredDirectionalLights : Aura2API.LightsCommonDataManager
  • HasRegisteredLightProbesProxyVolumes : Aura2API.VolumesCommonDataManager
  • HasRegisteredPointLights : Aura2API.LightsCommonDataManager
  • HasRegisteredSpotLights : Aura2API.LightsCommonDataManager
  • HasRegisteredVolumes : Aura2API.VolumesCommonDataManager
  • HasSpotCookieCasters : Aura2API.LightsCommonDataManager
  • HasSpotShadowCasters : Aura2API.LightsCommonDataManager
  • HasTexture : Aura2API.Texture2DArrayComposer
  • HasTexture2DMasks : Aura2API.VolumesCommonDataManager
  • HasTexture3DMasks : Aura2API.VolumesCommonDataManager
  • HasVisibleLights : Aura2API.PointLightsManager , Aura2API.SpotLightsManager
  • HasVisibleVolumes : Aura2API.VolumesManager

- i -

  • IsInitialized : Aura2API.AuraCamera

- l -

  • LightComponent : Aura2API.AuraLight
  • LightProbesCoefficients : Aura2API.TextureBuffers
  • LightProbesCoefficientsComputeBuffer : Aura2API.TextureBuffers
  • LightProbesCoefficientsTexture : Aura2API.TextureBuffers
  • LightProbesCoefficientsTextureResolution : Aura2API.TextureBuffers
  • LightProbesCoefficientsTextureResolutionIsValid : Aura2API.TextureBuffers
  • LightsCommonDataManager : Aura2API.CommonDataManager

- m -

  • Matrix : Aura2API.TransformParameters

- n -

  • NeedsToUpdateTexture : Aura2API.Texture2DArrayComposer

- o -

  • OcclusionTexture : Aura2API.TextureBuffers
  • One : Aura2API.LevelsParameters

- p -

  • PointCookieMapsArray : Aura2API.LightsCommonDataManager
  • PointShadowMapsArray : Aura2API.LightsCommonDataManager

- q -

  • QualitySettings : Aura2API.FrustumSettings

- r -

  • ReadBuffer : Aura2API.SwappableRenderTexture
  • RegisteredDirectionalLightsList : Aura2API.LightsCommonDataManager
  • RegisteredLightProbesProxyVolumesList : Aura2API.VolumesCommonDataManager
  • RegisteredPointLightsList : Aura2API.LightsCommonDataManager
  • RegisteredSpotLightsList : Aura2API.LightsCommonDataManager
  • RegisteredVolumesList : Aura2API.VolumesCommonDataManager
  • RequiredSizeX : Aura2API.Texture2DArrayComposer
  • RequiredSizeY : Aura2API.Texture2DArrayComposer

- s -

  • ShadowMapSize : Aura2API.DirectionalLightsManager
  • ShoukdComputeTexture2DMasking : Aura2API.AuraVolume
  • ShouldComputeNoise : Aura2API.AuraVolume
  • ShouldComputeTexture3DMasking : Aura2API.AuraVolume
  • Size : Aura2API.DirectionalLightParameters , Aura2API.LevelsData , Aura2API.MatrixFloats , Aura2API.PointLightParameters , Aura2API.SphericalHarmonicsCoefficients , Aura2API.SphericalHarmonicsFirstBandCoefficients , Aura2API.SpotLightParameters , Aura2API.TextureMaskData , Aura2API.VisibleCellData , Aura2API.VolumeData , Aura2API.VolumeDynamicNoiseData
  • SliceTexture : Aura2API.TextureBuffers
  • SpotCookieMapsArray : Aura2API.LightsCommonDataManager
  • SpotShadowMapsArray : Aura2API.LightsCommonDataManager

- t -

  • Texture : Aura2API.Texture2DArrayComposer
  • Texture2DMasksAtlas : Aura2API.VolumesCommonDataManager
  • Texture3DMasksAtlas : Aura2API.VolumesCommonDataManager
  • TextureCount : Aura2API.Texture2DArrayComposer
  • Time : Aura2API.AuraCamera
  • Type : Aura2API.AuraLight

- u -

  • UsesTexture2DMasking : Aura2API.AuraVolume
  • UsesTexture3DMasking : Aura2API.AuraVolume

- v -

  • VolumesCommonDataManager : Aura2API.CommonDataManager
  • VolumetricBuffersResolution : Aura2API.TextureBuffers
  • VolumetricBuffersResolutionIsValid : Aura2API.TextureBuffers

- w -

  • WriteBuffer : Aura2API.SwappableRenderTexture

- z -

  • Zero : Aura2API.LevelsParameters


Aura 2: Class Members - Events

  • OnCascadesCountChanged : Aura2API.LightsCommonDataManager
  • OnFrustumQualityChanged : Aura2API.FrustumSettings
  • OnRegisterPointLight : Aura2API.LightsCommonDataManager
  • OnRegisterSpotLight : Aura2API.LightsCommonDataManager
  • OnRegisterVolume : Aura2API.VolumesCommonDataManager
  • OnUninitialize : Aura2API.AuraLight , Aura2API.AuraVolume
  • OnUnregisterPointLight : Aura2API.LightsCommonDataManager
  • OnUnregisterSpotLight : Aura2API.LightsCommonDataManager
  • OnUnregisterVolume : Aura2API.VolumesCommonDataManager


Aura 2: Classes Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Classes
Classes Directory Reference


Aura 2: Attributes Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Attributes
Attributes Directory Reference


Aura 2: Structs Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Structs
Structs Directory Reference


Aura 2: Extensions Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Extensions
Extensions Directory Reference

Directories

Generated by doxygen 1.8.14


Aura 2: Core Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
Core Directory Reference


Aura 2: Helpers Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Helpers
Helpers Directory Reference


Aura 2: Enums Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Enums
Enums Directory Reference


Aura 2: Statics Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Statics
Statics Directory Reference


Aura 2: Aura2 Directory Reference

  • UnityProject
  • Aura2
Aura2 Directory Reference


Aura 2: UnityProject Directory Reference

  • UnityProject
UnityProject Directory Reference


Aura 2: Assets Directory Reference

  • UnityProject
  • Aura2
  • Assets
Assets Directory Reference


Aura 2: Aura 2 Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
Aura 2 Directory Reference


Aura 2: Code Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
Code Directory Reference

Directories

Generated by doxygen 1.8.14


Aura 2: Gaia Directory Reference

  • UnityProject
  • Aura2
  • Assets
  • Aura 2
  • Core
  • Code
  • Extensions
  • Gaia
Gaia Directory Reference


Aura 2: Main Page

Aura 2 Documentation